The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Build Your Own PC

Wireless Card Problems

(4 posts)
  • Started 7 years ago by medley56
  • Latest reply from raphoenix
  • Topic Viewed 1462 times

Posts: 22


I recently built a machine of the following components for reference:

Motherboard: AsRock P55 Extreme
CPU: Intel 2.66GHz Core i5
RAM: 2x2 Gb G Skill DDR3 1600
Graphics Card: EVGA GeForce 9800 GTX+
Power Supply: Antec TruePower New 750W
Wireless Card: Edimax 7128g
OS: Windows 7

So, the problem is this:
Everything seems to be working fine except for the wireless card. (First off, I want to mention, I have tried this card in a friend's machine and it worked fine there.) There is a green and a yellow light on the card and initially (when I first built the machine), both lights would come on and I could connect to the internet. Now, the green light has ceased to light up on startup and the wireless card can find networks but cannot connect to them. I first thought there was an error on my motherboard's "Dr. Debug" display (AA), but it turns out that is not an error at all according to the AsRock support team <>. Now I am at a loss. I have RMAd the card and have the same problem, I have completely rebuilt the machine 3 times now in search of this problem, now I am looking for anything that might point to the problem and a way of fixing it.

Please help,


PS. Here is a link to the discussion about the motherboard error AA in case someone thinks this is indeed a problem.


Posted 7 years ago
Posts: 3281

Gavin, hi. Not sure about this one. What OS was your friends pc running? Have you updated any drivers or settings or installed anything that might conflict with your wireless card?

Posted 7 years ago
Posts: 22

Thanks for your response ProstheticHead.

That's a good question now that I think about it. My friend was running Vista; I am running 7. Maybe that has something to do with it. Actually, new developments: I updated the mobo bios to the latest version just to see if that would change anything. Along with that I updated some other drivers, including the one for the wireless card. Nothing seemed to change.

Then I was looking at the statistics provided by the RALink utility that came with the wireless card. It produced some interesting numbers:

Frames Transmitted Successfully = 0
Frames Retransmitted Successfully = 0
Frames Fail To Receive ACK After All Retries = 220 (I honestly don't know what this means but I think it is significant?)

Frames Received Successfully = 4271
Frames Received with CRC Error = 1276 (This number dropped significantly after I pulled the battery out of my cordless phone)
Frames Dropped Due to Out-of-Resource = 0
Duplicate Frames Received = 0

So, anyway, anyone who has a suggestion for fixing this, please respond.


Posted 7 years ago
Posts: 14920


Believe we discussed your issue on this Topic Thread.

Best Regards,
Rick P.

Posted 7 years ago

Topic Closed

This topic has been closed to new replies.