The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 8

Windows 8 Install.wim read-only?

(2 posts)
  • Started 5 years ago by SlyCooperFan1
  • Latest reply from raphoenix
  • Topic Viewed 2344 times

Posts: 1

Hello How-To Geek forums! I'm new to the site and to the forums, so excuse me if I act like a noob in any way, shape, or form. :P

I've been following directions on using a Virtual Hard Drive to run Windows 8 on my computer without re-partitioning my existing hard drive from the following article here on How-To Geek: How to Dual Boot Windows 7 and 8 Without Re-Partitioning (Using VHD)

However, I have run into a brick wall, as one or two others have in the comments section of that article. When I type the following command into the Shell Window, ".\Install-WindowsImage.ps1 –WIM J:\Sources\Install.wim –Apply –Index 1 –Destination I:\" (replacing the letters with corresponding drives on my system), I get an error from Windows PowerShell telling me that install.wim cannot be read or written to. (I'll take a screenshot of the error if someone needs it.) I thought this was because I had been using Virtual CloneDrive to mount the .ISO, so I switched to MagicDisc; however, I received the same result.

I've found the culprit to be a stupid problem: the install.wim file, along with every other file in the .ISO, is read-only. So, while I facepalmed myself, I disabled the read-only attribute on install.wim. But that didn't work, because for some reason I wasn't allowed to. I tried to Take Ownership of the file, but I got the same result.

I know what the problem is - every file on the .ISO file is read-only - but I don't have a solution. Help, please? D:

Posted 5 years ago
Posts: 14920

Try this method with old DiskPart Commands.

There are plenty of ways to create a VHD so don't be dismayed.

F12 is F8 on a some Asus Machines

Rick P.

Posted 5 years ago

Topic Closed

This topic has been closed to new replies.