The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows 7

(Solved) - WINDOWS 7 SHUTS DOWN SLOW......

(14 posts)
  • Started 8 years ago by junjuramesh
  • Latest reply from vistamike
  • Topic Viewed 10132 times

junjuramesh
Posts: 0

Hi,
I am using windows 7 ultimate. I am using NOrton 360 on my PC. It's startup is very fine, less than a minute, performance is good, Not having any virus at all (fully protected and updated). But it is taking long time to shut down, more than 3 minutes. I googled for the solution to quick shut down the PC. I followed the methods given.
1. By enabling the "turn off automatic termination of applications that block or cancel shut down" in group policy editor.

2.By chnaging the registy value of "wait to kill service timeout" from 12000 to 3000 in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control.

3.Defragment the disk.( ofcourse NORTON 360 done that.)

I followed the three steps given above, but didn't get the result. It is taking long time to shutdown.

Can anyone suggest me with a solution to quick shutdown of PC ?

Thanking you..

Posted 8 years ago
Top
 
germ-x
Posts: 0

hi junjuramesh,
There are several reasons for a slow shutdown but before getting into some of the causes need more info.
How long has this been a problem?
Did this start after you installed Norton 360?
Have you installed any new software when this started happening?

Please post back

Posted 8 years ago
Top
 
JonMCC33
Posts: 0

Don't bother with a defrag. That has nothing to do with hard drive performance.
Uninstall Norton 360 and install Microsoft Security Essentials: http://www.microsoft.com/Security_Essentials/

Posted 8 years ago
Top
 
jessej07
Posts: 0

Since you have Norton 360, it's likely you paid your hard earned cash for it- use it for the duration of your subscription, don't uninstall it.

While I can't think of any practical tips for you at the moment I can tell you that I ran Vista with Norton 360 for over a year and it performed just fine. If the slowdown is caused by Norton, I would try a reinstall of it before just giving up on it.

Can you go into your task manager (right click on your task bar) and look at the processes that are currently running? Look around there for anything that looks suspicious.

You can try a free scan of PC Pitstop Optimize (DL link on the right of page). It will tell you what programs run at start up- these may be running in the background during shut down.

Posted 8 years ago
Top
 
marks100
Posts: 0

try this works ok http://www.sevenforums.com/tut.....html?ltr=R :)

Posted 8 years ago
Top
 
ispalten
Posts: 0

The 'answer' could be in your Event Viewer... check this link out for DETAILS, although for Vista, it should still work and possibly lead to clues why?

A device or program timeout, or waiting for a response that never comes could be the culprit.

Irv S.

Posted 8 years ago
Top
 
junjuramesh
Posts: 0

Ispalten, I have followed the link given and have seen the error message and warning messages about shutdown performance monitoring. I couldn't understand how to overcome this problem by google the event. Here I am giving snap of the event viewer and the properties of the event.

Can you please assist me to move further...

Thanking you.

Posted 8 years ago
Top
 
ispalten
Posts: 0

Uh, do you see the shutdown time there? 37 seconds... that is the SYSTEM SHUTDOWN... if it exceeds 10 seconds I think that is when you get the error entry. I have hardly any 200 errors, mostly boot 100's. The few I do have show 15 to 20 seconds...

THIS IS NOT your problem.

You have a TASK or PROCESS running that is NOT closing either due to an error or waiting for a timeout.

This is, to me, tricky to determine the cause. It can be done though.

First, boot into SAFE MODE and see how it shuts down. Faster that real mode, it would then be a problem with a driver or the network.

Secondly, open MSCONFIG and DISABLE all non-MS entries on the STARTUP tab. Again see how it shuts down...

If all the above still takes a long time, boot as above with non-MS items disabled. Now open Task Manager. Start killing processes (NOT EXPLORER) a few at a time and shut down. Still slow, repeat with others killed. Fast, it was one of the ones you killed. Cut those killed in half (do 6 or so at a time to speed the process up of determining 'who') and try again.

Report back results... but if you know what the file that is causing the problem, and its web site should have later files for it, try using them.

Irv S.

Posted 8 years ago
Top
 
junjuramesh
Posts: 0

Hi spalten, I booted into safe mode, it is taking long time as before. And I done a clean boot by disabling the Non-MS entries. Still the problem exists.
Thirdly I ended some of the process listed in the task manager, and I noticed the shutdown time in the event viewer, it is 33 seconds. I am not able to kill the process csrss.exe and winlogon.exe in normal mode, Access denied. I am giving the images of processess in safe mode and in normal startup respectively.

Posted 8 years ago
Top
 
ispalten
Posts: 0

Nothing there I don't know as 'normal'. The IGFXSRVC.EXE is Intel's video driver file, and of course the A/V, all the rest are Windows files.

DWM is also a windows function.

I guess I'd next try exiting my A/V and then doing a shutdown and see what happens?

Might also want to look at SYSINTERNALS (http://technet.microsoft.com/e.....95533.aspx and get Process Explorer and Process Monitor... try keeping them open (run one at a time) and see if during shutdown if something 'hangs'. It may be futile if they exit first though? I have not tried this so don't know if it will work?

Next step is to go to SERVICES and turn off running one... First the non-MS ones, see what happens...

All we really know at this point is that the true MS shutdown is not the problem.

Irv S.

Posted 8 years ago
Top
 
Bartman
Posts: 0

Do you have Norton and Kaspersky installed? I see an entry for Kaspersky in your Task Manager screenshot.
You could be getting a conflict between the two.

Posted 8 years ago
Top
 
junjuramesh
Posts: 0

No bartman I changed to Kaspersky after the problem occurs. The screenshot that I have displayed there is after the fouth week of occuring the problem.

Posted 8 years ago
Top
 
junjuramesh
Posts: 0

Thanks for ur suggestions mates. Finally I found the solution for my problem by making some tweaks to my registry.

What you want to do is go to the registry and change a couple values. Open the registry and locate the key{ \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management}, then change the value of ClearPageFile at Shutdown to a 0 IF the value is 1. If the value is 1, it will take longer for your computer to shutdown..this fix cured it all for me.

Thanks very much for sharing your time to solve my problem.

Accepted Answer · Posted 8 years ago
Top
 
vistamike
Posts: 0

That's great and thank you for letting us know how you solved it,

Mike

Posted 8 years ago
Top
 



Topic Closed

This topic has been closed to new replies.