The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Apple / OS X

wifi issues with new Ipad and wpa-enterprise

(5 posts)
  • Started 5 years ago by gferri
  • Latest reply from minnitianto
  • Topic Viewed 5622 times

Posts: 2

Hi everyone,
my name is Gabriele, and I have a lot of problems with my new ipad's wifi. My university tech staff is baffled, I've opened a bug report at Apple ( ) but I'll also paste here my issue hoping that someone may be able to help me.
I'm an experienced linux user, this is my first experience with apple, and so far I'm kinda disappointed.. the ipad is great, but not being able to connect to a wpa-enterprise network is a huge issue for me....

When I try to use my campus WPA-enterprise wifi network, the iPad (3rd gen., ios 5.1) connects successfully accepting a security certificate, then data is exchanged for 2 seconds (enough to load half a web page), then no more data is sent/received. Safari and other apps just time out.
It happens only on that particular network (my new iPad works perfectly on other networks - open, wep, and wpa2-personal). A different iPad (2nd gen., ios 5.1) works perfectly on that problematic wpa-enterprise network using the same username/password and the same setup.

Steps to Reproduce:
- Use a "new iPad" (3rd gen. wifi only, ios 5.1 9B176, model MC705TY, s/n DLXH6LM8DJ8T)
- Join a wifi network with the following specifications:
Network Name (SSID) ALMAWIFI
Security Type WPA-Enterprise
Data Encryption Type TKIP (Temporal Key Integrity Protocol)
Authentication Method Protected EAP (PEAP), EAP-MSCHAP v2
Server Certificate Validation required YES
Certification Authority thawte Primary Root CA
Authentication Server
((see full specifications at ))
- The iPad appears to connect correctly (ip address and DNS are correctly assigned by dhcp),
- data is exchanged with the access point for a few seconds, then stops,
- wifi is still connected but no data is exchanged.

(Username and password are correct. A different iPad 2nd gen, ios 5.1, works perfectly in the same physical place with the same username and password.)
(I have tried the solution detailed here - creating a profile with the iphone configuration utility, without improving the situation)
(It is not this issue as my certificate is not signed with md5)
(I have tried to reboot the device, and to wipe all the networking configuration on the ipad)

Expected Results:
To be able to actually send/receive data on the wpa-enterprise wifi network

Actual Results:
Wifi is connected, data in exchanged for 2 seconds then it stops and never resumes


All the technical information on the wifi network I cannot use is here (also in English, on the right side)

Posted 5 years ago
Posts: 6259

Well, first are you sure that the signal is the 2.4GHZ band and not the 5GHZ? If 5GHZ, it might connect for a short period and then drop?

One thing to try, reset your network settings using Settings > General > Reset > Reset Network Settings. That will wipe out the settings and you can start fresh. Re-boot (completely power off the iPad) to make sure it starts 'fresh'.

I read the English document and it appears WPA Personal is also available. Does this work?

In the US we have a phone number to call Apple and they call you back. If you can do this I suggest you call them if the above doesn't work? I have both an iPad2 and the 'New' iPad and the wi-fi appears to be identical to me, both in connection capability and speed of the connection. You may have a broken iPad?

Irv S.

Posted 5 years ago
Posts: 2

Hi ispalten,
first of all, thanks a lot for the reply :-)

The GHZ band tip may be a good idea. I'll definitely look into that and then report.
If that's the case, is there a way to force the ipad to select a certain frequency when several are available?

I'd say that the ipad isn't broken, as it works flawlessly with every other network. That's the thing that baffles me...


Posted 5 years ago
Posts: 6259

iPad's are 2.4GHZ N only (will work on lower speeds, G for instance). I'd be surprised if the signal is on the 5GHZ band, most that send that signal also do 2.4GHZ.

Irv S.

Posted 5 years ago
Posts: 1

Dear Gabriele,

I have the same problem as you with the ALMAWIFI connection and Ipad3. Do you have any news?


Posted 5 years ago

Topic Closed

This topic has been closed to new replies.