The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows XP

(Solved) - USB mouse not working

(39 posts)
  • Started 4 years ago by Needhelpbro
  • Latest reply from Lighthouse
  • Topic Viewed 14620 times

Needhelpbro
Posts: 105

I have a USB mouse, every time I insert it into the USB port is says it is downloading, the laser turns on, and it says it is ready to use. BUT it does not work.

Please ask for any info needed. *NOTE* It USED to work, now it does not.

[EDIT] It is a wired Synpatics(Or whatever) mouse.

I have learned that keyboards AND a different mouse do not work! I will start a new thread.

Posted 4 years ago
Top
 
Lighthouse
Posts: 13598

Is it wired ?

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

Yes.

Posted 4 years ago
Top
 
Lighthouse
Posts: 13598

Try another mouse.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

....Really... OK how about this, It USED to work now it does not.

Posted 4 years ago
Top
 
Lighthouse
Posts: 13598

Try it on another computer then.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

NEW thread going to happen.

Posted 4 years ago
Top
 
Lighthouse
Posts: 13598

Why ?

Posted 4 years ago
Top
 
Xhi
Posts: 6298

I have many things that used to work and now they don't. You need to rule out the possibility that it is broken. Try it on a different computer as LH suggests. Try a different mouse on this computer. That is the standard way to research this type of problem.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

When have I been warned?

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

Also, I will try to.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

[NEWS] The mice and keyboards work on another computer.

[EDIT] Yes, I keep forgetting about the edit post thing. Also, anything to comment on the news?

Anybody answer?

Posted 4 years ago
Top
 
Xhi
Posts: 6298

@Needhelpbro: You can edit a post up to 30 minutes from the original posting. Please do not make unnecessary multiple posts. Just click on the edit button.

Posted 4 years ago
Top
 
germ-x
Posts: 5310

If your talking about your wired mouse and saying it use to work, have you tried reinstalling the software?

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

Yes I have, I uninstalled the drivers and it. I let in re-install. NOTHING happens. I am not sure why or how.

Posted 4 years ago
Top
 
ronniesonora
Posts: 919

Open "device manager" and see if you have a yellow exclamation point by "mice and other pointing devices."

Posted 4 years ago
Top
 
ProstheticHead
Posts: 3281

Do they work if you boot into safe mode?

Are there any 'known bad' USB ports on your computer?

If your computer has USB ports on the front of the case, try plugging them in there too.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

I have two side USB's. I will try the safe mode in a minute or two.

Above more, I have no problems according to it.

[EDIT] I tried it in safe mode (all 3 of them) and nothing worked.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

Anyone have any solutions?

Posted 4 years ago
Top
 
G41M
Posts: 902

Are other usb devices such as flash drive, etc. works (detected) when plugged into the usb port?

Posted 4 years ago
Top
 
ronniesonora
Posts: 919

This is a long shot! Open "device manager" go down to "universal serial bus controllers" click on "+" sign then go to "usb root hub" and double click it. When the window opens click on the "power management tab" if the box "allow the computer to turn off this device to save power" is checked, uncheck it. Make sure you look at all usb root hubs.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

@Two above, yes it does detect USB drives. @Ronnie, I will try that.

[EDIT] I have 4 root hubs and two USB slots. Is that good?

Posted 4 years ago
Top
 
G41M
Posts: 902

Go to Control Panel > Administrative Tools >Services. Check "Human Interface Device Access" service is not disabled.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

@G4, I do not even have that service.

Posted 4 years ago
Top
 
ronniesonora
Posts: 919

Needhelpbro, did you also check your mouse in device manager in power management tab?

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

Let me check.

[EDIT] The mouse does not have that tab.

Posted 4 years ago
Top
 
ronniesonora
Posts: 919

You said you didn't have Human Interface Device Access. So try downloading is here http://download.cnet.com/USB-H.....48615.html
Read this http://en.wikipedia.org/wiki/H.....ace_device

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

@Ronnie... Thanks alot it just installed a bunch of free loading CRAP on my computer! Not one thing to do with HIDA! Now I gotta do a restore.

Posted 4 years ago
Top
 
G41M
Posts: 902

Open an elevated command prompt and type "sfc /scannow" (no quotes) to check and fix system files that maybe missing or corrupted.

Posted 4 years ago
Top
 
nosparks
Posts: 148

Needhelpbro, do you have the same USB mouse problem if you boot the computer from a Live Linux cd?

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

I do not have a "Live Linux CD"

Posted 4 years ago
Top
 
ProstheticHead
Posts: 3281

Download
http://www.ubuntu.com/
Burn to a CD or DVD with this
http://www.imgburn.com/

Posted 4 years ago
Top
 
ronniesonora
Posts: 919

Did you try any of the last 3 or 4 posts?

Posted 4 years ago
Top
 
nosparks
Posts: 148

For Live Linux the easy way on USB stick:

Download Slax zip for USB from http://www.slax.org/download.php

Read here http://www.slax.org/documentation.php how to unzip it to your USB stick and then run the bootinst.bat file in the /slax/boot/ directory to make it bootable.

That's it. Stick will only have about 254 meg used.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

@Ronnie, I have tried some. Now I have to re-install my computer because that thing you made me download I think it gave me viruses. So re install might fix it anyways. Thanks for all of your help even if it was nothing.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

NEWS: I tried that linux thing and my mouse worked on it, so I am going to re download my computer.

Posted 4 years ago
Top
 
nosparks
Posts: 148

That's the beauty of Live Linux. It takes your Windows software out of the picture and allows (most of the time) verification of the hardware. There's been alot of new computers sold because people equate Windows problems as being the fault of the hardware.

Posted 4 years ago
Top
 
Needhelpbro
Posts: 105

I reinstalled XP, it works now.

Posted 4 years ago
Top
 
Lighthouse
Posts: 13598

Well there you go. Always a good thing to do :)

Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.