The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows Vista

(Solved) - Update not working after SP2 install

(6 posts)
  • Started 9 years ago by aweysham
  • Latest reply from aweysham
  • Topic Viewed 1096 times

aweysham
Posts: 0

I installed Vista SP2 successfully (or so I thought). All seems to be working fine except now Windows update does not work. I get a blank window , no text. Same for "turn off/on auto updating", just blank window. If I change I get message, "Security Center can't change your automatic updating setting, select manual", then I get the blank window.
If I select "view installed updates" I get the complete list. Seems this happened after installing Vista SP2
Im running Vista Business on a ASUS U6S, 3 gig ram, T9300 2.5GHz, Norton INternet Security 2009
No other problems. I keep the computer clean, defragged regularly.

Posted 9 years ago
Top
 
ScottW
Posts: 0

aweysham, hello. That is not a good sign -- SP2 is supposed to make Vista more reliable, not more flaky. You should consider uninstalling SP2 as described in this KB article.

When I look through the list of changes in SP2, I don't see anything that I would suspect of causing problems with Windows Update or window draw routines. It suggests to me that there is some other factor at work in your Vista install.

Posted 9 years ago
Top
 
aweysham
Posts: 0

Thanks for that Scott, I was hoping not to get that suggestion. I got another suggestion from another forum and suggested I needed to registger 3 different dll. did that but the last one created another error like, " dllrergisterserver entry point was not found". I'll keep trying and if no good will go the remove SP2 route. I read several people having trouble before SP2 formally released but I installed it after it was available on Win Update.

Posted 9 years ago
Top
 
LH
Posts: 0

aweysham. I found SP2RC 100% reliable, and faster than SP2. To the extent, I may change back soon.
(I shall wait and see what happens with the next round of updates first tho)

Posted 9 years ago
Top
 
aweysham
Posts: 0

I updated to SP2 when it became available via Win Update. I purposely cleaned my drive, defragged and scanned. then loaded SP2. I heard there was a HD gain. I did, I gained 37gig space all on C, lost a bit on D though ??

now Win Update does not work. I tried several suggestions offered by others to no avail. I am in email correspndenc with a MS Support tech. he has given me several steps to do and I've done them all to no avail. still the same. One suggestion from another tech on Vista Club gave me this site:
http://www.winvistaclub.com/t164.html
I followed those instructions since my update window was exactly as shown on the site. I registered the first two dll OK but the third brings up a message:
"module mshtml loaded but entry point DLLRegister was not found.
I researched that on the net seems there are lots of progblems there.
I've tried the System File Checker which show error, sent that screen shot to MS tech, instructed to boot in safe mode
computer would not do that so researched that and got the answer right here, use msconfig
did that and ran SFC again, same error.
then ran "fsutil resource setautoreset true c:\", that was successful but still Win update not working.
also from another suggestion I reset Internet Explorer as that was suggested as the cause, still no good.

Computer is working fine except that update. would be nice if MS would install some elements of Windows as separate programs that could be uninstalled and then reinstalled. I suggested that in my answer to "Was this Helpful".

I'll keep you guys posted if I have any luck. Meanwhile Im willing to try some suggestions.
Andy

Posted 9 years ago
Top
 
aweysham
Posts: 0

Solved for now. My solution:
I had suggestions that Norton Internet Security was the problem. Researched that on the net. Disabled NIS 09' temporarily to no avail. Finally decided to uninstall SP2 (as per ScottW suggestion, thanks). Problem cleared up immediately. Win Update works. Now that Update works it does not list SP2 as an update as it did before. Strange?? Now it list "System Update Readiness Tool" only. From now on I will keep a very good log of what I install and when.

Now some may say SP2 is more important than NIS. Not for me. I love NIS and what it does for me. I've been using Vista with SP1 for long time and have all the initial bugs worked out of Vista thanks to lots of help and hacks from people like on this and other forums. Lots of very smart people out there. So I'll stick with SP1 and NIS 09'. I'll continue to research the problem though. I kept SP2 for Office and MS Projects. Regards the hd space gained, yes I gained 37g when installed SP2 and still have a gain of 21g after uninstall SP2.

Many thanks to all who gave me their suggestions. Very much appreciated.

Posted 9 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

The Best Tech Newsletter Anywhere

Join 250,000 subscribers and get a daily digest of news, geek trivia, and our feature articles.