The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows Vista

(Solved) Trying to get Oblivion to work on Vista

(25 posts)
  • Started 11 years ago by 6pack1
  • Latest reply from LH
  • Topic Viewed 38930 times

6pack1
Posts: 0

Ok, this has been bugging me since I first tried to play Oblivion on Vista. I keep hearing stories of how it works perfectly, yet I still can't get it to work. No other sites help, and it seems only this site can have a remote chance.

Anywho, Everything is past recommended; CPU GPU processor RAM etc.
and I have tried:
-Running in compatibility mode for XP
-Running as Admin
-Taking out old saves
-Disabling the compatibility options with check boxes

And recently I have tried partitioning XP, but have failed. I get to "The comp will restart and finish setup" and then it gets stuck after the motherboard boot screen (with F12 for boot menu, DEL for BIOS, etc.) then after a while, no message pops up, but some caracters on the screen (The second boot screen shows the PCI Devices, their numbers etc) disappear. Say one thing is 54DE, after the time period it will be 54D and other objects lose letters. So, I had to keep restarting, then I finally gave up and repaired Vista, and now am asking how to get it to work with Oblivion, my main reason for XP at all.

Posted 11 years ago
Top
 
taybay
Posts: 0

What happens that makes it not work?

Posted 11 years ago
Top
 
6pack1
Posts: 0

Hopefully I can explain it so you can imagine it.:

At first it is fine. I double click the icon to get the launcher (I have clicked every icon to launch Oblivion, both launcher and just the straight game) and the launcher or game starts up fine. I get the black box in the corner showing it is working and the the screen goes black to start up the actual game. (with the launcher, I press play game. No mods or anything.)

So everything is working fine, and the beginning logos show up before it loads the menus and so on. But, usually before the First Bethesda logo finishes (Bethesda, a Zenimax company or whatever) the games stops, flashes twice with two black screens (Showing the program closing) and then a pop-up saying:

"Oblivion has stopped working.
-Search for a solution online and close the application
-Close the application"

I have done both answers and neither one produced any results.

Like I said, I have tried many, if not all of the solutions given out to other people. I am wondering how the heck they could get theirs to run perfectly, with minimal tweaking, yet I can't get mine to work at all. I'm not mad at them, I am just frustrated at Oblivion for being such a butthole.

I have installed it numerous times, and none have come to fruition. It is bothering me that Bethesda only gives out a canned response and doesn't really even try to help. I have scoured many sites trying to find help, and some of those were sites just saying which games ran on Vista. Those same sites say it ran smoothly.

Posted 11 years ago
Top
 
taybay
Posts: 0

The only thing I can think of right now is perhaps updating your video card driver. I doubt that's the problem but it's worth a shot.

Posted 11 years ago
Top
 
6pack1
Posts: 0

Well, updating did nothing. Here, I will put the details of the error...

Problem signature:
Problem Event Name: APPCRASH
Application Name: Oblivion.exe
Application Version: 1.1.0.425
Application Timestamp: 444e8718
Fault Module Name: Oblivion.exe
Fault Module Version: 1.1.0.425
Fault Module Timestamp: 444e8718
Exception Code: c0000005
Exception Offset: 00168616
OS Version: 6.0.6000.2.0.0.768.3
Locale ID: 1033
Additional Information 1: 2fcc
Additional Information 2: d3f06874836bbf3fa55bf45b7982809e
Additional Information 3: c432
Additional Information 4: 6de6445b2bc3a0a04458ac1484730ad3

Read our privacy statement:
http://go.microsoft.com/fwlink.....cid=0x0409

I don't know if that will help at all, but it is worth a try.

Posted 11 years ago
Top
 
6pack1
Posts: 0

Oh and don't be afraid to post your problems here. I see it has been viewed at least 60 times, so if you guys have problems then post them. I am sure we can get you all help with it, and also if you guys have any ideas for getting it to work, no matter how "Out there" they may be, post them. I can use all the help I can get.

The thing is that all my other XP-based games work. Steam (Half-life 2, CS:Source, DoD, etc.), The Movies (Thank God for that! If it didn't I'd be screwed for my Media projects), Stalker, and various non-games.

Maybe I'm naive, but the game is just written in code. It should be able to be read by the computer. I mean, that s what a computer does, right? So why is it that it can't read these simple(language-wise) bits of info?

Posted 11 years ago
Top
 
jd2066
Posts: 0

> So why is it that it can't read these simple(language-wise) bits of info?
It does read the code. The problem is that the game calls libraries to do certain things like access the hardware.
One example is the game calls DirectX in Windows which in turn uses device drivers to do something with the hardware.
The game expects those calls to work in a certain way and if there are problems it doesn't expect the game can crash.
With the new versions of DirectX and device drivers there can be things changed that the game didn't think would change so it crashes.
Also there can be bugs in those new versions that can cause the game to crash also.

Posted 11 years ago
Top
 
taybay
Posts: 0

Honestly there's not much we can do here for you at this point. You would probably be better off posting in a gaming forum or an Oblivion-specific forum where they know more about what you're talking about. Sorry =\

Posted 11 years ago
Top
 
6pack1
Posts: 0

Damn.. Well thanks anyway guys. I at least know people are willing to help quickly (I never expected an average of two hours, that is pretty quick.)

Oh well, I guess I will go see if anyone on an Oblivion specific forum can help.

See y'all later!

Posted 11 years ago
Top
 
pandemic1444
Posts: 0

I had problem like that with a play first game turned out to be my video card. Though an updated driver didn't work for me.

Posted 11 years ago
Top
 
MrBonkers
Posts: 0

Same sort of problem happened to me too. Turns out my video card was unsupported by Oblivion. Luckily, you can download a program called 'Oldblivion' that allows you to play it regardless of your video card:

http://www.oldblivion.com/?page=download

Now to run Oblivion, you just need to begin it from the Oldblivion.exe file.

Posted 11 years ago
Top
 
agent
Posts: 0

k i need help on obvivion sorry about the spelling anyway i am on vista i dont really know what my compters spec is but i know it wont work this game but for some reason it does i got past the start bits i click new game make my charctor then i went though the game intill the sire gets killed i go down to the hole to the sewers i click on it and it just stops i cant get past the hole bit where you go down to the sewers it says

search on line and close program like everyone said on here

can anyone help get past that bit

i done everything they said on the help read me like i put everything low because i have not got a very good computer and i stop ffshow just incase because it says to do it i done everything but it wont let me and i have put it on xp serivce 2 and run as abminster

O if this helps i have download the game from a torrent wesbite so would that mean it broke or corrupt????

Problem signature:
Problem Event Name: APPCRASH
Application Name: Oblivion.exe
Application Version: 1.1.0.425
Application Timestamp: 444e8718
Fault Module Name: Oblivion.exe
Fault Module Version: 1.1.0.425
Fault Module Timestamp: 444e8718
Exception Code: c0000005
Exception Offset: 00168616
OS Version: 6.0.6000.2.0.0.768.3
Locale ID: 1033
Additional Information 1: 2fcc
Additional Information 2: d3f06874836bbf3fa55bf45b7982809e
Additional Information 3: c432
Additional Information 4: 6de6445b2bc3a0a04458ac1484730ad3

any if anyone wanta to email me it agent_robbo@hotmail.co.uk

Posted 10 years ago
Top
 
Iivaitte
Posts: 0

I'm having the exact same problem.
Only diff is that I can actually play it for like 10 sec.
Heres what happens, I click on the launcher, music but no swoosh when I scroll through the launcher menu.
I click on the launcher directly from the cd and I get from the launcher no sound at all.
When I get into the main menu in the game I get a moving map in the back ground but no music.
When I get to playing the game it lets me play with no problems what so ever and crashes within 10-20 secs.

My error in the error report is exactly as his is

I have a vista Acer aspire T180, AMD Athlon 64 processer, 1G ram, 32-bit operating system.

I got my computer and oblivion at the same time, installed oblivion played with out any problems (not even lag)
and then I got power hungry and kept messing with the system settings to make it faster, still no problems.
Then I took a break from oblivion to make room for a new game NWN2 and the DX version that came with it.
I then started having problems with oblivion and my computer.
I fixed my computer but still can't get oblivion to work. In other words I put all the settings back.

Also when I Looked at the DLL I found that the computer can't find audiodg.exe.

Is this enough info to fix the problem.

Reports: 1 · Posted 10 years ago
Top
 
Iivaitte
Posts: 0

oh, btw I bought mine.

Problem Event Name: APPCRASH
Application Name: Oblivion.exe
Application Version: 1.1.0.425
Application Timestamp: 444e8718
Fault Module Name: ASAudio.ax
Fault Module Version: 1.3.1.63
Fault Module Timestamp: 46a5b521
Exception Code: c0000005
Exception Offset: 00007804
OS Version: 6.0.6000.2.0.0.768.2
Locale ID: 1033
Additional Information 1: 8d13
Additional Information 2: cdca9b1d21d12b77d84f02df48e34311
Additional Information 3: 8d13
Additional Information 4: cdca9b1d21d12b77d84f02df48e34311

Extra information about the problem
Bucket ID: 601345553

Posted 10 years ago
Top
 
Iivaitte
Posts: 0

ok I have the solution but it means no music.
there should be two config files, one will be in my games in my documents and another will be in the default bethesda softworks folder
clikc and edit them both so they agree, give the property 0 to music and your problem should be solved.

Posted 10 years ago
Top
 
Scott
Posts: 0

Thanks for posting back, livaitte

Posted 10 years ago
Top
 
magster
Posts: 0

For anyone haveing the ASAudio.ax problem and running windows vista, this worked for me and I did not lose any music or sound quality. Go to the mpeg directory under C:/Program Files/Common Files and delete the ASAudio.ax file. I actually moved mine to a trash directory in case I would ever need it again. Now Oblivion plays perfectly with great sound and music and no crashes. I am running a nvidia 8800 GTX video card, creative x-fi sound card and windows vista home premium. Hope this works for someone else.

P.S.: I was at work (not at home) when I wrote this. You would go to C:\Program Files\Common Files\ArcSoft\MPEG Engine and the file ASAudio.ax is in there if it is on your computer. Sorry about that.

Posted 10 years ago
Top
 
dls
Posts: 0

Thanks magster, that worked for me. Oblivion plays fine now.

Posted 10 years ago
Top
 
Iivaitte
Posts: 0

Sorry if i"m late for responding but it did work, magster's Idea was the solution, it solved everything.
good job magster!!! ^^*

Posted 10 years ago
Top
 
Losno420
Posts: 0

Unfortunately I found out that my latest save was what was giving me problems(Dang now I have to go back 4 hrs but at least I can play). I play on an older save and it doesn't seem to give me trouble yet....

Posted 10 years ago
Top
 
0711misterX
Posts: 0

I copied the save-data (C:/Users/Username/My Games/Oblivion), reinstalled the game and Oblivion is running.

Posted 10 years ago
Top
 
0711misterX
Posts: 0

Now i have a little problem :) i wrote that the game is running but only without the patch oblivion_v1.2.0416german.exe :(

can anyone explain what livaite said? where have i have exactly give the 0 to the music?

please help

Posted 10 years ago
Top
 
vlad86
Posts: 0

I have a problem that started in My Windows XP and continued even when I installed Vista even updating it to the latest version (1.2.0416)
I still suffer a crash:
This is the error

Problem Event Name: APPCRASH
Application Name: Oblivion.exe
Application Version: 1.2.0.214
Application Timestamp: 45d4c5a7
Fault Module Name: Oblivion.exe
Fault Module Version: 1.2.0.214
Fault Module Timestamp: 45d4c5a7
Exception Code: c0000005
Exception Offset: 0024918e
OS Version: 6.0.6001.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 2ccd
Additional Information 2: b7a25245ecd6b36b9d66fa98ae9b5ff2
Additional Information 3: 55d0
Additional Information 4: 8957880a9861ca6bc8d1b0d6846efaee

Can Anyone help me urgently ?
Thanks

Posted 9 years ago
Top
 
bixwok
Posts: 0

I'm having a similar problem in that my Oblivion crashes on startup, but I don't know how to retrieve the error message details. Can someone please explain?

Thank you

Posted 8 years ago
Top
 
LH
Posts: 0

bixwok hi. Please start a New Topic.

Posted 8 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

The Best Tech Newsletter Anywhere

Join 250,000 subscribers and get a daily digest of news, geek trivia, and our feature articles.