I'm running Vista Home Premium 64bit on laptop on C partition. D partition has Windows 7 Professional 64bit installed. Both were running fine [using dual boot] until 4 or 5 days ago when Windows 7 would go thru ordinary booting, login page came up, then window --

"The procedure entry point DvmHintDxUpdate could not be located in the dynamic link library user32.dll."

If I click on the OK button, then the screen goes black and only the cursor can be seen.
After experimenting, I found I could use Ctrl-Alt-Del to load Task Manager, and then could run various programs by using it -- but of course I cannot get on internet since the network and wireless drivers apparently do not load. There is intermittent activity of the hard drive while the screen remains black -- have no idea what this means.

Search on internet suggests that maybe maybe User32.dll is corrupt -- but can't find anywhere to download a valid copy. Help would be appreciated.

I've tried all Repair and Recovery items after booting with Windows 7 Pro Install disk.

Safe mode boot produces the exact same result.

System restore-I apparently didn't save any restore points!

Booting to C drive -- Vista still works fine!

Posted 7 years ago