The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows 7

(Solved) - svchost.exe

(49 posts)
  • Started 7 years ago by doublek
  • Latest reply from doublek
  • Topic Viewed 3319 times

doublek
Posts: 0

I am gettein an svchost.exe application error when trying to shut down my laptop. I have windows 7. My computer is running slow now also

Posted 7 years ago
Top
 
whs
Posts: 0

Find out which .dlls run under this particular svchost.exe which is only a generic process. For that you run Process Explorer (download from MS) and hover over the svchost.exe in question - or go to Properties.

Posted 7 years ago
Top
 
doublek
Posts: 0

whs.......this wasn't helpful, I still have the application error..and I am not sure what you want me to look for in Properties..........Someone please help

Posted 7 years ago
Top
 
Xhi
Posts: 0

I'm afraid you are right. I'm not sure how you determine which svchost.exe is giving you the problem. Thus which to look at. Perhaps whs will be back with more explicit instructions.

In the mean while there are several things that you can do. First I would Download a program called CCleaner Run the cleaner and allow it to delete what it finds, then run the Registry cleaner and Fix all it finds. Then go to Tools->Startup Tab and disable all but your security programs and any others that you specifically recognize that you would personally have to start if they were not started for you. If you recognize none that is OK. Reduce this list to no more than 10. Try a shutdown and see if the problem has gone away.

To continue to solve the slowness problem download, install, update and run Malwarebytes Antimalware and remove anything it finds. Reboot then again shutdown and see if things go better.

After doing these two things check back with what has happened.

Posted 7 years ago
Top
 
ispalten
Posts: 0

There are other things that can help too, and a lot of info can be gotten, seeTHIS ARTICLE for some details on how to help identify shutdown problems.

SVCHOST usage can also get some needed details or hints to the problems. Check these links :

Good Tool to see what SVCHOST is really running
How to use the above
http://technet.microsoft.com/en-us/magazine/ff642468.aspx
https://www.howtogeek.com/howto/windows-vista/what-is-svchostexe-and-why-is-it-running/
http://www.techrepublic.com/blog/window-on-windows/identify-and-get-detailed-information-about-processes-in-windows-7/3340
http://www.watchingthenet.com/how-to-identify-what-programs-started-svchostexe-in-windows.html

As you can see there is more than one way to 'skin a cat', but what is important is to identify what is actually running, see if there are any errors associated with any of those, and figuring out one by one if any can be stopped from running to see if that fixes the problem. Once the problem is known, the fix is easier.

Irv S.

Posted 7 years ago
Top
 
whs
Posts: 0

My answer was a brief as your problem description. Give me the exact message you get (snip it and post it) and I will see whether we can get closer to determining which svchost.exe it is.

Posted 7 years ago
Top
 
doublek
Posts: 0

svchost.exe-application error The application was unable to start correctly (0xc0000142). Click Ok to close the application.

this is the exact wording that comes up when I try and shut down.

Posted 7 years ago
Top
 
GuiltySpark
Posts: 0

Hi doublek ,

Bring up a command prompt in Admin mode (by right clicking the cmd.exe icon in start menu --- Accessories) and type :

sfc /scannow

Posted 7 years ago
Top
 
doublek
Posts: 0

Guiltyspark..........nothing happend and now the window won't close

Posted 7 years ago
Top
 
Xhi
Posts: 0

Hitting the X in the upper right doesn't work?? Type Exit at the C: prompt.

Posted 7 years ago
Top
 
doublek
Posts: 0

It says i must be an administrator running a console session.........I am the administrator i thought

Posted 7 years ago
Top
 
doublek
Posts: 0

I am the administrator I just checked i tried it again and it still won't work

Posted 7 years ago
Top
 
GuiltySpark
Posts: 0

You need to right click the cmd.exe icon and select Run as Admin.

Posted 7 years ago
Top
 
doublek
Posts: 0

Ok it's running.......it said it may take awhile........than what

Posted 7 years ago
Top
 
GuiltySpark
Posts: 0

After its finished it will say whether or not there are any probs or that it fixed things. Then you need to restart your machine and see if the error still occurs.

Posted 7 years ago
Top
 
doublek
Posts: 0

Scanning complete it says:
Windows Resource protection did not find any integrity violations.

Posted 7 years ago
Top
 
doublek
Posts: 0

The error is still there it won't let me restart my computer, I keep clicking Ok and it won't do nothing. Only way to shut down is hold the power button

Posted 7 years ago
Top
 
doublek
Posts: 0

Gotta go for a couple hours.......please post some things for me to try.......I'll be back

Posted 7 years ago
Top
 
ispalten
Posts: 0

I don't understand, the error you posted is for STARTING an application. "svchost.exe-application error The application was unable to start correctly (0xc0000142). " but you said you were shutting down the system?

When you get the error, can you get back to the desktop? Look in EVENT VIEWER for that same error, it might have more details.

Irv S.

Posted 7 years ago
Top
 
Xhi
Posts: 0

Would you mind trying the things I outlined above??

Posted 7 years ago
Top
 
GuiltySpark
Posts: 0

Maybe worth posting your laptop Make/Model and specs too.

Posted 7 years ago
Top
 
whs
Posts: 0

It is probably a .dll from a program that you installed. The system file checker can only repair some of the system files, but not application files. Can you tell us which program you were trying to start, or did it come out of the blue.

If you can id that program, uninstall it and then reinstall it. But use Revo Uninstaller (advanced option) for the uninstall.

Posted 7 years ago
Top
 
doublek
Posts: 0

Ispaltan.......yes the error showed that when i was shutting down. I can get back to my desktop by clicking cancel. Where is Event Viewer?

Posted 7 years ago
Top
 
doublek
Posts: 0

whs this came out of the blue about a week ago. I have no clue what program it pertains to.
Hi have a HP G71 with windows 7 not sure what else you want to know

Posted 7 years ago
Top
 
doublek
Posts: 0

Xhi...I never got the email for the Malware download...........

Posted 7 years ago
Top
 
whs
Posts: 0

You can try a repair install with your installation or repair disc. That gives you a better chance to repair it because the system file checker does not have all files in the mirror. But if it is an application .dll, only reinstalling the application will help - but unfortunately we do not know which one it is.

Posted 7 years ago
Top
 
Xhi
Posts: 0

What e-mail? My link was to the File Hippo download site. Just download Latest Version.

Posted 7 years ago
Top
 
doublek
Posts: 0

Xhi. I downloaded the CC Scanner and malware....Now I am getting a Windows cannot find'C:\Users\Ken and Karen\AppData\local\temp\rundll32.exe.
I am alsoe still getting the svchost.exe error at shut down but after clicking ok a few time my computer will actually resart. Than this occured...I went into my facebook account though I would play some games and it said i needed adobe flash upgrade so I did and still can't play the games. HELP ME !!

Posted 7 years ago
Top
 
Xhi
Posts: 0

This is beginning to look more and more like malware. Try running Malwarebytes from Safemode with networking.

[u][b]Boot to Safe Mode with Networking[/b][/u]
When you boot up before it starts Windows and after the initial BIOS checks, hit the F8 key several times. The start of Windows is usually accompanied by a single Beep. If normal Windows comes up try, try again. A Black screen with choices should come up, choose Safe Mode with Networking.

Posted 7 years ago
Top
 
doublek
Posts: 0

Xhi.....Ok I came up in safemode with networking......I ran a quick scan 4 items found (which is a lot less than when I did it the first time last night) I restarted computer than I get a malwarebytes message that has detected a malicious process attempting to start and has blocked the execution aattemp
C:\users\kenand karen\appdata\local\temp\rundll32.exe trojan.agent. asks if I want to disable protection ignore or quarantine

Posted 7 years ago
Top
 
Lighthouse
Posts: 0

Delete all the files in the temp folder, reboot the computer, see if that file comes back.

Posted 7 years ago
Top
 
Xhi
Posts: 0

Definately quarantine.

Posted 7 years ago
Top
 
doublek
Posts: 0

Lighthouse.........where is my temp folder..............Xhi I quarantined it

Posted 7 years ago
Top
 
Lighthouse
Posts: 0

Here,
C:\users\kenand karen\appdata\local\temp\

Posted 7 years ago
Top
 
doublek
Posts: 0

It let me delete all but one file.......FXSAPIDebugLogFile...when i try and delete it this comes up again
C:\users\kenand karen\appdata\local\temp\rundll32.exe

Posted 7 years ago
Top
 
Lighthouse
Posts: 0

Use this app to delete it,
http://www.filehippo.com/download_unlocker/

Posted 7 years ago
Top
 
doublek
Posts: 0

It says The publisher of Unlocker1.9.1.exe gouldn't be verified are you sure you want to run the program?

Posted 7 years ago
Top
 
Xhi
Posts: 0

Yes, run it.

Posted 7 years ago
Top
 
Lighthouse
Posts: 0

It is fine, go ahead and run it.

Posted 7 years ago
Top
 
doublek
Posts: 0

Ok I downloaded it.......no scan or nothing came up....i went back into my temp folder and I still cannot delete FXSAPIDebugLogFile

Posted 7 years ago
Top
 
Lighthouse
Posts: 0

Did you install it ok. If yes,
Right click on that file and select Unlocker.

Posted 7 years ago
Top
 
doublek
Posts: 0

When I right click on that file unlocker isn't there.
I do show it in my programs

Posted 7 years ago
Top
 
doublek
Posts: 0

Lighthouse I am off to Sunday service....I will be back in a couple hours.......please post some help for me......I am ready to get out my .45 and shoot it like that father did to his daughters laptop.

Posted 7 years ago
Top
 
Lighthouse
Posts: 0

Try taking Ownership of the file, then deleting it,
https://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/

Posted 7 years ago
Top
 
doublek
Posts: 0

Lighthouse it didn't work.......I'm not even sure if I installed it properly or uninstalled it properly

Posted 7 years ago
Top
 
Lighthouse
Posts: 0

If Unlocker does not show in your right click context menu, then you have not installed it, or a virus is stopping you from doing so.
Try installing it again.
Shut down the computer before and after you install it. (restart the comp after 10 seconds)

Posted 7 years ago
Top
 
doublek
Posts: 0

Lighthouse Right click in my temp file at the one I can't delete?

Posted 7 years ago
Top
 
Lighthouse
Posts: 0

yes

Posted 7 years ago
Top
 
doublek
Posts: 0

the malware i downloaded totally goofed up the system i had to pay 150 to clean everything up problem solved

Posted 7 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

The Best Tech Newsletter Anywhere

Join 250,000 subscribers and get a daily digest of news, geek trivia, and our feature articles.