The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows Vista

(Solved) - right-click not working in browsers

(15 posts)
  • Started 10 years ago by ferisT
  • Latest reply from Tristian
  • Topic Viewed 14660 times

ferisT
Posts: 0

Has anyone knows the sollution how to enable mouse right-click functions in browsers(im using Avant and IE) ?
By right-clicking ,e.g. on internet links or pictures, there is no response from a right mouse button, although by cliking desktop's items its works properly.

Im having new HP laptop with Vista H Premium and have checked all possible options in Control Panel for mouse and in Internet Tools (in browsers options)...havent figured yet how to fix it.

I would be gratefull for your advice.

Posted 10 years ago
Top
 
Scott
Posts: 0

Often a website will preclude you from saving pictures via an embedded script.

Posted 10 years ago
Top
 
ferisT
Posts: 0

Scott,
for any sites its not functional...

Posted 10 years ago
Top
 
Scott
Posts: 0

One web solution is to uninstall the mouse drivers from Device Manager, reboot and Scan for Hardware Changes.

Posted 10 years ago
Top
 
ajax622
Posts: 0

I've actually noticed this problem with my Vista copy. At first I thought it was a Vista issue. But I found that it was a trojan and removed it. I have no idea how I got the trojan, but I think it was from a torrent (I found it with AVG and looking at the task manager).

Let me know if I am wrong, and it was the mouse driver.

Posted 10 years ago
Top
 
michael
Posts: 0

You can collect torjans from torrents, but also from types of websites. Make sure that AVG deletes it and doesn't quarantine it.

--
Mike

Posted 10 years ago
Top
 
ferisT
Posts: 0

Ajax,there were no malware detected by my AV (Norton IS), niether by a2 or AVG...
By the way, after installing AVG, system started to behave very unstable, stalled few times, and Avant browser was freezing after starting. I've used AVG on my old XP and it did good job. Seems that with Vista they need some "tweeks" to develop...(i uninstalled AVG after scan).
In the meantime, I have to check the Scott's provided sollution when i get few free hours to spend...
Michal, I dont use any torrents or any such kind of stuff...

Thanks guys for your time.

Just strange, that for ANY browsers content, the right-click is not working and its seems that im only one got this problem...

Posted 10 years ago
Top
 
michael
Posts: 0

Try using this to help if you are using Internet Explorer:

http://support.microsoft.com/kb/318378

Posted 10 years ago
Top
 
Scott
Posts: 0

"In the meantime, I have to check the Scott's provided sollution when i get few free hours to spend..."

The troubleshooting step I provided above will take mere minutes.

Posted 10 years ago
Top
 
michael
Posts: 0

Oh sorry Scott, never looked up. :P Oh well - good enough to have multiple ways.

--
Mike

Posted 10 years ago
Top
 
ferisT
Posts: 0

lol scott,
im a bit unfamiliar with this hardware scan...
thought i need time to figure it up first.

Posted 10 years ago
Top
 
ferisT
Posts: 0

Michael,
the link u provided is for Win XP...
im refering to Vista, tho i wish i had my trusted XP back again (but it crashed)

Posted 10 years ago
Top
 
michael
Posts: 0

I am sure that that link will work for Vista. Most things do work. If you still have your recovery discs for XP then I am sure you could switch back, unless you bought your computer with Vista preinstalled and got rid of the XP one.

--
Mike

Posted 10 years ago
Top
 
ferisT
Posts: 0

thanks guys ... i have solved the issue !

Its all has to do with Google's tool bar. Sometimes u need to upgrade for newest version of it, sometimes to remove it totally, sometimes just enable it and put it on your browser's tab.

Being myself non-google user i have disabled it what caused me such problems. Now i have to figure how to safely remove it without affecting mouse settings (i have tried that but mouse right-click was not restored).

Thanks for your time guys, hope this small solvedd annoyance would be helpful for other readers too.
Cheers

Posted 10 years ago
Top
 
Tristian
Posts: 0

FerisT, thanks, man. You are the man!
That was my exact problem, and I have been stressing, because I work online, and my cable bill is due, and couldn't figure out the problem. It was the Google Toolbar! Thanks again.

Posted 8 years ago
Top
 



Topic Closed

This topic has been closed to new replies.