The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows 7

(Solved) - no disk in drive

(13 posts)
  • Started 7 years ago by curry318
  • Latest reply from curry318
  • Topic Viewed 7947 times

curry318
Posts: 0

What does this mean and how can I get rid of it?
_______________________________________________________
SnippingTool.exe - No Disk
_______________________________________________________

"X" There is no disk in the drive. Please insert a disk into drive
\Device\Harddisk2\DR5.

_______________________________________________________
Cancel Try Again Continue
_______________________________________________________

This thing is always popping up and it is very hard to get rid of no matter which button I click on. It finally goes away, but I don't know what makes it go away. It is very irritating. There is a red circle with a white X in it, where I put an "X" above.

Thanks. Pat

Posted 7 years ago
Top
 
Xhi
Posts: 0

Do you have anything in any drives? USB, Card drives?, CD drive, etc. If so reboot and remove them.

Posted 7 years ago
Top
 
curry318
Posts: 0

It also does this when I try to save something in Notepad. It seems to me like it wants me to put a disk in a drive to put something on it, not remove something. I'm not trying to put anything on a disk, just save it on the computer like always. I'm not doing anything different than I ever have before that I know of. This just started happening lately and I don't know why. I have turned the computer off and on many times since this began and it just keeps doing it anyway. What is: \Device\Harddisk2\DR5? I never heard of that before.

Posted 7 years ago
Top
 
Xhi
Posts: 0

When you look in disk management does your OS have the drive letter C: If not what drive does have that letter?

Posted 7 years ago
Top
 
curry318
Posts: 0

Sorry, but I don't know what you mean by "When you look in disk management."

When I look under COMPUTER, I see this:
Local Disk (C:)
DVD RW Drive (D:)
Elements (F:) - this is my external HD
Norton Backup Drive - I disabled this a long time ago because I use the external HD

I used to have an (E:) Drive where the external HD was, but it just vanished one day and by itself the external HD went to the (F:) Drive. It's been a long time, but I think I might have been using flash drives at the time; but after I got the external HD, I have pretty much quit using the flash drives.

Sometimes I hate computers. They can be such a pain. I envy your knowledge. I'm fine, doing what I do, but when something goes wrong, I'm lost. If I don't do something every day, I forget how to do it. And stuff keeps changing all the time, too, which makes it hard for me. I am 75 and never really had a good memory anyway and now it's worse. Even if I learn something, I can't remember it for long if I don't use it often. I'm just trying to explain to you why I may seem so stupid to you. :)

A lot of times, these little irritating things start to happen and nobody seems to be able to figure it out; and then, just as suddenly, they just disappear. I don't think I will ever understand it.

I appreciate your help and your patience. Thanks

Posted 7 years ago
Top
 
Xhi
Posts: 0

There may be references in your registry that are still referencing that old e: drive.

First, disk management is accessed by right click on Computer and select manage, then disk management under storage.

Second, I would connect a flash drive to a USB port. If it does not come up as E: then go to Disk Management and right click, select change drive letter and change it to E:. If that does not work then that is your problem, it thinks it has an E: drive and it does not. If the problem goes away under this configuration then you will need to find Registry entries referring to E: drive and see what can be moved.

My hunch is that there were folder or programs installed on the old E: drive that were not properly uninstalled when E: went away.

Posted 7 years ago
Top
 
curry318
Posts: 0

Thanks. I will try that.

Posted 7 years ago
Top
 
Enthusiast
Posts: 0

It is possible that you plugged in a USB or external drive and did a save straight to that drive from notepad or another program. Sometimes these programs "remember" the last place that a file was saved to and default to that location on the next save. Because you have since removed the external or USB drive, that location cannot be accessed, leading you to get the "there is no disk in the drive" error.

It may be possible to stop receiving this error by:

1. Plug in a USB/external drive
2. Open a file and attempt to SAVE AS. If you do not get the error, your USB/external drive is recognized as the missing drive. If not you will have to try plugging in another USB port, change drive letter, etc. until the right drive is located.
3. Save the file on the local hard drive (C, D). This should reset the default save location to a drive that is always physically present.
4. If ever you want to store a file on an external drive or USB device directly from a program, such as notepad, save the file to your local hard drive, then copy or move it to the external location.

Posted 7 years ago
Top
 
curry318
Posts: 0

That sounds fantastic. I just hope I can do all that. Thank you.

Posted 7 years ago
Top
 
germ-x
Posts: 0

There is another way to control your drive letters.
Plug in your external hdd and flash drives.
If you insert and remove your flash drives most then those letters will be higher.
If you leave your external hdd plugged in then it should be the next latter after your Cd/DVD burner.
Open disk management and start assigning new letters to your hardware in the order you want then to be shown.
I made my flash drives the last letter since I inset and remove that most often. When I unplug the flash drive that letter drops off and the last letter will be my external hdd or DVD burners if the external hdd is also unplugged

Posted 7 years ago
Top
 
Xhi
Posts: 0

Maybe this is what you said, germ-x, but what I do for any drives I plug in often is to start with Z: and work backwards. That way they are always the same letter when you plug them in. The one I changed to Z: remains Z: no matter when or which port I plug it in.

Posted 7 years ago
Top
 
raphoenix
Posts: 0

If you have Free old SIW program, can look at storage and see Registry History of USB Sticks (drives) that have been plugged in.

Rick P.

Posted 7 years ago
Top
 
curry318
Posts: 0

Most of the stuff above I did not understand, so what I did was just clean out everything I could think of on my computer and it just stopped doing that. I don't know what I did or didn't do, but it's gone. Sometimes this kind of thing happens to me. It drives me crazy for a long time and then it just goes away. I don't know why. I wish I understood it, but I don't. Thanks to you all for trying to help me. I'm afraid your answers were beyond my understanding.

Accepted Answer · Posted 7 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

The Best Tech Newsletter Anywhere

Join 250,000 subscribers and get a daily digest of news, geek trivia, and our feature articles.