The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows Vista

Not Solved - mht files won't open

(47 posts)
  • Started 10 years ago by SarahJames
  • Latest reply from Jack333
  • Topic Viewed 31720 times

SarahJames
Posts: 0

To keep everything neat and tidy, I'll start a new topic for this one.

A couple of days ago all of a sudden my mht-files won't open anymore. Or rather, they open and close again directly. If I have a window open in Iexplore it get's pushed to the front, but that's all that happens.
I had just installed Grisoft Free AVG virusscanner (verion 8.0) and someone else posted about trouble resulting from that, so I removed AVG and now I use Avira, but my mht's still won't open. Not the old ones I already had, nor the new ones I make (I can still save a website as mht - that's no problem).

I have already restored my standard programs in the control panel. That didn't help either.

Greets,
Sarah

Posted 10 years ago
Top
 
jack7h3r1pp3r
Posts: 0

i don't really think this will help but here: http://filext.com/file-extension/MHT

Posted 10 years ago
Top
 
SarahJames
Posts: 0

I've registered so I can I post on their forum, but the activation email hasn't arrived yet. Maybe someone there has any ideas ;-)

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Jippie ayay jippie jippie jee - I don't have to post there anymore.
I don't know what happened: I installed jZip so I can open rar-files and all of the sudden mht icon disappeared and became a blank file. So I ran reset standard programs and it appeared Iexplore wasn't standard for anything anymore. So I made it standard again and voila, mht opens like a charm.
Funny things - those computers ....

Sun is shining, so I'm off again. A great day, everyone!
Sarah

Posted 10 years ago
Top
 
Lighthouse
Posts: 0

Nice way to start the day. With a success. Well done

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Bummer - not a succes after all. The error is back again :(
And I should be doing something else now!
I'll be back tonight to try again.

Posted 10 years ago
Top
 
jack7h3r1pp3r
Posts: 0

so you changed the files to open with ie and then they worked so since this problem is back have you checked to see if the files are still set to open in ie still?

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Yes Jack7h - it worked and then it didn't anymore. As I have said on another thread:
"Anyone knowing anything about getting mht back to right again is very welcome! It is a feature I use very often and I greatly miss it. I have loads of tutorials for a variety of topics and I can't acces them.
Reading this: http://filext.com/file-extension/MHT
I found out mht is about the same as eml, so now I copy a tutorial from the CD I've burned it to and then rename the extension to eml and I can read it, but it is very uncomfortable going about it like that"

I have registered at fileXT to be able to post at their forum, but my confirmation email never arrived - I'll try registering again in a minute and I'll take a look at the AVG forum too (more about that here:
https://www.howtogeek.com/forum/topic/avg/page/2?replies=28#post-23266 ).

Sarah.

Posted 10 years ago
Top
 
jd2066
Posts: 0

Here is one thing to try for opening them:
1. Open Internet Explorer.
2. Press CTRL+O to open the open dialog.
3. Click browse and double click the mht file.
4. Click ok.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

@ jd2066 : Nope doesn't work either.

Posted 10 years ago
Top
 
jd2066
Posts: 0

Which part of the fails and do you get an error message?

Posted 10 years ago
Top
 
SarahJames
Posts: 0

I press ctrl + o, browse, open the mht and nothing happens. Absolutely nothing. No errormessage or anything.

Posted 10 years ago
Top
 
jd2066
Posts: 0

That is odd. So you click ok, the dialog goes away and then you don't see anything happening?
Here is one more idea:
Open Internet Explorer.
Open the folder with the mht file.
Drag the mht file to an empty white space of Internet Explorer and drop it.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Doesn't work either :(

Posted 10 years ago
Top
 
jd2066
Posts: 0

That is quite odd. Both of those should have at least done something weather work or show an error message.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

This is the reply I got from the AVG forum:

<<Aparently the MHT file association issue is really common ... in most cases the recommended fix for it was to re-install IE which currently presents a problem with Vista.

I had hoped your previous antivirus had been ones that are known to cause various issues after uninstalling ... unfortunately if Bulldog does or doesn't is hard to say though I couldn't find any info one way or the other... and there doesn't appear to be a seperate uninstaller for it... so that was another dead-end direction to suggest to you..

So, I had to look at solutions for the issue itself... this is also not going to be one that can be blamed on AVG itself because it doesn't associate itself with this file type... the issue may have surfaced during/after the installation but the cause was something else...

This is about the only possible suggestion I can think of for you to try...

Control Panel (Classic View) > Default Programs > Set your default programs
(first link) > highlight Internet Explorer > Choose defaults for this program
(bottom green arrow) > make sure .mht is checked and press the Save button in
the lower right corner.

That should re-associate the files... if you use another browser as your default, then you would need to set it back as your default once the issue itself is resolved.>>

Well, as said I have tried to re-asociate the files, but that didn't work.
And I wonder about reinstalling Iexplore - won't I run into other problems when I do that?

Posted 10 years ago
Top
 
jd2066
Posts: 0

Internet Explorer is integrated with Windows Vista so the only way to reinstall Internet Explorer is to reinstall Windows Vista.
You could use Firefox with the UnMHT extension to view the mht files.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Ohhh, I'm not happy now :(
But I won't give up. I don't use firefox and renameing the mht extension to eml enables me at least to view the mht, but I'll keep looking for a solution.
Mind you - looking at other forums I have found this does occur quite frequently. Vista quirck ...
But if it is bugging more people a solution will be found eventually, right?
So I'll just practice a little patience and keep on the lookout for a solution.
Suggestions are still very welcome;-)

Sarah.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

OK - I think I've got it ....
I'm almost afraid to think it;-)
Remember I installed jZip and all of a sudden it worked and then it didn't anymore?
jZip installed by default with all kinds of archives associated, but I re-associated zip with Explorer and that's when the mht problem recurred. Now by accident I associated zip with jZip again and voila, mht works. I haven't got a clue what those two have to do with one another, but I don't care.
it is of absolutely no importance to me to keep zip associated with explorer, so I'm happy with my solution!

So I went overboard: Along the way I also came across Zipeg and it has a sheep icon. Now if you've ever read Matthew Thomas' Before and After, you get an instant image of exploding sheep and after all this trouble the image stuck. So I edited the zipeg icon and gave that to jZip, resulting in this:

Probably doesn't mean anything to any of you, but cracks me up every time;-D

Posted 10 years ago
Top
 
Scott
Posts: 0

Holy schaapsmeerders...

Posted 10 years ago
Top
 
Lighthouse
Posts: 0

I could understand exploding sheep. But normally they pretty hardy

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Posted 10 years ago
Top
 
Lighthouse
Posts: 0

Long time since I read Nostrodamus

Posted 10 years ago
Top
 
SarahJames
Posts: 0

I don't believe it - I'm going crazy here: problem is back, just like before. Been gone for a couple of hours and now it is back again after Nero made a backup. I haven't got a clue why, because jZip is nicely associated with the zip files and nothing has changed!!!!

Oh wait - that's not true: I uninstalled Multiset using Revo.

But apart from that, nothing changed. What's going on here???

I'm off to bed - to dream up a solution or explode like one of my sheep ....

Sarah.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

One more try ...
Made a registry-entry so mht don't open with Iexplore, but with Windows Mail (I figured if I can change the extension to eml and they open, I might as well leave the extension be and change the app that opens them). Added a DefaultIcon key, so there's a visual difference with eml files. (Had a nice icon lying around I downloaded somewhere;-D).

So far it works, but I had to disable iexplore checking if it's the default browser (hate that function anyway ...).
If anybody else is interested I'm more than willing to provide the reg file (I found in my search that this is a very frequent problem - a real Vista quirck, and there isn't a good solution yet, so this might help someone else), but I don't know where to post it for download (my website doesn't allow zips).
Suggestions?

Note for anyone interested in using it: modifying the registry can be hazardous - you do so at your own risk!
Also: you'll have to edit the location for the iconfile yourself.

Cheers,
Sarah.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

OK - an update to where I stand right now.
I was thinking about format C:\ and reïnstalling all of Vista afresh, but now that I have PSP XL working and it is clear that I can't use the most economic setting for printing in Word 97 ever, so reinstalling is no use there, I hope to solve the last problems I have one by one.

I'm thinking about getting me Office 2007 - I hear a lot of positive rumblings about it, but I'm not ready yet for the enormeous amount of work it will bring me - I have so much settings imported in normal.dot and they won't transfer to the new version, and that's apart from the Ukeys4Word that I use for typing Greek. I know there are other apps out there who do the same, but I've been using it for something like 10 years by now and can type it blind - I don't want to lose it!!!
If anyone knows how to transfer normal.dot settings from Word97 straight to the newest version I'd be very very happy!

Well, back to the task at hand.
As said, my mht files won't open and lately I also got this error:

By now I know this happens when I use jZip.

So the problem comes back to the same thing: it has to do with standard programs and Iexplore.
Also when I click on standard programs and want to choose what files are associated with my standard programs there is something weird with the icon for Windows Photogalery - it looks like a IcoFx file instead of the standard icon I expect.
Since Windows has a problem if you delete or modify the standard programs I've not changed anything when it comes to that - I once got that notion with Windows Media Player, but never pulled through, because I was warned off and I have a huge HDD so I don't need the space.
So why has that changed?

But anyway when I want to change what files a program is default for I can only add extensions, not unselect them :

So I do that by rightclicking on a file and chooseing another program as default for opening. I wondered if that is just Vista security again or should I be able to unselect extensions?

Another thing is I don't have the SP1 installed and I read something about it elsewhere, but I forgot where. I allow Vista to update on it's own (I set it to warning me now ;-D), but it doesn't install the SP1, so there was something with incompatability with certain programs etc., but I don't remember the exact facts.
I was thinking maybe this will restore what's wrong with Iexplore and I might not have to sort all this out manually - wishfull thinking, probably, but hey, you never know ... LOL

Ohh, well, there you got it, my life's story:)
Your input is very welcome!

Sunday Sarah ...

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Edit: LOL I see at my screenshot I was asking already for updateing the SP1, but now where was that post ...???

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Edit2: there I go again, solving my own problems ...
Just to be sure I take a look at updates and I haven't had a warning (should have had it, I thought ...), but there it is 'available updates: KB936330: Windows Vista Service Pack 1'

So I'll set a restore point, by coincidence made a full backup yesterday, and this afternoon I'll be running the update. If it get's very quiet after that you can take it it went wrong ... LOL

Keep thinking for me about solving the rest of it please ;-)

Sarah.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Ha - SP1 posed no real problems, but it didn't solve any either. Mht still gives the same error. Useing jZip still gives "pure virtual function call" whatever that may be.

I have reset Iexplore after that, so all plugins were deleted, hoping that might do some good, but it changed nothing.

Any ideas left anyone?

Goodnight,
Sarah.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

OK, a couple of weeks have passed, I haven't tried to get the mht's to work anymore, because I'm fed up with them and all of a sudden my icon for them has disappeared (I open them with Windows Mail now, at least that way I can use some of them - not all, because mail supports far less scripts), so I choose Iexplore to open them, because if a customized icon disappears it's easiest to get it back by choosing another default app to open the file and then set it back to the program you normally use.

So I open one with Iexlore, expecting it to shutdown at once, but funny funny funny - it opens normally!
I've tried a couple of times now and it still works ...
Now I hope it still works tomorrow, because I've had some other times it worked and then it didn't anymore - so I'm keeping my fingers crossed.

Just had to let you know:)

Cheers,
Sarah.

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Next morning: it still works ....

Posted 10 years ago
Top
 
Scott
Posts: 0

SarahJames,

Happy to hear things are (relatively) normal. Sorry to hear (and watch) about KNVB :(

Posted 10 years ago
Top
 
SarahJames
Posts: 0

Thanks Scott:)

Geek, I think this topic is ready to be closed - my mht really works:)
And I temporarily borrowed my mother's printer (a Canon) and Word97 works perfectly with that, so that is sorted too. I've made a complete backup with Nero Backitup, set a restore point, made a backup with Erunt (guess I'm safe now?) and nóóóóó way I'll format C and reinstall Vista - works perfectly as it is!

Cheers,
Sarah.

Posted 10 years ago
Top
 
harley
Posts: 0

mht files won't open? tried infor sent / did'nt work/ this is an xp program, that may make a differance/ not very good with computers thanks harley

Posted 9 years ago
Top
 
SarahJames
Posts: 0

Hi Harley,

Sorry saw your post only now!
I'm not really sure what made the mht go wrong and what set it right again. At the time (as this thread shows) I tried everything.
I believe it is different on XP than on Vista.
You should be able to rightclick mht, choose internet explorer as default for opening those files and then it should be allright.

Hope that works, if not, post back and maybe someone else has an idea.
I've never worked with XP, so I don't really know what the difference with Vista is.

Cheers,
Sarah.

Posted 9 years ago
Top
 
SarahJames
Posts: 0

OK, for 10 months I've been ok, but now I updated to IE 8 and what do you know?
Yeah right, mht has died on me again ...
And I don't know what made it work the first time ... LOL

Posted 9 years ago
Top
 
LH
Posts: 0

Uninstall IE8, and use IE7. Then instigate this,
http://www.microsoft.com/downl.....laylang=en

Posted 9 years ago
Top
 
SarahJames
Posts: 0

@ LH - I'm back at IE7, but can't get the blocker for IE8 to work ...

Posted 9 years ago
Top
 
LH
Posts: 0

Do you have Windows Update set to Auto update ?

Posted 9 years ago
Top
 
SarahJames
Posts: 0

No, I get a request.

Posted 9 years ago
Top
 
LH
Posts: 0

The next time IE8 arrives to download, kill it. It's right click, something!

Posted 9 years ago
Top
 
SarahJames
Posts: 0

LOL LOL LOL - kill it!
Well, I did - only is it called 'hide update' ;)

Thanks!

Posted 9 years ago
Top
 
LH
Posts: 0

Well there you go :)

Posted 9 years ago
Top
 
jamescoll
Posts: 0

I had a very similar problem with .mht files and generally IE8 acting up (I'm on vista). I reinstalled IE8 but same problem.
I resolved the issue by locating the iexplore.exe file (it was in C:\Windows\winsxs\x86_microsoft-windows-ie-internetexplorer_31bf3856ad364e35_8.0.6001.18702_none_124d22632fc9f126problem ) and copying it to C:\Program Files\Internet Explorer. All problems resolved!

Posted 8 years ago
Top
 
LH
Posts: 0

jamescoll. Thanks. You have registered 2 HTG accounts. You are only allowed 1. Which would you like to keep ?

Posted 8 years ago
Top
 
SarahJames
Posts: 0

Jamescoll - bit long ago, but I tried what you did, but it didn't help. Thanks for offering anyway:)

Posted 8 years ago
Top
 
Jack333
Posts: 0

Hi, I ran into the problem of saved .mht files not opening in IE (now 8) in Feb, 2010, looked around heaps, and found a way to fix the .mht files with an explaination. Unfortunately, I just fixed the file I needed and didn't save the reference. It added a "--" at the end of the file. Here's how to fix the individual saved .mht files:
1. Open the .mht file in a text editor like WordPad.
2. Scroll to the bottom, end after the last character.
3. Add “--“
4. Save it, it will now open in Internet Explorer!

Hope this helps.

Posted 8 years ago
Top
 



Topic Closed

This topic has been closed to new replies.