The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows Vista

(Solved) - How to turn Windows Firewall on

(24 posts)
  • Started 9 years ago by Shkumbin
  • Latest reply from nyess418
  • Topic Viewed 28859 times

Shkumbin
Posts: 0

Hi all.
I can't turn on my windows firewall, I open security center-firewall then "turn on" option but there opens a window writes: "Security Center can't turn on Windows Firewall" / "Turn on manually(with underline to hand click on it)" when i hand click it, opens a window named "Windows Firewall" then I go "turn windows firewall on or off(with underline hand click)" when i click this opens a window saying: "Windows Firewall settings cannot be displayed because the associated service is not running.Do you want to start the Windows Firewall service?" and i click yes but then opens a window saying: "Windows cannot start the windows Firewall.
I don't know where's the problem and how to fix it?

Waiting for help.
Thanx all. I've got trust in u, because u have solved me some previous problems.

Posted 9 years ago
Top
 
Scott
Posts: 0

From Start>run, type in services.msc and make sure 'Windows Firewall' is Started and set to Automatic. Any other firewall you have (i.e. AVG) could be interfering as well

Posted 9 years ago
Top
 
Onlinebrowser
Posts: 0

Had the same problem.I did a system restore.

Posted 9 years ago
Top
 
pumpkinman
Posts: 0

i would say you have a corrupt file

Posted 9 years ago
Top
 
whs
Posts: 0

Just make sure you don't have 2 firewalls running at the same time - that spells trouble. Security suites have a tendency to turn their own firewalls on and turn the Vista firewall off. Exception is the firewall in the router. That can be additional and is probably your best firewall.

Posted 9 years ago
Top
 
Shkumbin
Posts: 0

Thanks Scott. I tried this (services.msc) but nothing it doesn't turn windows firewall on. When i press "start" opens a window "Services" saying:"Windows could not start the Windows Firewall service on Local Computer. Error 1068: The dependency service or group failed to start."
But before installing "AVG 8.0 Free" i had Bitdefender it had his own firewall then i uninstall it(Bitdefender) and i installed "AVG 8.0 Free" but in "Security Center- Windows Firewall" in the list on the firewall is and BitDefender Firewall( u know in the list of firewalls which one do u want to choose to turn on) But if i click the option "I'll turn on BitDefender Firewall myself" nothing happens, just that windows closes.
And i think it is interfering with windows firewall. But i don't know how to remove Bitdefender from the list of firewalls because i have uninstalled it.

OnlineBrowser: system restoring hmmm. i don't know i would like to let this the last :) and i don't if i can do this because this problem i have since months ago and i don't have a created restore point in that time.

pumpkinman: maybe that is.

All Thanks

Posted 9 years ago
Top
 
Shkumbin
Posts: 0

whs: i don't know there can be a option bitdefender firewall is not uninstalled, even when i had "bitefender total security" i have uninstalled.

Thanx.

Posted 9 years ago
Top
 
ScottW
Posts: 0

Shkumbin, you seem to have a lot going on over there. There may be pieces of BitDefender left lying around on your system since it still shows up on the firewall list. See if there are still Add/Remove entries for it with Revo Uninstaller and/or Windows Installer Clean Up Utility. After an uninstall, run CCleaner on the registry to get rid of any last remnants of BitDefender.

To check for, and correct, corrupt system files, use the System File Checker (SFC). From an elevated command prompt, run:

> sfc /scannow

After all of that, restart and see if Windows Firewall will start. If not, then we will move on to looking at what is stopping it.

Posted 9 years ago
Top
 
Shkumbin
Posts: 0

Hi ScottW thanx for help. I did System File Checker(SFC) and this were the results(i have copied all cmd):
C:\Windows\system32>sfc /scannow
Beginning system scan. This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.Windows Resource Protection found corrupt files but was unable to fix some of them.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log

Posted 9 years ago
Top
 
ScottW
Posts: 0

Shkumbin, see if you can find the CSB.log file and try these instructions from MS on analyzing the entries:
http://support.microsoft.com/kb/928228

This corrupt file might be the cause of the firewall problem, or it might not be. However, we should try to eliminate this error from SFC before proceeding with other debug.

Posted 9 years ago
Top
 
Shkumbin
Posts: 0

Hi SocottW, thanx for helping me. I did what says in "support microsoft" but nothing, i tried to turn windows fairewall on but i couldn't. And in the list the BitDefender firewall it's not removed.
Thanx.

Posted 9 years ago
Top
 
whs
Posts: 0

To get rid of the remnants of BitDefender you may want to try this. http://antivirus.about.com/gi/...../kb/290301
PS: If you happen to get the German version, top right on the page you can switch it to English.

Posted 9 years ago
Top
 
ScottW
Posts: 0

So, there were no entries in CBS.log that identified a problem file? Try restarting your system and run the SFC again. I have seen it before that sometimes a second scan will run clean after an error.

For Windows Firewall, let's find out the status. Run the following commands from an elevated Command Prompt:

> sc queryex mpssvc
> sc qc mpssvc

Post the output of those commands here. The second command will give a list of dependencies for the Firewall service. On mine the dependencies are:

DEPENDENCIES : mpsdrv
: bfe

Posted 9 years ago
Top
 
cssloth
Posts: 0

Hi I have a similar problem, my firewall service will not start. I have tried all the suggestions, when i did the sc comamnds posted in the comment above i got "[SC] OpenService FAILED 1060: The specified service does not exist as an installed service." I got the same message twice.

Posted 9 years ago
Top
 
ScottW
Posts: 0

cssloth, Hi and welcome. Please start another thread (topic) for yourself. Even if two people have the exact same problem, which is rare, it's difficult to manage more than one user per thread. Please tell us your OS in the new thread.

Posted 9 years ago
Top
 
Shkumbin
Posts: 0

Thanx, ScottW for help, I resovled the problem with cmds u gived me.

Thankx a lot ScottW.

Posted 9 years ago
Top
 
Shkumbin
Posts: 0

SOLVED

Posted 9 years ago
Top
 
ScottW
Posts: 0

Shkumbin, that's great news! Can you tell us what you needed to do to get the firewall running again? It can be helpful when diagnosing the same or similar problem in the future. Thanks.

Posted 9 years ago
Top
 
k9
Posts: 0

I have a question - Why would anyone want to turn on the Windows firewall? There are loads of better firewalls out there I believe, and Comodo firewall being one of the best (so I've heard) and its free!!

Posted 9 years ago
Top
 
Lighthouse
Posts: 0

It's very much a matter of what you prefer. Windows Firewall gets a blasting, but it does the job. If I were you, I would try Comodo first, and then comment on it.

Posted 9 years ago
Top
 
kumi
Posts: 0

I don't know but THANX ALL.

Posted 9 years ago
Top
 
Shkumbin
Posts: 0

I don't know but THANX ALL.

Posted 9 years ago
Top
 
Lighthouse
Posts: 0

Shkumbin/kumi. Which of you accounts would you like to use please?

Posted 9 years ago
Top
 
nyess418
Posts: 0

I have the same porblem what fixed it ?

> sc queryex mpssvc
> sc qc mpssvc

Post the output of those commands here. The second command will give a list of dependencies for the Firewall service. On mine the dependencies are:

DEPENDENCIES : mpsdrv
: bfe

Posted 9 years ago
Top
 



Topic Closed

This topic has been closed to new replies.