The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows Vista

How to remove "Personal Safe Icon" from my desktop?

(9 posts)
  • Started 11 years ago by PatrickKevin
  • Latest reply from bellas1777
  • Topic Viewed 6849 times

PatrickKevin
Posts: 0

subj

Posted 11 years ago
Top
 
LH
Posts: 0

Try,
http://www.filehippo.com/download_unlocker/

Posted 11 years ago
Top
 
PatrickKevin
Posts: 0

Installed the latest version of Unlocker...doesn't work with "Personal Safe" on my Desktop

Posted 11 years ago
Top
 
LH
Posts: 0

Try,
https://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/
and then delete it.

Posted 11 years ago
Top
 
PatrickKevin
Posts: 0

I think you are using a wrong approach. It is NOT a real folder (and a shortcut neither). It is an icon. It's smth like Internet Explorer icon - type object on the Desktop.

Posted 11 years ago
Top
 
LH
Posts: 0

So what does it say in it's Properties ?

Posted 11 years ago
Top
 
PatrickKevin
Posts: 0

It has no such a line like "Properties" when I right-click it.

Posted 11 years ago
Top
 
LH
Posts: 0

In Fingerprint Reader > Control Center > File Safe > Personal Safe,
Does it give you the option to not show the icon ?

Posted 11 years ago
Top
 
bellas1777
Posts: 0

I have had this problem for ages and eventually tracked it down to Protector Suite. If you uninstall that through Add/Remove Programs or Programs & Features (assuming you don't use that program) the icon should go away.

Posted 11 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

The Best Tech Newsletter Anywhere

Join 250,000 subscribers and get a daily digest of news, geek trivia, and our feature articles.