The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Windows 7

External hard drive prevents boot-up

(13 posts)
  • Started 9 years ago by keno54
  • Latest reply from jeremyfisher
  • Topic Viewed 18341 times

keno54
Posts: 0

First - I am a self-taught amateur, so please excuse any sloppy use of technical terms.

I have a Dell brand computer (Vostro 400). I just installed Windows 7. In preparation for the install, I bought an Iomega Prestige 1TB external hard drive and made a disk image backup before the install. I also have a Maxtor One Touch external hard drive hooked up. I did the install. Updated all of the programs and re-started Windows numerous times during the install process. No problems. Restored my data from the Iomega external hard drive. Everything was working fine, and I shut down for the night.

Next morning, Windows would not start. I could get to the boot menu, and I made sure it was starting from hard drive. It would then go to Windows starting screen, and nothing would happen. I eventually have to turn the power off, since I am unable to change anything with the keyboard (ctrl,alt,del does nothing, none of the F buttons do anything, so I hold the power button until it shuts down).

So, I re-install Windows 7 (after once again reformatting). Hours later, same problem.

Long story short, I have now figured out that if the Iomega external hard drive is connected, Windows won't start. I can get to the boot menu and choose to start from the hard drive, no Windows start. I tried the recovery disk and told the boot menu to start from the CD. No dice - it won't run (and I separately tested the recovery disk before starting the install and I know it normally works). I unplugged the Iomega drive and restarted. Bingo - no problem. Windows starts up perfectly. Once Windows is up and running, I can re-connect the Iomega and use it and the information on it with no problem. I can even restart from Windows with the Iomega connected, so long as I don't do a complete shut down. As soon as I completely shut down, Iomega slams the computer and Windows will not open.

I should also mention that I can leave the Maxtor connected and Windows will start up perfectly from a complete shutdown. It is only when the Iomega is connected that I have a problem. And it renders the computer unusable until I disconnect it.

I did some digging (hours so far) on this site (I didn't find anything) and other internet sites, So far, nothing has solved the problem. At this point, I am simply disconnecting the Iomega after shutdown and reconnecting after Windows is fully loaded. That is a pain and makes it hard to deal with.

In my digging I found the following on the issue:

"Solution #1
posted on Sep 12, 2009
Not Rated)

Crankstart
Crankstart

Rank: Guru
Rating: 92%, 262 votes
Hi,

Assuming this is a windows machine it's likely one of two things, either the machine was re-installed/repaired while the drive was attached and the boot sector may have been moved to the external drive by accident. The other is that the Virtual memory file may have been moved to the external drive which would prevent windows from loading.

If you have repaired the machine lately you may need to re-repair it with the drive detached in order to solve the problem. If not right click on my computer, select properties. When the new window opens select advanced then click the settings button in the performance section. Again select the advanced tab, Click the change button on the Virtual Memory section and remove any reference to memory being used on the external drive. If it is the only drive listed as using memory, be sure to add at least 2GB(2048MB) to the C drive first.

Let me know how you make out,

Chris " (from http://www.fixya.com/support/t.....ernal_hard)

Does anyone have any ideas? What do you think of the ideas from "Chris" above?

Posted 9 years ago
Top
 
ispalten
Posts: 0

Well. off-hand the external drive could be set in BIOS as the BOOT DRIVE and it doesn't have a boot sector on it?

Check the BIOS and see if USB (if it is that) or it is enabled as a SATA boot drive (check the boot order).

If you press SPACE BAR before Windows starts and after the BIOS screen do you get the Windows screen for testing? If you use F8 what shows as the normal boot drive from that screen or F12 when booting after the BIOS screen appears?

Irv S.

Posted 9 years ago
Top
 
keno54
Posts: 0

Irv - thanks for the response.

I have checked the BIOS setup. The boot menu shows my internal hard drive (C:) as first, USB external hard drive (Maxtor) second, and USB external hard drive (Iomega) as third.

I tried the space bar before Windows starts. I got a screen that asked to specify operating system and that would allow testing, also a choice for advanced options at F8. Everything shows internal drive first.

I did not see a choice disabling USB boot choices, but I once again point out the the Maxtor stays connected and does not cause a boot problem.

Posted 9 years ago
Top
 
ispalten
Posts: 0

Try going into the BIOS and removing the Iomega from booting. Matter of fact, if the Maxtor isn't a boot device, remove it too. See if that helps.

There should be a BIOS screen for BOOT ORDER and also what is considered (on my Dell at least, and XPS) the device groups for booting. Normally, at least the way I do it, it to set the first CD/DVD as bootable first, followed by the bootable disk drives (only ones that have boot partitions on it and NOT via Dual Boot). If I should want to boot off of a USB Flash drive, my BIOS only shows that choice when the drive is in the system otherwise it doesn't show.

BTW, Iomega it seems has an FAQ on this problem, it must happen a lot with their drives.

Irv

Posted 9 years ago
Top
 
keno54
Posts: 0

Irv - again, thanks for the response. I am not at my office now, but will try your suggestions when I get back later today. I did find the Iomega FAQ after posting this querry.

From memory, I do not recall there being a choice of removing either the Maxtor or the Iomega from the Boot Order scheme. They are both detected as hard drives when connected, with the internal drive listed first, the externals on down the list. But I looked for, and do not recall seeing, a way to remove them from the boot list. Can you offer a suggestion on how to do that?

After finding the Iomega FAQ, I dug around the internet and found multiple discussions that indicated that the Dell bios's had an internal limitation of 137 gigs as the maximum size of a hard drive it could deal with. That makes no sense to me as an external drive that is not a boot drive, but again, I am by no means a computer expert. And it is mentioned by Iomega. But the one thing that really makes me question that is that my computer came from Dell with an internal 250 gig hard drive.

Do you know if there is any way to find the capacity of the BIOS? I tried to find that information on the Dell site. Might as well have asked someone off the street. It takes forever to get a nonresponsive response.

At any rate, your help is appreciated. I will let you know what I find when I return to my office this afternoon.

Posted 9 years ago
Top
 
ispalten
Posts: 0

Keno,

In my Dell BIOS I have 2 areas I can make choices. First one is the BOOT SEQUENCE. It lists 'groups', like disk drives and cd/dvd drives. On another page I have the DEVICES, again listed by groups, disk drives and cd/dvd drives. I can't open it right now so I can't give exact names.

Anyway, for the BOOT SEQUENCE, you can select the order of which the BIOS will look for the boot record, if it isn't found on the first, it searches the 2nd, and so on. When you click on the items it opens a small window and you can then either move this as well, or even disable the ones without a boot record on them.

Go HERE and look at page 178 on how to do this.

I suspect this is what is KILLING you,

____________________
Removable Device Priority Used to set the device priority of removable devices like
USB floppy drives. The items displayed are dynamically
updated according to the removable devices connected.
________________

When the External drive is plugged in, it tries and fails to boot from it, but can't go onto the next drive, it might have a MBR on it? Disabling this boot device or disconnecting of course works.

The 137GB limit, well, it was REAL many years ago. Before the advent of drives over 137GB's, BIOS was able to handle the disk sector addresses in 28 bits, and this limited the size to 137GB's. Of course once those drives sizes were surpassed, a BIOS change was required. Most manufacturers went to 48 or 64 bits to handle the sector count and released BIOS upgrades. Today, this is standard practice and all recent systems are built with this already adopted. See HERE for more info and reading if you are interested.

Irv S.

Posted 9 years ago
Top
 
keno54
Posts: 0

Irv - again, thanks. I looked at your references and then went to the Boot Device Configuration. I disabled all boot devices except the CD and the Hard Disk (the other devices listed were "Removable" and "Boot Other Device"). Same issue. With the Iomega connected, it gets past the Dell screen (which gives me the F2 setup and F12 Boot Menu screens), and puts the "Starting Windows" screen, but it never gets past there. I power down, disconnect the Iomega, re-start, and no problem. I should also point out the even though the "Removable" and "Other" are disabled, the One Touch and the Iomega still show up under the "Hard Disk Boot Priority" section - as USB HDD0 and USB HDD1. There is no way to remove or disable them on that screen. The Vostro manual says to use the space bar to disable, but that does nothing on my machine.

Regarding whether there is an MBR on the Iomega, I don't know how to tell that.

I opened the Windows Explorer screen for the Iomega and there is a "System Volume Information" folder and an "$AVG" (I have AVG antivirus installed, but I am not sure how that got onto the Iomega drive - I did not consciously put it there) and a "$Recycle Bin folder". Other than that are the Acronis image files that I created before the Windows 7 install. Nothing else. The System Volume Information file says it is not accessible and access is denied (no choice to open as Administrator (even though I am the Administrator). Could that contain the MBR? I made a quick google search for how to determine if an MBR exists, but I didn't find anything that made sense to me.

I looked at the One Touch directory, and it also has an $AVG and System Volume Information (also inaccessible) files.

I unfortunately have to travel for the next three days and will not be able to dig much further into this until next week.

I very much appreciate your help. If you have any other thoughts or suggestions, please let me know.

Should I re-set the Boot Device Configuration back to where it was originally since those changes didn't fix the problem?

Thanks again, Keno54.

Posted 9 years ago
Top
 
ispalten
Posts: 0

Keno,

The MBR or Master Boot Record is a hard coded sector in the BIOS. As a system boots, the BIOS loads that SPECIFIC sector into memory and jumps to it. All BIOS do this one task after they initialize the system and other 'work'. All PC's work the same, and hard disks that are bootable have this MBR, Master Boot Record, in the same location of memory. Once the MBR is loaded, control is passed to it and it then starts loading the OS as the MBR has specific code to do so. Location of this is the first PHYSICAL Sector of a disk. A binary disk editor would allow you to read this data. For more MBR info, check THIS LINK for a good explanation of the MBR and booting process.

The directories 'System Volume Information' and '$Recycle bin' are system created if you have SYSTEM RESTORE and a Trash Bin on for that drive, they appear automatically. Guess $AGV if from AVG's security suite, maybe the drives quarantine location, again, not something that you create but the app does.

=======================
"I should also point out the even though the "Removable" and "Other" are disabled, the One Touch and the Iomega still show up under the "Hard Disk Boot Priority" section - as USB HDD0 and USB HDD1. There is no way to remove or disable them on that screen. The Vostro manual says to use the space bar to disable, but that does nothing on my machine."
==================

If it is like most BIOS', what you have to do is 'select' those, that is press ENTER and then the OPTION will appear. It may be different on your BIOS though?

The document reads

------------------
Changing Boot Sequence for Future Boots
1 Enter system setup (see "Entering System Setup" on page 174).
2 Use the arrow keys to highlight the Boot Sequence menu option and press
<Enter> to access the menu.
NOTE: Write down your current boot sequence in case you want to restore it.
3 Press the up- and down-arrow keys to move through the list of devices.
4 Press the spacebar to enable or disable a device (enabled devices have a
checkmark).
5 Press plus (+) or minus (–) to move a selected device up or down the list.
=======

It sort of indicates that you can disable it for booting purposes doesn't it?

More here,

==============
Boot Device Configuration
Removable Device Priority Used to set the device priority of removable devices like
USB floppy drives. The items displayed are dynamically
updated according to the removable devices connected.

Hard Disk Boot Priority Used to set the device priority of hard drives. The items
displayed are dynamically updated according to the hard
drives detected.

First Boot Device Removable; Hard Disk; CDROM; USB-CDROM; Legacy
LAN; Disabled (Removable by default)

Second Boot Device Removable; Hard Disk; CDROM; USB-CDROM; Legacy
LAN; Disabled (Hard disk by default)

Third Boot Device Removable; Hard Disk; CDROM; USB-CDROM; Legacy
LAN; Disabled (CD-ROM by default)

Boot Other Device Enabled; Disabled (Disabled by default)
===============

I'd edit REMOVABLE drive to OFF/DISABLED.

I'd edit Hard Disk Boot to be ONLY the C: drive.

I'd edit First Boot Device Removable to be CDROM.

I'd edit Second Boot Device Removable to be Hard Disk, which by the above setting would be only the C: drive.

This should clear the problem.

Irv S.

Posted 9 years ago
Top
 
keno54
Posts: 0

Irv - last one for the night. I went back in to the Boot Device Configuration, and my BIOS is apparently different than most. When i get into the Hard Drive Disk Boot area, there is no way to remove or disable the two USB HDD drives - I tried "Enter" and even delete - I cannot get those two devices out of the listing, nor is there any choice to disable. I did everything but take an eraser to the screen. I can't change or delete them. So I did arrange the order as you suggested - removable is disabled, CD Rom is 1st, Hard Drive is 2nd (but there is no way to provide that C: is the only hard drive to consider - although it is listed first in the order). I moved the Iomega down to last in that order.

I do note that when I start the computer up, it goes to the Dell page (with the Setup F2 and Boot Menu F12 choices) and if I don't interrupt it and go into the setup or boot order menu (F12), I hear the Iomega disk spin up for a few seconds. Then the Windows Starting page comes up, then it hangs. Obviously, it is going to the Iomega to get instructions. Finding none, I guess it just sits.

This is aggravating beyond description.

At any rate, I once again sincerely thank you for you assistance and perseverance. I have three long travel days ahead, so I will have to leave it behind for now. Thanks for your patience, my friend.

Keno

Posted 9 years ago
Top
 
ispalten
Posts: 0

Keno,

A couple of thoughts, not in any particular order.

1) The BIOS you have may not be the latest, check the DELL Support site for your computer, the latest is 1.0.15 (HERE). Even if you have the latest, re-install it to be sure it is correct. You'll find the version either on the first screen or when you use F2.

2) It is possible the IOMEGA did have a prior boot record on it (sector 0) that points into the drive for a file that can't be found, and since it is a 'real' MBR, the BIOS is 'done' and doesn't look for other MBR's. Fix may be to delete ALL partitions and re-partition and format.

3) On the Windows CD is a program called FIXMBR. It might just fix the MBR if you run it with that drive as the root, that is open a command prompt, change to that drive and the using the command fixmbr \Device\HardDiskx, where x is the IOMEGA drive. I don't think it can hurt anything but you might not be able to easily determine the IOMEGA drive description in terms of \Device\HardDiskx.

4) If under warranty for the computer, call Dell. If the IOMEGA is under warranty, call Iomega?

5) Keep the IOMEGA unplugged until needed?

As you can see, I'm grasping at straws here.

Last thing I'd try I guess is RESETTING the CMOS settings and try setting it up again. Have the IOMEGA disconnected so it doesn't scan it when you power back up. HERE is an HTML version of the manual, might be easier to read, and look at the FLASHING THE BIOS and CLEARING THE CMOS pages specifically.

Irv S.

Posted 9 years ago
Top
 
keno54
Posts: 0

Irv - just getting back in the saddle after a long weekend.

Regarding the BIOS, mine is 1.0.15. I tried the BIOS re-install, and my computer wouldn't let it happen - said something to the effect that program was already installed and operation was prevented. I will now try to investigate how to reload the BIOS even though it says not to.

I think fix #2 may be the way to go. I will need to brush up on how exactly to do that. My concern is that the Iomega drive contains my pre-7 drive image, my second one is on the Maxtor drive, and I do not trust the Maxtor drive. At any rate, once I get comfortable with everything, I think I will image this W7 setup, wipe the Iomega disk clean and then re-image back on the Iomega.

Probably the best option of all is simply to leave the Iomega off until I need it. It was my hope to establish a daily backup program with the Iomega (I work from home and my home office computer is the master), but that will be too much for my feeble mind to keep track of if I have to make sure to turn it on and off before booting up. It's just that little things like that drive me crazy. I know there is a way to fix it, and from time to time I will get hacked off and try it again.

At any rate, I have wasted about all the time even I can justify on this one. Once again, I truly appreciate all of your efforts to help me out.

A sincere thanks to you, Irv.

Keno

Posted 9 years ago
Top
 
somp
Posts: 0

Keno,
May I make an observation. I see that you have the latest Bios as posted at Dell, you can set back to factory setting in Bios which I believe it is called reset. Did you have this problem with previous OS, if not, then Bios is not the problem. Intel has newer Chipsets installation utility for Win 7 on their website, although it claims that it will not solve USB driver problems. In search box, type disk management, it will bring you to list of disks connected to the computer. Your Iomega drive should list as simple volume,healthy partition. If it lists as Active, you can copy your image to Maxtor first, come back and check action-all tasks-delete volume. You can then make new partition, it will then format the drive and finish.

Regards,
Somp

Posted 9 years ago
Top
 
jeremyfisher
Posts: 0

I toiled with the same problem all day yesterday and found the solution on this thread:

http://social.answers.microsof.....38676e0880

For me it was disabling USB legacy support in the bios that worked.

Best of luck

Posted 8 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

The Best Tech Newsletter Anywhere

Join 250,000 subscribers and get a daily digest of news, geek trivia, and our feature articles.