The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

Can't boot to Windows 7: Bootmgr has been formatted

(5 posts)
  • Started 7 years ago by tjololo
  • Latest reply from raphoenix
  • Topic Viewed 1530 times

Posts: 2

Ok, I'll try to make this short because this is the second time I've written it (last time the browser crashed and I lost everything, grr!!!).

Situation 1: Working computer: HP dv5-1160us with windows vista and recovery partition.
Situation 2: working computer: Installed windows 7 between Vista and Recovery. Partitions: sda1: vista sda2: 7 sda3: recovery
Situation 3: Half-working computer (can boot fedora): Deleted partitions 1 and 3, moved partition 2 to the left and expanded, installed Fedora 12. Partitions: sda2: 7 sda1: /boot sda3: fedora
Situation 3: Half-working computer (can boot fedora): Relabeled partitions and reinstalled fedora. Partitions: sda1: 7 sda2: /boot sda3: fedora

I'm trying to fix the boot sector on Windows 7. After doing research (should have done it before, I curse myself for not researching), I found out that 7 installs its boot entry on Vista's boot sector and doesn't even write one of its own.

Here's the big issue: I've tried going into the Windows 7 install cd, running repair my computer and doing things from there, but the issue is it doesn't see my operating system (doesn't list it when you first select "repair my computer"). I've gone in manually to repair the bootloader by hand. I've used two sets of instructions, one of which I found on (google search neosmart Recovering Vista bootloader from DVD and you'll find it) which is the most comprehensive. It has me do the following commands:

del C:\boot\bcd (didn't work, there is no c:\boot. I had to mkdir c:\boot then move on)
bcdedit /createstore C:\boot\bcd.tmp (worked)
bcdedit.exe /store c:\boot\bcd.tmp /create {bootmgr} /d "Windows Boot Manager" (worked)
bcdedit.exe /import c:\boot\bcd.tmp (error: partition contains unrecognized file system. Please install drivers for hard drive then try again)

And that's as far as I've gotten. I've tried bootsect.exe /nt60 all /force, which says it worked, but then following it with a bootrec.exe /rebuild bcd lists windows 7, I hit accept, and it gives me the unrecognized file system error.

I'm at a loss here. I managed to make an image of that partition with linux to back up my data. Here's what I was thinking:
Option A: I reformat and reinstall, then copy the boot sector, put it into my image, then restore that image to the partition. Issues: I'm not sure how to add it to a .img.gz image I made with dd of a full partition.
Option B: I repair the boot sector on my Windows 7 partition. Issues: I don't know how or I would have done it already
Option last-resort-oh-god-please-no: I reformat and reinstall, back up my data, and eat the loss of all my programs. Issues: I like my programs and I don't know where to get them all again...Plus I don't want to have to re-purchase them all.

So there's my issue, sorry about the novel, but I'm trying to be specific and give you all the info you need to know. I'm also going to tag on the results of an fdisk -l from my linux so you all can see hopefully where the troubles lie.

[scott@Mike ~]$ sudo fdisk -l
[sudo] password for scott:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x38c0dbaf

Device Boot Start End Blocks Id System
/dev/sda1 1 19122 153597433+ 7 HPFS/NTFS
/dev/sda2 * 19123 19148 204800 83 Linux
/dev/sda3 19148 38913 158766407+ 8e Linux LVM

Disk /dev/dm-0: 157.3 GB, 157257039872 bytes
255 heads, 63 sectors/track, 19118 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 5318 MB, 5318377472 bytes
255 heads, 63 sectors/track, 646 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table

Posted 7 years ago
Posts: 1

bootmgr problem is exactly the same as tjololo

Posted 7 years ago
Posts: 1521

donald4168, please post your question in a new topic.

Posted 7 years ago
Posts: 2

So no advice from anyone? I was hoping to get this done, things are starting to pile up. I guess since I have the backup of my partition I'm going to reinstall, then if anyone thinks of a way I can fix it I'll follow their advice.

Posted 7 years ago
Posts: 14920

You have a one hard drive OEM PC with Windows preinstalled which gives you very few options for doing anything.
My Best personal advice is to download the Machine OEM Device drivers, put them on a CD or Memory stick, Obtain a FULL copy of Windows, Nuke the complete hard drive with Dban and Clean install the system.
With a FULL copy of Windows, you will have many more options.
Best Regards,
Rick P.

Posted 7 years ago

Topic Closed

This topic has been closed to new replies.