How-To Geek Forums / Windows Vista

The How-To Geek Forums Have Migrated to Discourse

Topic Posts
Using Wireless "N" With NetGear Router
Last post by ispalten about 5 years ago
Latest Post 18
What is Nissrv.exe? It's a newly installed update.
Last post by Itanaman about 6 years ago
Latest Post 5
(Solved) - HELP!! Unable to run system recovery(OS not detected)
Last post by banananut about 6 years ago
Latest Post 6
Latest Post 4
(Solved) - My computer can't find my files
Last post by GuiltySpark about 6 years ago
Latest Post 10
startup repair repeating on reboot (vista)
Last post by mostlyharmless about 6 years ago
Latest Post 18
(Solved) - Virtual Clone Drive not mounting ISO
Last post by brownlids about 6 years ago
Latest Post 10
(Solved) - what is ssr?
Last post by germ-x about 6 years ago
Latest Post 13
(Solved) - SD/MMC card reader not working !
Last post by LH about 6 years ago
Latest Post 15
(Solved) - Connecting Outlook 2007 with Hotmail
Last post by LH about 6 years ago
Latest Post 19
Need help restoring windows vista back to factory settings -23
Last post by nemico about 6 years ago
Latest Post 42
pc cooling fan plastic mounting clips to motherboard
Last post by LH about 6 years ago
Latest Post 8
Does anyone know if this is normal for Superantispyware? -2
Last post by ispalten about 6 years ago
Latest Post 22
rundll32
Last post by ispalten about 6 years ago
Latest Post 5
Vista: Bootmgr is missing and no operating system showing -2
Last post by germ-x about 6 years ago
Latest Post 24
(Solved) - Switch b/ 5GH & 2.4GH?
Last post by ixijackixi about 6 years ago
Latest Post 5
Strange Apostrophe Key stroke behaviour
Last post by LH about 6 years ago
Latest Post 5
How to view recent activities in my computer.
Last post by germ-x about 6 years ago
Latest Post 4
Latest Post 4
BootMGR Missing + No OS Installed -2
Last post by whs about 6 years ago
Latest Post 21
(Solved) - Very slow PC restart
Last post by StringJunky about 6 years ago
Latest Post 5
emit a wifi signal from a desktop computer?
Last post by G41M about 6 years ago
Latest Post 2
(Solved) - Weird file
Last post by Tobacktothefuture about 6 years ago
Latest Post 3
Windows Vista Boot Manager is missing or corrupt
Last post by MaxRomz about 6 years ago
Latest Post 16
Default back to factory settings without disk
Last post by G41M about 6 years ago
Latest Post 2
(Solved) - LITTLE BLACK SQUARES
Last post by germ-x about 6 years ago
Latest Post 18
Adding video Memory
Last post by arcanecasster about 6 years ago
Latest Post 9
(Solved) - error code 43
Last post by Atlas about 6 years ago
Latest Post 8
MPEG-2 encoder is missing!!! -23
Last post by LH about 6 years ago
Latest Post 48
Setting up a SSH tunnel
Last post by zs474 about 6 years ago
Latest Post 3

Forums Topics Posts
Windows Vista
14,578 93,275
Windows 7
11,690 70,873
Windows 8
469 3,155
Windows XP
8,336 49,604
Linux
1,094 4,511
Apple / OS X
493 1,933
Microsoft Office
2,112 7,862
Geek Stuff
6,546 39,418
Build Your Own PC
1,453 11,295
Site Suggestions
358 2,616
Tutorials
323 1,443
Disability Tech
61 283
Off Topic
3,555 43,090
Buy / Sell Forum
46 342