<!DOCTYPE html>
<html lang="en-US">
<head>
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="amp-ad-enable-refresh" content="doubleclick=30">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel="preload" href="/public/htgfonts/htgfonts.css" as="style">
<style type="text/css">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</style>
<link rel="stylesheet" href="/public/htgfonts/htgfonts.css">
<link rel="preload" as="image" href="https://www.howtogeek.com/wp-content/uploads/2021/05/MS-excel-logo-675.png?width=1198&trim=1,1&bg-color=000&pad=1,1"/>
<!-- Future Aperture -->
<script>
	!function(n,e,i){if(!n){n=n||{},window.permutive=n,n.q=[],n.config=i||{},n.config.apiKey=e,n.config.environment=n.config.environment||"production";for(var o=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],r=0;r<o.length;r++){var t=o[r];n[t]=function(e){return function(){var i=Array.prototype.slice.call(arguments,0);n.q.push({functionName:e,arguments:i})}}(t)}}}(window.permutive,"253158cc-875d-4ed4-a52d-e954eca49313",{ "consentRequired": true });
	window.googletag=window.googletag||{},window.googletag.cmd=window.googletag.cmd||[],window.googletag.cmd.push(function(){if(0===window.googletag.pubads().getTargeting("permutive").length){var g=window.localStorage.getItem("_pdfps");window.googletag.pubads().setTargeting("permutive",g?JSON.parse(g):[])}});
</script>
<script async src="https://6093eccf-6734-4877-ac8b-83d6d0e27b46.edge.permutive.app/6093eccf-6734-4877-ac8b-83d6d0e27b46-web.js"></script>
<script src="https://freyr.futurecdn.net/freyr.js" async></script>
<script>
	window.freyr = window.freyr ? window.freyr : { cmd: [] };
	window.freyr.cmd.push(function(){window.freyr.setGaEnabledStatus(false)})
	window.freyr.cmd.push(function(){window.freyr.pushAndUpdate('pageLoadEvent', {})});
</script>
<!-- End Future Aperture -->
<script>window._htg_tags = ["features"];</script><title>How to Highlight Duplicates in Microsoft Excel </title>
<meta property="fb:page_id" content="65878196434"/>
<link rel="alternate" type="application/rss+xml" title="How-To Geek RSS Feed" href="https://feeds.howtogeek.com/HowToGeek"/>
<meta name="ROBOTS" content="INDEX, FOLLOW"/>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","author":{"@type":"Person","name":"Mahesh Makvana","url":"https:\/\/www.howtogeek.com\/author\/maheshmakvana\/","jobTitle":"Writer"},"mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/www.howtogeek.com\/816924\/excel-highlight-duplicates\/"},"publisher":{"@type":"Organization","name":"How-To Geek","logo":{"@type":"ImageObject","url":"https:\/\/www.howtogeek.com\/public\/images\/htgamp.png","height":60,"width":233}},"headline":"How to Highlight Duplicates in Microsoft Excel","name":"How to Highlight Duplicates in Microsoft Excel","datePublished":"2022-07-13T13:00:06-04:00","dateModified":"2022-07-12T10:55:57-04:00","description":"Do you want to find and optionally delete the duplicate entries in your spreadsheets? If so, use Microsoft Excel&#8217;s conditional formatting option to highlight duplicates and then select an option to remove those items. We&#8217;ll show you how.","image":["https:\/\/www.howtogeek.com\/wp-content\/uploads\/2021\/05\/MS-excel-logo-675.png?height=200p&trim=2,2,2,2&crop=16:9"]}</script>	<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@howtogeek">
<meta name="twitter:image" content="https://www.howtogeek.com/wp-content/uploads/2021/05/MS-excel-logo-675.png?height=200p&trim=2,2,2,2"/>
<meta property="og:site_name" content="How-To Geek"/>
<meta property="og:title" name="title" content="How to Highlight Duplicates in Microsoft Excel"/>
<meta property="og:type" content="article"/>
<meta property="og:description" name="og:description" content="Do you want to find and optionally delete the duplicate entries in your spreadsheets? If so, use Microsoft Excel&#8217;s conditional formatting option to highlight duplicates and then select an option to remove those items. We&#8217;ll show you how."/>
<meta property="og:image" content="https://www.howtogeek.com/wp-content/uploads/2021/05/MS-excel-logo-675.png?height=200p&trim=2,2,2,2"/>
<meta name="description" content="Do you want to find and optionally delete the duplicate entries in your spreadsheets? If so, use Microsoft Excel&#8217;s conditional formatting option to highlight duplicates and then select an option to remove those items. We&#8217;ll show you how."/>
<link rel="shortcut icon" href="/public/favicon.ico" type="image/x-icon"/>
<link rel="icon" type="image/png" href="/public/images/32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/public/images/96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/public/images/192x192.png" sizes="192x192">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<meta name="msapplication-TileImage" content="/public/images/144x144.png">
<meta name="msapplication-TileColor" content="#000">
<meta name="theme-color" content="">
<link rel='canonical' href='https://www.howtogeek.com/816924/excel-highlight-duplicates/'/>
<meta property="og:url" content="https://www.howtogeek.com/816924/excel-highlight-duplicates/"/><link rel="amphtml" href="https://www.howtogeek.com/816924/excel-highlight-duplicates/amp/"/>
<script>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</script>
<script>
	!function(e,n){"function"==typeof define&&define.amd?define([],n("adsenseLoader")):"object"==typeof exports?module.exports=n("adsenseLoader"):e.adsenseLoader=n("adsenseLoader")}(this,function(e){"use strict";var n="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js",t=!1,o=250,a={laziness:1,onLoad:!1},r=function(e,n){var t,o={};for(t in e)Object.prototype.hasOwnProperty.call(e,t)&&(o[t]=e[t]);for(t in n)Object.prototype.hasOwnProperty.call(n,t)&&(o[t]=n[t]);return o},i=function(e,n){var t,o;return function(){var a=this,r=arguments,i=+new Date;t&&i<t+e?(clearTimeout(o),o=setTimeout(function(){t=i,n.apply(a,r)},e)):(t=i,n.apply(a,r))}},s=[],d=[],c=[],u=function(e){(adsbygoogle=window.adsbygoogle||[]).push({});var n=e._adsenseLoaderData.options.onLoad;"function"==typeof n&&e.querySelector("iframe").addEventListener("load",function(){n(e)})},f=function(){if(!s.length)return!0;var e=window.pageYOffset,o=window.innerHeight;s.forEach(function(a){var r,i,f,L,y,g=(r=a,i=r.getBoundingClientRect(),{top:i.top+document.body.scrollTop,left:i.left+document.body.scrollLeft}).top,h=a._adsenseLoaderData.options.laziness+1;if(g-e>o*h||e-g-a.offsetHeight-o*h>0)return!0;s=p(s,a),a._adsenseLoaderData.width=l(a),function(e,n){e.classList?e.classList.add(n):e.className+=" "+n}(a.children[0],"adsbygoogle"),d.push(a),"undefined"!=typeof adsbygoogle?u(a):c.push(a),t||(t=!0,f=n,L=function(){c.forEach(u)},(y=document.createElement("script")).src=f,y.async=!0,y.addEventListener("load",function(){y.parentNode.removeChild(y),"function"==typeof L&&L()}),document.body.appendChild(y))})},l=function(e){return parseInt(window.getComputedStyle(e,":before").getPropertyValue("content").slice(1,-1)||9999)},p=function(e,n){return e.filter(function(e){return e!==n})},L=function(e,n){return e._adsenseLoaderData={originalHTML:e.innerHTML,options:n},e.adsenseLoader=function(n){"destroy"==n&&(s=p(s,e),d=p(d,e),c=p(d,e),e.innerHTML=e._adsenseLoaderData.originalHTML)},e};function y(e,n){"string"==typeof e?e=document.querySelectorAll(e):void 0===e.length&&(e=[e]),n=r(a,n),[].forEach.call(e,function(e){e=L(e,n),s.push(e)}),this.elements=e,f()}return window.addEventListener("scroll",i(o,f)),window.addEventListener("resize",i(o,f)),window.addEventListener("resize",i(o,function(){if(!d.length)return!0;var e=!1;d.forEach(function(n){n._adsenseLoaderData.width!=l(n)&&(e=!0,d=p(d,n),n.innerHTML=n._adsenseLoaderData.originalHTML,s.push(n))}),e&&f()})),y.prototype={destroy:function(){this.elements.forEach(function(e){e.adsenseLoader("destroy")})}},window.adsenseLoaderConfig=function(e){void 0!==e.scriptUrl&&(n=e.scriptUrl),void 0!==e.throttle&&(o=e.throttle)},y}),document.addEventListener("DOMContentLoaded",function(e){setTimeout(function(){var e=function(){new adsenseLoader(".htg-lazyload",{onLoad:function(e){}})};"undefined"!=typeof __tcfapi?__tcfapi("addEventListener",2,function(n,t){n?t&&("useractioncomplete"!=n.eventStatus&&"tcloaded"!=n.eventStatus||(n.purpose&&n.purpose.consents&&n.purpose.consents.length>2?(n.purpose.consents[1]||!1)&&e():e())):e()}):e()},800)});</script>
<script>
	window.showDoNotSellInfo = function() {
		var link = document.createElement('a');
		link.href = '#';
		link.innerText = 'Do not sell my info';
		var container = document.getElementById('show-do-not-sell-info-container');
		container.appendChild(link);
		return link;
	}

	window.validateAriaEmail = function(elem) {
		var re = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
	    if (re.test(elem.value)) {
			elem.setAttribute('aria-invalid', false);
		} else {
			elem.setAttribute('aria-invalid', true);
		}
	}
</script>
<!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script type="text/javascript" async=true>
	(function() {
		var host = window.location.hostname;
		var element = document.createElement('script');
		var firstScript = document.getElementsByTagName('script')[0];
		var url = 'https://quantcast.mgr.consensu.org'
		.concat('/choice/', 'uer8ZPXHG8WDU', '/', host, '/choice.js')
		var uspTries = 0;
		var uspTriesLimit = 3;
		element.async = true;
		element.type = 'text/javascript';
		element.src = url;
	
		firstScript.parentNode.insertBefore(element, firstScript);
	
		function makeStub() {
		var TCF_LOCATOR_NAME = '__tcfapiLocator';
		var queue = [];
		var win = window;
		var cmpFrame;
	
		function addFrame() {
			var doc = win.document;
			var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);
	
			if (!otherCMP) {
			if (doc.body) {
				var iframe = doc.createElement('iframe');
	
				iframe.style.cssText = 'display:none';
				iframe.name = TCF_LOCATOR_NAME;
				doc.body.appendChild(iframe);
			} else {
				setTimeout(addFrame, 5);
			}
			}
			return !otherCMP;
		}
	
		function tcfAPIHandler() {
			var gdprApplies;
			var args = arguments;
	
			if (!args.length) {
			return queue;
			} else if (args[0] === 'setGdprApplies') {
			if (
				args.length > 3 &&
				args[2] === 2 &&
				typeof args[3] === 'boolean'
			) {
				gdprApplies = args[3];
				if (typeof args[2] === 'function') {
				args[2]('set', true);
				}
			}
			} else if (args[0] === 'ping') {
			var retr = {
				gdprApplies: gdprApplies,
				cmpLoaded: false,
				cmpStatus: 'stub'
			};
	
			if (typeof args[2] === 'function') {
				args[2](retr);
			}
			} else {
			queue.push(args);
			}
		}
	
		function postMessageEventHandler(event) {
			var msgIsString = typeof event.data === 'string';
			var json = {};
	
			try {
			if (msgIsString) {
				json = JSON.parse(event.data);
			} else {
				json = event.data;
			}
			} catch (ignore) {}
	
			var payload = json.__tcfapiCall;
	
			if (payload) {
			window.__tcfapi(
				payload.command,
				payload.version,
				function(retValue, success) {
				var returnMsg = {
					__tcfapiReturn: {
					returnValue: retValue,
					success: success,
					callId: payload.callId
					}
				};
				if (msgIsString) {
					returnMsg = JSON.stringify(returnMsg);
				}
				if (event && event.source && event.source.postMessage) {
					event.source.postMessage(returnMsg, '*');
				}
				},
				payload.parameter
			);
			}
		}
	
		while (win) {
			try {
			if (win.frames[TCF_LOCATOR_NAME]) {
				cmpFrame = win;
				break;
			}
			} catch (ignore) {}
	
			if (win === window.top) {
			break;
			}
			win = win.parent;
		}
		if (!cmpFrame) {
			addFrame();
			win.__tcfapi = tcfAPIHandler;
			win.addEventListener('message', postMessageEventHandler, false);
		}
		};
	
		makeStub();
	
		var uspStubFunction = function() {
		var arg = arguments;
		if (typeof window.__uspapi !== uspStubFunction) {
			setTimeout(function() {
			if (typeof window.__uspapi !== 'undefined') {
				window.__uspapi.apply(window.__uspapi, arg);
			}
			}, 500);
		}
		};
	
		var checkIfUspIsReady = function() {
		uspTries++;
		if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
			console.warn('USP is not accessible');
		} else {
			clearInterval(uspInterval);
		}
		};
	
		if (typeof window.__uspapi === 'undefined') {
		window.__uspapi = uspStubFunction;
		var uspInterval = setInterval(checkIfUspIsReady, 6000);
		}
	})();
	</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script type="text/javascript">
	window.bordeaux = window.bordeaux || {};
	window.bordeaux.cmd = window.bordeaux.cmd || [];
	window.bordeaux.cmd.push(function(){
	var targeting = {
			kw: [],
			tag: ["features","microsoft-excel","microsoft-office"]
		};
	window.bordeaux.setTargeting(targeting);
		window.bordeaux.setPageTemplate('article');
		window.bordeaux.setPageCategory('article');
		window.bordeaux.init();
	});
	</script>
<script defer type="text/javascript" src="https://bordeaux.futurecdn.net/bordeaux.js"></script>
<style>
@media print {
	#masthead, .full-screen-menu, .adslot, .site-footer, #secondary , #purch_N_C_0_1, .social-media-buttons, .article-bottom, .jw-loaded, #purch_N_C_0_1 {display:none !important;}
	#page::before {
	    content: "How-To Geek";
	    font-size: 24px;
	    font-weight: bold;
	    padding-left: 20px;
	    width: 700px;
	    border-bottom: 1px solid black;
	    display: block;
	    margin: 10px auto;
	}
}
#purch-gdpr-banner {
	z-index: 9999999 !important;
	background-color: #555 !important;
}

</style>
<!-- Facebook Pixel Code -->
<script>
 setTimeout(function(){
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s) } (window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
   fbq('init', '335401813750447');
   fbq('track', 'PageView');
  },3000);
</script>
<!-- End Facebook Pixel Code -->
<style>
	@-webkit-keyframes moka-slide-in {
		100% { 
			top: 50%; left: 50%; 
			-ms-transform: translateX(-50%) translateY(-50%); -webkit-transform: translate(-50%,-50%); transform: translate(-50%,-50%);
		}
	}
	@keyframes moka-slide-in {
		100% { 
			top: 50%; left: 50%; 
			-ms-transform: translateX(-50%) translateY(-50%); -webkit-transform: translate(-50%,-50%); transform: translate(-50%,-50%);
		}
	}

	@-webkit-keyframes moka-fade-in {
		100% { 
			opacity: 1;
		}
	}
	@keyframes moka-fade-in {
		100% { 
			opacity: 1;
		}
	}

	@-webkit-keyframes moka-fade-in-partial {
		100% { 
			opacity: 0.8;
		}
	}
	@keyframes moka-fade-in-partial {
		100% { 
			opacity: 0.8;
		}
	}

	#v2campaignpopup {
		background-color: white;
	}
	.darkmode #v2campaignpopup {
		background-color: black;
		border: 1px solid white;
	}
	
	#v2campaignpopup_backdrop {
		position: fixed;
		top: 0;
		left: 0;
		right: 0;
		bottom: 0;
		opacity: 0; 
		-webkit-animation: moka-fade-in-partial 1s forwards; 
		-webkit-animation-delay: 0s; 
		animation: moka-fade-in-partial 1s forwards; 
		animation-delay: 0s;
		background-color: #000;
		z-index: 100005;
	}
	.darkmode #v2campaignpopup_backdrop {
		background-color: black;
	}

	#moka-v2campaign-closebtn {
		font-family: Raleway,sans-serif; 
		cursor: pointer; 
		text-align: center; 
		position: absolute; 
		top: 0; 
		right: 0; 
		min-height: 20px; 
		width: 30px; 
		background: white; 
		color: black;
	}
	.darkmode #moka-v2campaign-closebtn {
        color: white;
        background-color: black;
    }

	/* Push whole block down a smidge for close button, on mobile */
	@media screen and (max-width: 768px) {
		#v2campaignpopup {
			margin-top: 20px;
			overflow: auto;
			border: 1px solid black;
		}
		.darkmode #v2campaignpopup {
			border: 1px solid white;
		}
	}
</style>
<script type="text/javascript">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</script></head>
<body class="post-template-default single single-post postid-816924 single-format-standard group-blog">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<amp-iframe width="1" height="1" sandbox="allow-scripts allow-same-origin allow-popups allow-popups-to-escape-sandbox" layout="fixed" frameborder="0" src="https://ads.servebom.com/serve_cdn/amp/amp_head.html">
<amp-img layout="responsive" width="1" height="1" src="https://ads.servebom.com/serve_cdn/amp/amp_placeholder.png" placeholder></amp-img>
</amp-iframe>
<header id="masthead" class="site-header nav-down" role="banner">
<div class="inner">
<a href='https://www.howtogeek.com/' class='home' title="How-To Geek Home" aria-label="How-To Geek Home">
<div class="site-branding">
<img width="145" height="46" aria-hidden="true" tabindex="-1" role="presentation" src='data:image/png;base64,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' class='main-logo' alt=''/>
</div><!-- .site-branding -->
</a>
<button class="htg-hamburger hamburger hamburger--slider" type="button" aria-label="Expand Menu">
<span class="hamburger-box" role="presentation">
<span class="hamburger-inner" role="presentation"></span>
</span>
</button>
<svg class="search" aria-label="Search Icon" role="img" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" fill="#fff"/></svg>
<span class="twitter"><a title="Twitter" aria-label="Twitter" href="https://twitter.com/howtogeek/"><svg title="Twitter Icon" aria-label="Twitter Icon" xmlns="http://www.w3.org/2000/svg" enable-background="new 0 0 512 512" viewBox="0 0 512 512" aria-hidden="true" tabindex="-1"><path fill="white" d="M256,16C123.5,16,16,123.5,16,256c0,132.5,107.5,240,240,240s240-107.5,240-240C496,123.5,388.5,16,256,16z M376.3,192.9c-0.1,0.1-0.1,0.1-0.2,0.2c0.1,1.5,0.1,3,0.2,4.5c0,1.6,0.1,3.2,0.1,4.8c0,98.3-79.7,177.9-177.9,177.9 c-33.8,0-65.3-9.4-92.2-25.7c0,0,51,4.3,85.9-28.3c0,0-41.6-5.4-57.3-44c0,0,18.1,3,28.9,0c0,0-50-20.5-48.8-62.1 c0,0,17.5,7.2,25.9,7.2c0,0-44.6-30.8-18.1-88c0,0,34.4,66.3,128.4,66.9l0.1-0.1c-0.7-3.7-1-7.5-1-11.4c0-34.8,28.2-63,63-63 c17.8,0,33.9,7.4,45.3,19.2l0.5-0.2c0,0,3.7-1,8.8-2.5c8.6-2.5,21.2-6.3,26.1-9c0,0-5.1,19.3-20.8,30.3c-0.5,0.4-1,0.7-1.5,1 c0,0,0.6,0,1.7-0.1c4.8-0.2,18.7-1.5,31.5-8.4C404.6,162.8,391.4,180.4,376.3,192.9z"/></svg></a></span>
<span class="facebook"><a title="Facebook" aria-label="Facebook" href="https://facebook.com/howtogeek/"><svg title="Facebook Icon" aria-label="Facebook Icon" viewBox="0 0 1000 1000" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" aria-hidden="true" tabindex="-1"><g><path d="M500,1000L500,1000C223.9,1000,0,776.1,0,500l0,0C0,223.9,223.9,0,500,0l0,0c276.1,0,500,223.9,500,500l0,0   C1000,776.1,776.1,1000,500,1000z"/><path style="fill: white;" d="M630,1000V612.7h130l19.5-150.9H630v-96.4c0-43.7,12.1-73.5,74.8-73.5h79.9V157   c-13.8-1.8-61.3-5.9-116.5-5.9c-115.2,0-194.1,70.3-194.1,199.5v111.3H343.8v150.9h130.3V1000H630z"/></g></svg></a></span>
<span class="twitter-mobile"><svg role="img" aria-label="Twitter Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></span>
<span class="facebook-mobile"><svg role="img" aria-label="Facebook Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></span>
<div class="subscribe-button" tabindex="-1">Free Newsletter</div>
<ul id="topmenu" role="menu">
<li role="menuitem"><a class="menuitem-buyingguides" href="/buying-guides/">Buying Guides</a></li>
<li role="menuitem"><a class="menuitem-news" href="/news/">News</a></li>
<li role="menuitem"><a class="menuitem-reviews" href="/t/single-review/">Reviews</a></li>
<li role="menuitem"><a class="categories" href="/">Explore</a></li>
</ul>
</div>
</header><!-- #masthead -->
<div class="header-commission-statement">We select and review products independently. When you purchase through our links we may earn a commission. <a target="_blank" href="/about/">Learn more.</a></div>
<div class="full-screen-menu category-menu">
<div class="full-screen-menu-inner">
<div class="inner">
<form class="searchform" action="/search/" method="get">
<input type="text" name="q" value="" placeholder="Enter search term" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<nav id="site-navigation-1" class="main-navigation" role="navigation">
<div style="float: left; max-width: 15%; width: 145px;">
<ul role="menu" style="width: 100%;">
<li role="menuitem" class="explore-menu-trigger explore-menu-active" data-targetclass="explore-menu-windows">Windows <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem" class="explore-menu-trigger" data-targetclass="explore-menu-iphone">iPhone <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem" class="explore-menu-trigger" data-targetclass="explore-menu-android">Android <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem" class="explore-menu-trigger" data-targetclass="explore-menu-mac">Mac <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem" class="explore-menu-trigger" data-targetclass="explore-menu-smarthome">Smart Home <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem" class="explore-menu-trigger" data-targetclass="explore-menu-office">Office <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem" class="explore-menu-trigger" data-targetclass="explore-menu-security">Security <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem" class="explore-menu-trigger" data-targetclass="explore-menu-linux">Linux <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem" class="explore-menu-trigger" data-targetclass="explore-menu-devops">DevOps <div class="desktop-menu-right-arrow">&raquo;</div></li>
<li role="menuitem"><a href="https://www.howtogeek.com/about/">About Us</a></li>
<li role="menuitem"><a href="https://www.howtogeek.com/contact/">Contact Us</a></li>
<li role="menuitem"><a href="https://www.facebook.com/groups/geektalkgroup/">Geek Talk</a></li>
</ul>
</div>
<div style="" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-windows"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/226280/how-to-take-screenshots-in-windows-10/">Take Screenshot on Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/windows-vista/mount-an-iso-image-in-windows-vista/">Mount an ISO image in Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/windows-vista/what-is-svchostexe-and-why-is-it-running/">What Is svchost.exe?</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/107511/how-to-boot-into-safe-mode-on-windows-8-the-easy-way/">Boot Into Safe Mode</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/186775/how-to-download-windows-7-8-and-8.1-installation-media-legally/">Where to Download Windows Legally</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/206329/how-to-find-your-lost-windows-or-office-product-keys/">Find Your Lost Product Keys</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/224342/how-to-clean-install-windows-10/">Clean Install Windows 10 the Easy Way</a></li></div><div style="" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-windows"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/windows-vista/enable-the-hidden-administrator-account-on-windows-vista/">Enable Windows Administrator Account</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/244678/you-dont-need-a-product-key-to-install-and-use-windows-10/">Use Windows 10 Without Product Key</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/233159/how-to-find-your-wi-fi-password/">Find Your Wi-Fi Password</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/225385/what%e2%80%99s-the-best-antivirus-for-windows-10-is-windows-defender-good-enough/">Best Antivirus for Windows 10 and 11</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/164668/how-to-electronically-sign-documents-without-printing-and-scanning-them/">Electronically Sign PDFs</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/345504/how-to-open-heic-files-on-windows-or-convert-them-to-jpeg/">Open HEIC Files on Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/">Use the Linux Bash Shell on Windows</a></li></div><div style="" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-windows"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/27350/beginner-geek-how-to-edit-your-hosts-file/">Edit Your Hosts File</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/204057/how-to-see-who%e2%80%99s-connected-to-your-wi-fi-network/">See Who's Connected to Your Wi-Fi</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/193669/whats-the-difference-between-gpt-and-mbr-when-partitioning-a-drive/">What's the Difference Between GPT and MBR</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/224471/how-to-prevent-windows-10-from-automatically-downloading-updates/">Stop Windows From Downloading Updates</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/windows-vista/using-windows-vista-system-restore/">Use System Restore on Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/197268/how-to-find-the-best-wi-fi-channel-for-your-router-on-any-operating-system/">Find the Best Wi-Fi Channel</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/204036/how-to-add-check-boxes-to-word-documents/">Add Check Boxes to Word Documents</a></li></div><div style="font-weight: bold; width: 80%;" class="explore-menu-segment" data-targetclass="explore-menu-windows"><a style="display: inline-block;" href="https://www.howtogeek.com/category/windows/">Browse All Windows Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-iphone"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/688893/how-to-find-downloaded-files-on-an-iphone-or-ipad/">Find Downloaded Files on an iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/411095/how-to-detect-hidden-surveillance-cameras-with-your-phone/">Detect Hidden Surveillance Cameras</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/425994/how-to-move-google-authenticator-to-a-new-phone-or-multiple-phones/">Move Google Authenticator to a New Phone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/669589/how-to-use-your-iphone-as-a-webcam/">Use Your iPhone as a Webcam</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/513196/how-to-hide-private-photos-and-videos-on-your-iphone/">Hide Private Photos on iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/666363/how-to-convert-heic-photos-to-jpg-on-iphone-and-ipad/">Convert HEIC Photos to JPG on iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/354990/can-you-use-facetime-on-android/">Use FaceTime on Android</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-iphone"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/439570/how-to-remove-activation-lock-on-an-iphone/">Remove Activation Lock on an iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/401068/how-to-set-a-gif-as-a-live-wallpaper-on-your-iphone/">Set a GIF as Wallpaper on iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/436770/my-iphone-or-ipad-screen-wont-rotate.-how-do-i-fix-it/">iPhone or iPad Screen Won't Rotate</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/440078/how-to-enable-dark-mode-on-your-iphone-and-ipad/">Enable Dark Mode on your iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/427757/how-to-troubleshoot-iphone-and-ipad-app-crashes/">Fix Crashing Apps on iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/690823/how-to-take-a-screenshot-by-tapping-the-back-of-your-iphone/">Take Screenshot by Tapping Back of iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/440246/how-to-pair-two-sets-of-airpods-with-the-same-iphone/">Pair Two Sets of AirPods With the Same iPhone</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-iphone"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/440633/%c2%a0how-to-download-files-using-safari-on-your-iphone-or-ipad/">Download Files Using Safari on Your iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/351912/whats-the-latest-version-of-ios-for-iphones-and-ipads/">Latest Version of iOS and iPadOS</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/450770/how-to-force-your-apple-watch-to-sync-with-your-iphone/">Force Your Apple Watch to Sync</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/446415/how-to-pair-the-apple-airpods-pro/">Pair AirPods with Any Device</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/509018/how-to-hide-an-app-on-your-iphone-or-ipad/">Hide an App on Your iPhone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/408142/how-to-change-your-apple-id-email-address/">Change Your Apple ID Email Address</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/722717/how-to-disable-notifications-for-the-shortcuts-app-on-iphone/">Turn Off iPhone Shortcuts Notifications</a></li></div><div style="font-weight: bold; width: 80%;display: none;" class="explore-menu-segment" data-targetclass="explore-menu-iphone"><a style="display: inline-block;" href="https://www.howtogeek.com/category/iphone-and-ipad/">Browse All iPhone Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-mac"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/233159/how-to-find-your-wi-fi-password/">Find Your Wi-Fi Password</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/184091/5-ways-to-free-up-disk-space-on-a-mac/">Free Up Disk Space on Your Mac</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/197268/how-to-find-the-best-wi-fi-channel-for-your-router-on-any-operating-system/">Find the Best Wi-Fi Channel</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/191054/how-to-create-bootable-usb-drives-and-sd-cards-for-every-operating-system/">Create Bootable USB Drives</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/299457/how-to-remove-a-password-from-a-pdf-file/">Remove a PDF Password</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/217158/what-to-do-when-your-mac-won%e2%80%99t-start-up/">What to Do When Your Mac Won't Turn On</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/187359/5-ways-to-run-windows-software-on-a-mac/">Run Windows Software on Mac</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-mac"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/269272/how-to-stream-from-vlc-to-your-chromecast/">Stream From VLC to Chromecast</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/236055/how-to-write-to-ntfs-drives-on-a-mac/">Write to NTFS Drives on a Mac</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/215400/how-to-turn-your-computer-into-a-dlna-media-server/">Turn Your Computer Into a DLNA Media Server</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/180953/3-free-ways-to-remotely-connect-to-your-macs-desktop/">3 Ways to Remotely Connect to Mac</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/214053/how-to-turn-your-mac-into-a-wi-fi-hotspot/">Turn Your Mac Into a Wi-Fi Hotspot</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/209517/how-to-stop-your-macs-mail-app-from-wasting-gigabytes-of-space/">Stop Mac's Mail App Wasting Space</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/669589/how-to-use-your-iphone-as-a-webcam/">Use Your iPhone as a Webcam</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-mac"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/408142/how-to-change-your-apple-id-email-address/">Change Your Apple ID Email Address</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/413212/is-it-bad-to-have-your-desktop-pc-on-the-floor/">PC on the Floor</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/734540/how-to-freely-move-pictures-in-microsoft-word/">Freely Move Pictures in Word</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/735756/how-to-cut-and-paste-files-on-mac/">Cut and Paste Files on Mac</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/747946/what-are-aae-files-from-an-iphone-and-can-i-delete-them/">What Are AAE Files from an iPhone?</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/737510/how-to-download-and-install-older-versions-of-macos/">Download and Install Older Versions of macOS</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/738706/can-i-use-icloud-drive-for-time-machine-backups/">Can I Use iCloud Drive for Time Machine Backups?</a></li></div><div style="font-weight: bold; width: 80%;display: none;" class="explore-menu-segment" data-targetclass="explore-menu-mac"><a style="display: inline-block;" href="https://www.howtogeek.com/category/mac/">Browse All Mac Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-android"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/232726/how-to-install-the-google-play-store-on-your-amazon-fire-tablet/">Google Play Store on Fire Tablet</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/233159/how-to-find-your-wi-fi-password/">Find Your Wi-Fi Password</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/164668/how-to-electronically-sign-documents-without-printing-and-scanning-them/">Electronically Sign PDFs</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/345504/how-to-open-heic-files-on-windows-or-convert-them-to-jpeg/">Open HEIC Files on Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/">Use the Linux Bash Shell on Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/197268/how-to-find-the-best-wi-fi-channel-for-your-router-on-any-operating-system/">Find the Best Wi-Fi Channel</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/114667/how-to-install-android-apps-to-the-sd-card-by-default-move-almost-any-app-to-the-sd-card/">Move Android Apps to the SD Card</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-android"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/112852/how-to-backup-your-text-messages-to-your-gmail-account/">Back Up Text Messages to Gmail</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/269272/how-to-stream-from-vlc-to-your-chromecast/">Stream From VLC to Chromecast</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/338698/how-to-hide-your-active-status-on-facebook-messenger/">Hide Facebook Messenger Status</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/230683/how-to-manage-app-permissions-on-android-6.0/">Manage App Permissions on Android</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/411095/how-to-detect-hidden-surveillance-cameras-with-your-phone/">Detect Hidden Surveillance Cameras</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/115533/how-to-disable-or-uninstall-android-bloatware/">Remove Bloatware on Android</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/425994/how-to-move-google-authenticator-to-a-new-phone-or-multiple-phones/">Move Google Authenticator to a New Phone</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-android"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/166610/who-needs-a-scanner-scan-a-document-to-pdf-with-your-android-phone/">Scan to PDF on Android</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/166057/how-to-find-your-lost-android-phone-even-if-you-never-set-up-a-tracking-app/">Find Your Lost Android Phone</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/354990/can-you-use-facetime-on-android/">Use FaceTime on Android</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/43135/how-to-change-the-default-application-for-android-tasks/">Set Default Apps on Android</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/201843/how-to-trim-and-cut-videos-on-your-android-device/">Trim Videos on Android</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/202297/how-to-disable-automatic-app-updates-in-android/">Disable Android App Updates</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/204378/how-to-reboot-or-factory-reset-your-google-chromecast/">Reboot or Factory Reset Chromecast</a></li></div><div style="font-weight: bold; width: 80%;display: none;" class="explore-menu-segment" data-targetclass="explore-menu-android"><a style="display: inline-block;" href="https://www.howtogeek.com/category/android/">Browse All Android Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-smarthome"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/204057/how-to-see-who%e2%80%99s-connected-to-your-wi-fi-network/">See Who's Connected to Your Wi-Fi</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/197268/how-to-find-the-best-wi-fi-channel-for-your-router-on-any-operating-system/">Find the Best Wi-Fi Channel</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/192654/how-to-monitor-your-internet-bandwidth-usage-and-avoid-exceeding-data-caps/">Monitor Your Internet Bandwidth Usage</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/351631/why-is-my-amazon-echo-blinking-yellow-red-or-green/">Why is My Echo Blinking</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/208030/how-to-set-up-a-nas-network-attached-storage-drive/">Set Up a NAS Drive</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/248590/whats-the-difference-between-the-amazon-echo-and-echo-dot/">Difference Between the Echo and Echo Dot</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/278486/amazon-prime-is-more-than-free-shipping-here-are-all-of-its-extra-features/">Amazon Prime Features</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-smarthome"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/731552/how-to-control-all-your-smart-home-devices-in-one-app/">Control All Your Smart Home Devices in One App</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/742041/best-led-strip-light/">Best LED Strip Lights</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/727279/how-to-use-hand-gestures-with-the-google-nest-hub/">Use Hand Gestures with Google Nest Hub</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/735213/best-smart-light-bulbs/">Best Smart Light Bulbs</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/728412/how-to-connect-alexa-to-wi-fi/">Connect Alexa to Wi-Fi</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/731793/how-to-schedule-a-smart-plug-with-alexa/">Schedule a Smart Plug with Alexa</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/749819/best-robot-vacuum/">Best Robot Vacuums</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-smarthome"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/748626/how-to-play-games-on-a-google-nest-hub/">Play Games on a Google Nest Hub</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/687256/how-to-set-up-and-use-google-assistants-good-morning-routine/">Google Assistant Good Morning Routine</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/777272/eve-motionblinds-will-future-proof-your-smart-homes-windows/">Eve MotionBlinds</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/733480/7-alexa-skills-to-make-your-life-easier-on-amazon-echo/">7 Alexa Skills to Make Your Life Easier</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/738228/can-power-companies-remotely-adjust-your-smart-thermostat/">Can Power Companies Remotely Adjust Your Smart Thermostat?</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/756499/smart-home-gifts/">Best Smart Home Gifts</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/730221/what-is-a-smart-plug/">What Is a Smart Plug?</a></li></div><div style="font-weight: bold; width: 80%;display: none;" class="explore-menu-segment" data-targetclass="explore-menu-smarthome"><a style="display: inline-block;" href="https://www.howtogeek.com/category/smart-home/">Browse All Smart Home Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-office"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/206329/how-to-find-your-lost-windows-or-office-product-keys/">Find Your Lost Product Keys</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/204036/how-to-add-check-boxes-to-word-documents/">Add Check Boxes to Word Documents</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/microsoft-office/insert-horizontal-lines-in-word-documents-quickly/">Insert Horizontal Lines In Word</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/222614/how-to-enable-windows-10s-hidden-dark-theme/">Windows 10 Dark Mode</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/57552/the-10-most-ridiculously-awesome-geeky-computer-pranks/">Awesome Geeky Computer Pranks</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/225568/how-to-configure-and-customize-the-taskbar-in-windows-10/">Customize the Taskbar in Windows 10</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/windows-vista/what-is-ctfmonexe-and-why-is-it-running/">What Is ctfmon.exe?</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-office"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/12366/convert-a-row-to-a-column-in-excel-the-easy-way/">Convert a Row to a Column</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/45670/how-to-highlight-a-row-in-excel-using-conditional-formatting/">Highlight a Row Using Conditional Formatting</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/103481/how-to-use-multiple-headers-and-footers-in-a-single-document/">Use Multiple Headers and Footers</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/203892/how-to-create-fillable-forms-with-ms-word-2010/">Make a Form in Word</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/198052/how-to-remove-duplicate-rows-in-excel/">Remove Duplicate Rows in Excel</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/205086/beginner-how-to-make-windows-show-file-extensions/">Make Windows Show File Extensions</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/173478/10-important-computer-security-practices-you-should-follow/">Computer Security Tips</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-office"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/731303/how-to-add-a-drop-down-list-to-a-word-document/">Add a Drop-Down List to a Word Document</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/740936/how-to-number-or-label-equations-in-microsoft-word/">Number or Label Equations in Word</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/739579/how-to-count-colored-cells-in-microsoft-excel/">Count Colored Cells in Excel</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/238852/how-to-add-a-word-or-phrase-to-the-dictionary-on-your-android-device/">How to Add a Word or Phrase to Android's Auto</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/687118/is-your-microsoft-office-still-getting-security-updates/">Office Security Updates</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/740291/how-and-why-to-start-microsoft-excel-from-the-command-prompt/">Start Excel from the Command Prompt</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/730732/how-to-delete-all-presentation-notes-at-once-in-microsoft-powerpoint/">Delete All Notes at Once in PowerPoint</a></li></div><div style="font-weight: bold; width: 80%;display: none;" class="explore-menu-segment" data-targetclass="explore-menu-office"><a style="display: inline-block;" href="https://www.howtogeek.com/category/microsoft-office/">Browse All Microsoft Office Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-security"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/windows-vista/what-is-svchostexe-and-why-is-it-running/">What Is svchost.exe?</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/224342/how-to-clean-install-windows-10/">Clean Install Windows 10 the Easy Way</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/244678/you-dont-need-a-product-key-to-install-and-use-windows-10/">Use Windows 10 Without Product Key</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/233159/how-to-find-your-wi-fi-password/">Find Your Wi-Fi Password</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/225385/what%e2%80%99s-the-best-antivirus-for-windows-10-is-windows-defender-good-enough/">Best Antivirus for Windows 10 and 11</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/204057/how-to-see-who%e2%80%99s-connected-to-your-wi-fi-network/">See Who's Connected to Your Wi-Fi</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/114667/how-to-install-android-apps-to-the-sd-card-by-default-move-almost-any-app-to-the-sd-card/">Move Android Apps to the SD Card</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-security"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/105633/how-to-create-a-password-protected-folder-without-any-extra-software/">Hide or Password Protect a Folder in Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/299457/how-to-remove-a-password-from-a-pdf-file/">Remove a PDF Password</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/221001/how-to-set-up-your-own-home-vpn-server/">Set Up Your Own Home VPN Server</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/265027/how-to-disable-cortana-in-windows-10/">Disable Cortana in Windows 10</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/131338/how-to-access-your-router-if-you-forget-the-password/">Access Your Router If You Forget the Password</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/247380/how-to-fix-windows-update-when-it-gets-stuck/">Fix a Stuck Windows Update</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/236055/how-to-write-to-ntfs-drives-on-a-mac/">Write to NTFS Drives on a Mac</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-security"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/247573/how-to-mirror-your-iphone-or-ipads-screen-on-your-windows-pc/">Mirror iPhone or iPad to Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/230683/how-to-manage-app-permissions-on-android-6.0/">Manage App Permissions on Android</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/411095/how-to-detect-hidden-surveillance-cameras-with-your-phone/">Detect Hidden Surveillance Cameras</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/134046/how-to-connect-to-a-vpn-in-windows/">Connect to VPN on Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/434655/how-to-hide-the-games-youre-playing-on-steam/">Hide Steam Games You're Playing</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/135638/the-best-free-ways-to-send-encrypted-email-and-secure-messages/">Send Encrypted Emails and Messages</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/126911/what-to-do-if-you-get-a-virus-on-your-computer/">Remove Viruses on Windows</a></li></div><div style="font-weight: bold; width: 80%;display: none;" class="explore-menu-segment" data-targetclass="explore-menu-security"><a style="display: inline-block;" href="https://www.howtogeek.com/category/privacy-security/">Browse All Privacy and Security Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-linux"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/164668/how-to-electronically-sign-documents-without-printing-and-scanning-them/">Electronically Sign PDFs</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/">Use the Linux Bash Shell on Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/27350/beginner-geek-how-to-edit-your-hosts-file/">Edit Your Hosts File</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/193669/whats-the-difference-between-gpt-and-mbr-when-partitioning-a-drive/">What's the Difference Between GPT and MBR</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/197268/how-to-find-the-best-wi-fi-channel-for-your-router-on-any-operating-system/">Find the Best Wi-Fi Channel</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/191054/how-to-create-bootable-usb-drives-and-sd-cards-for-every-operating-system/">Create Bootable USB Drives</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/299457/how-to-remove-a-password-from-a-pdf-file/">Remove a PDF Password</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-linux"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/112888/3-ways-to-access-your-linux-partitions-from-windows/">Access Your Linux Partitions From Windows</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/187359/5-ways-to-run-windows-software-on-a-mac/">Run Windows Software on Mac</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/221001/how-to-set-up-your-own-home-vpn-server/">Set Up Your Own Home VPN Server</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/173828/what-to-do-when-windows-wont-boot/">Windows Won't Boot</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/197542/the-4-best-alternatives-to-utorrent-on-windows/">Best Alternatives to uTorrent</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/269272/how-to-stream-from-vlc-to-your-chromecast/">Stream From VLC to Chromecast</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/howto/ubuntu/delete-files-older-than-x-days-on-linux/">Delete Files Older Than x Days</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-linux"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/67660/how-to-diagnose-and-fix-an-overheating-laptop/">Fix an Overheating Laptop</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/215400/how-to-turn-your-computer-into-a-dlna-media-server/">Turn Your Computer Into a DLNA Media Server</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/412055/37-important-linux-commands-you-should-know/">Important Linux Commands</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/198476/how-to-install-minecraft-on-ubuntu-or-any-other-linux-distribution/">Install Minecraft on Ubuntu Linux</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/143263/how-to-test-your-antivirus-firewall-browser-and-software-security/">Test Your Antivirus, Firewall, and More</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/748445/best-linux-laptops/">Best Linux Laptops</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/735089/6-lightweight-linux-distros/">Best Lightweight Linux Distros</a></li></div><div style="font-weight: bold; width: 80%;display: none;" class="explore-menu-segment" data-targetclass="explore-menu-linux"><a style="display: inline-block;" href="https://www.howtogeek.com/category/linux/">Browse All Linux Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-devops"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/what-is-ssh-agent-forwarding-and-how-do-you-use-it/">What is SSH Agent Forwarding and How Do You Use It?</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-connect-to-localhost-within-a-docker-container/">How to Connect to Localhost Within a Docker Container</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-manage-an-ssh-config-file-in-windows-linux/">How to Manage an SSH Config File in Windows and Linux</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-run-gui-applications-in-a-docker-container/">How to Run GUI Applications in a Docker Container</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-use-cron-with-your-docker-containers/">How to Use Cron With Your Docker Containers</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-check-if-your-server-is-vulnerable-to-the-log4j-java-exploit-log4shell/">How to Check If Your Server Is Vulnerable to the log4j Java Exploit (Log4Shell)</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/what-is-a-pem-file-and-how-do-you-use-it/">What Is a PEM File and How Do You Use It?</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-devops"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-run-your-own-dns-server-on-your-local-network/">How to Run Your Own DNS Server on Your Local Network</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-check-if-the-docker-daemon-or-a-container-is-running/">How to Check If the Docker Daemon or a Container Is Running</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-pass-environment-variables-to-docker-containers/">How to Pass Environment Variables to Docker Containers</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-view-kubernetes-pod-logs-with-kubectl/">How to View Kubernetes Pod Logs With Kubectl</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-use-docker-to-containerise-php-and-apache/">How to Use Docker to Containerize PHP and Apache</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-use-state-in-functional-react-components/">How to Use State in Functional React Components</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-create-a-simple-bot-in-microsoft-teams/">How to Create a Simple Bot In Microsoft Teams</a></li></div><div style="display: none;" class="explore-menu-segment" role="menu" data-targetclass="explore-menu-devops"><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-get-started-with-portainer-a-web-ui-for-docker/">How to Get Started With Portainer, a Web UI for Docker</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-find-your-apache-configuration-folder/">How to Find Your Apache Configuration Folder</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-restart-kubernetes-pods-with-kubectl/">How to Restart Kubernetes Pods With Kubectl</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-send-a-message-to-slack-from-a-bash-script/">How to Send a Message to Slack From a Bash Script</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/is-rocky-linux-the-new-centos/">Is Rocky Linux the new CentOS?</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/how-to-get-the-size-of-an-amazon-s3-bucket/">How to Get the Size of an Amazon S3 Bucket</a></li><a class="oswald-header-menu-link" role="menuitem" href="https://www.howtogeek.com/devops/when-not-to-use-docker-cases-where-containers-dont-help/">When Not to Use Docker: Cases Where Containers Don&#8217;t Help</a></li></div><div style="font-weight: bold; width: 80%;display: none;" class="explore-menu-segment" data-targetclass="explore-menu-devops"><a style="display: inline-block;" href="https://www.howtogeek.com/devops/">Browse All DevOps Articles</a> | <a style="display: inline-block;" href="https://www.howtogeek.com/buying-guides/" ">Browse Buying Guides</a></div>	<br style="clear: both;">
<div class="mobile-hamburger-socials">
<span class="instagram" style="background: none; display: inline-block;">
<a title="Instagram" aria-label="Instagram" href="https://www.instagram.com/howtogeeksite">
<svg style="fill: black; height: 24px; width: auto; margin-right: 0px;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1"><path d="M12 2.163c3.204 0 3.584.012 4.85.07 3.252.148 4.771 1.691 4.919 4.919.058 1.265.069 1.645.069 4.849 0 3.205-.012 3.584-.069 4.849-.149 3.225-1.664 4.771-4.919 4.919-1.266.058-1.644.07-4.85.07-3.204 0-3.584-.012-4.849-.07-3.26-.149-4.771-1.699-4.919-4.92-.058-1.265-.07-1.644-.07-4.849 0-3.204.013-3.583.07-4.849.149-3.227 1.664-4.771 4.919-4.919 1.266-.057 1.645-.069 4.849-.069zm0-2.163c-3.259 0-3.667.014-4.947.072-4.358.2-6.78 2.618-6.98 6.98-.059 1.281-.073 1.689-.073 4.948 0 3.259.014 3.668.072 4.948.2 4.358 2.618 6.78 6.98 6.98 1.281.058 1.689.072 4.948.072 3.259 0 3.668-.014 4.948-.072 4.354-.2 6.782-2.618 6.979-6.98.059-1.28.073-1.689.073-4.948 0-3.259-.014-3.667-.072-4.947-.196-4.354-2.617-6.78-6.979-6.98-1.281-.059-1.69-.073-4.949-.073zm0 5.838c-3.403 0-6.162 2.759-6.162 6.162s2.759 6.163 6.162 6.163 6.162-2.759 6.162-6.163c0-3.403-2.759-6.162-6.162-6.162zm0 10.162c-2.209 0-4-1.79-4-4 0-2.209 1.791-4 4-4s4 1.791 4 4c0 2.21-1.791 4-4 4zm6.406-11.845c-.796 0-1.441.645-1.441 1.44s.645 1.44 1.441 1.44c.795 0 1.439-.645 1.439-1.44s-.644-1.44-1.439-1.44z"/></svg>
</a>
</span>
&nbsp;
<span class="twitter" style="background: none; display: inline-block;"><a title="Twitter" aria-label="Twitter" href="https://twitter.com/howtogeek"><svg style="height: 24px; width: auto;" title="Twitter Icon" aria-label="Twitter Icon" xmlns="http://www.w3.org/2000/svg" enable-background="new 0 0 512 512" viewBox="0 0 512 512" aria-hidden="true" tabindex="-1"><path fill="#020202" d="M256,16C123.5,16,16,123.5,16,256c0,132.5,107.5,240,240,240s240-107.5,240-240C496,123.5,388.5,16,256,16z M376.3,192.9c-0.1,0.1-0.1,0.1-0.2,0.2c0.1,1.5,0.1,3,0.2,4.5c0,1.6,0.1,3.2,0.1,4.8c0,98.3-79.7,177.9-177.9,177.9 c-33.8,0-65.3-9.4-92.2-25.7c0,0,51,4.3,85.9-28.3c0,0-41.6-5.4-57.3-44c0,0,18.1,3,28.9,0c0,0-50-20.5-48.8-62.1 c0,0,17.5,7.2,25.9,7.2c0,0-44.6-30.8-18.1-88c0,0,34.4,66.3,128.4,66.9l0.1-0.1c-0.7-3.7-1-7.5-1-11.4c0-34.8,28.2-63,63-63 c17.8,0,33.9,7.4,45.3,19.2l0.5-0.2c0,0,3.7-1,8.8-2.5c8.6-2.5,21.2-6.3,26.1-9c0,0-5.1,19.3-20.8,30.3c-0.5,0.4-1,0.7-1.5,1 c0,0,0.6,0,1.7-0.1c4.8-0.2,18.7-1.5,31.5-8.4C404.6,162.8,391.4,180.4,376.3,192.9z"/></svg></a></span>
&nbsp;
<span class="facebook" style="background: none; display: inline-block;"><a title="Facebook" aria-label="Facebook" href="https://facebook.com/howtogeek"><svg style="height: 24px; width: auto;" title="Facebook Icon" aria-label="Facebook Icon" style="margin-top: 1px;" viewBox="0 0 1000 1000" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" aria-hidden="true" tabindex="-1"><g><path d="M500,1000L500,1000C223.9,1000,0,776.1,0,500l0,0C0,223.9,223.9,0,500,0l0,0c276.1,0,500,223.9,500,500l0,0   C1000,776.1,776.1,1000,500,1000z"/><path style="fill: white;" d="M630,1000V612.7h130l19.5-150.9H630v-96.4c0-43.7,12.1-73.5,74.8-73.5h79.9V157   c-13.8-1.8-61.3-5.9-116.5-5.9c-115.2,0-194.1,70.3-194.1,199.5v111.3H343.8v150.9h130.3V1000H630z"/></g></svg></a></span>
<!-- Silly chrome bottom bar blocks social icons on mobile -->
<br/><br/><br/><br/><br/>
<br/><br/><br/><br/><br/>
</div>
</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu buyingguides-content htg-custom-menu-content">
<div class="full-screen-menu-inner">
<div class="inner">
<div style="width: 23%; float: left;" role="menu">
<h4 style="text-transform: uppercase;">Complete Guides<br/>by How-To Geek</h4><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/buying-guides/">Browse All Buying Guides</a></div><img src="/wp-content/themes/htg-responsive/img/2022-HOWTOGEEK-BEST_OF-GENERIC.png" width="200px" style="margin: 0 auto;" alt="How-to Geek Best Of Badge Award">	</div>
<div style="min-height: 320px; width: 46%; float: left; border-left: 1px solid black; border-right: 1px solid black; padding-left: 4%; padding-right: 3%;" role="menu">
<h4 style="text-transform: uppercase;">Our Latest Product Roundups</h4>
<div style="width: 50%; float: left; padding-right: 8px;"><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/809386/best-surge-protector/">Best Surge Protectors</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/807220/best-ethernet-cable/">Best Ethernet Cables</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/807382/best-camera-strap/">Best Camera Straps</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/810929/best-ring-alternative/">Best Ring Alternatives</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/804785/best-wi-fi-adapter/">Best Wi-Fi Adapters</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/808118/best-outdoor-solar-light/">Best Outdoor Solar Lights</a></div></div><div style="width: 49%; float: left; padding-left: 8px;"><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/805227/best-sd-card-for-cameras/">Best SD Cards For Cameras </a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/804636/best-crypto-hardware-wallet/">Best Crypto Wallets</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/806159/best-computer-speaker/">Best Computer Speakers</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/800503/best-cell-phone-plan/">Best Cell Phone Plans</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/800357/best-camera-bag/">Best Camera Bags</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/803635/best-ultrawide-monitor/">Best Ultrawide Monitors</a></div>	</div>
<div style="clear: both;"></div>
</div>
<div style="min-height: 320px; width: 31%; float: left; padding-left: 4%" role="menu"><h4 style="text-transform: uppercase;">Reader Favorites</h4><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/748445/best-linux-laptops/">Best Linux Laptops</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/722600/best-wi-fi-routers/">Best Wi-Fi Routers</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/722178/5-awesome-pc-accessories-you-should-buy/">Awesome PC Accessories</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/772140/best-wireless-earbuds/">Best Wireless Earbuds </a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/772573/best-smartwatch/">Best Smartwatches</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/768999/best-oculus-quest-2-accessories/">Best Oculus Quest 2 Accessories</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/772995/best-home-theater-system/">Best Home Theater Systems</a></div>	</div>
<div style="clear: both;"></div>
</div>
</div>
</div>
<script>
	document.addEventListener("DOMContentLoaded", function(event) { 
		document.querySelectorAll('.menuitem-buyingguides')[0].addEventListener('click', function(event) {
			showGenericContentBlock(document.querySelectorAll('.buyingguides-content')[0], event, this);
		});	
	});
</script>	<div class="full-screen-menu news-content htg-custom-menu-content">
<div class="full-screen-menu-inner">
<div class="inner">
<div style="width: 23%; float: left;" role="menu">
<h4 style="text-transform: uppercase;">More from How-To Geek</h4><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/buying-guides/">Browse All Buying Guides</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/news/">Browse All News Articles</a></div>	</div>
<div style="min-height: 320px; width: 46%; float: left; border-left: 1px solid black; border-right: 1px solid black; padding-left: 4%; padding-right: 3%;" role="menu">
<h4 style="text-transform: uppercase;">Latest Geek News</h4>
<div style="width: 50%; float: left; padding-right: 8px;"><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/818090/your-ev-cant-have-a-custom-low-speed-noise-says-the-us/">Custom EV Low-Speed Sounds</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817896/android-13-is-almost-here-but-probably-not-for-your-phone/">Android 13 Final Beta</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/818061/spotify-bought-a-wordle-clone-you-can-play-it-for-free/">Spotify Bought a Wordle Clone</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817962/googles-all-in-one-subscription-can-now-replace-zoom-too/">Google Meet With Google One</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817144/samsungs-galaxy-tab-a8-is-only-160-for-prime-day/">Galaxy Tab A8 Deal</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/815217/sony-wh-1000xm4-has-a-fantastic-prime-day-discount/">Sony WH-1000XM4 Deal</a></div></div><div style="width: 49%; float: left; padding-left: 8px;"><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817735/ankers-tiny-35-65-usb-c-charger-is-a-great-prime-day-buy/">Anker Nano II 65W Deal</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817666/get-150-off-this-awesome-65-inch-4k-android-tv-today/">Hisense 65-Inch 4K TV Deal</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817623/get-a-new-kindle-for-only-45-today-50-off/">Amazon Kindle 50% Off</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817519/upgrade-to-smart-sprinklers-at-an-all-time-low-price/">Smart Sprinklers Sale</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817530/is-verizons-cheap-new-unlimited-5g-plan-right-for-you/">Verizon 5G Welcome Unlimited</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817487/you-can-now-try-the-ios-16-and-ipados-16-public-beta/">iOS 16 & iPadOS 16 Public Beta</a></div>	</div>
<div style="clear: both;"></div>
</div>
<div style="min-height: 320px; width: 31%; float: left; padding-left: 4%" role="menu"><h4 style="text-transform: uppercase;">Reader Favorites</h4><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/680690/how-to-install-free-hevc-codecs-on-windows-10-for-h.265-video/">Install Free HEVC Codecs</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/411095/how-to-detect-hidden-surveillance-cameras-with-your-phone/">Detect Hidden Surveillance Cameras</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/438141/how-to-play-adobe-flash-swf-files-outside-your-web-browser/">How to Open SWF Files</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/224159/how-to-disable-bing-in-the-windows-10-start-menu/">Disable Bing in Windows 10 Start Menu</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/434655/how-to-hide-the-games-youre-playing-on-steam/">Hide Steam Games You're Playing</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/669589/how-to-use-your-iphone-as-a-webcam/">Use Your iPhone as a Webcam</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/513196/how-to-hide-private-photos-and-videos-on-your-iphone/">Hide Private Photos on iPhone</a></div>	</div>
<div style="clear: both;"></div>
</div>
</div>
</div>
<script>
	document.addEventListener("DOMContentLoaded", function(event) { 
		document.querySelectorAll('.menuitem-news')[0].addEventListener('click', function(event) {
			showGenericContentBlock(document.querySelectorAll('.news-content')[0], event, this);
		});	
	});
</script>	<div class="full-screen-menu reviews-content htg-custom-menu-content">
<div class="full-screen-menu-inner">
<div class="inner">
<div style="width: 23%; float: left;" role="menu">
<h4 style="text-transform: uppercase;">More from How-To Geek</h4><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/t/single-review/">Browse All Reviews</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/buying-guides/">Browse All Buying Guides</a></div><img src="/wp-content/themes/htg-responsive/img/2022-HowToGeek-EC_FINAL.png" width="200px" style="margin: 0 auto;" alt="How-to Geek Editor Choice Badge Award">	</div>
<div style="min-height: 320px; width: 46%; float: left; border-left: 1px solid black; border-right: 1px solid black; padding-left: 4%; padding-right: 3%;" role="menu">
<h4 style="text-transform: uppercase;">Latest Reviews</h4>
<div style="width: 50%; float: left; padding-right: 8px;"><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/817514/amazon-fire-7-kids-tablet-review/">Amazon Fire 7 Kids Tablet Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/814976/avermedia-pw515-4k-ultra-hd-webcam-review/">AVerMedia PW515 4K Ultra HD Webcam Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/814596/amazon-halo-view-review/">Amazon Halo View Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/814043/picsart-gold-review/">Picsart Gold Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/813481/nzxt-signal-4k30-capture-card-review/">NZXT Signal 4K30 Capture Card Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/811056/privadovpn-review-disrupting-the-market/">PrivadoVPN Review</a></div></div><div style="width: 49%; float: left; padding-left: 8px;"><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/811349/innocn-ultrawide-40c1r-monitor-review/">INNOCN Ultrawide Monitor Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/809850/cleanmymac-x-review/">CleanMyMac X Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/806199/chipolo-card-spot-review/">Chipolo CARD Spot Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/808578/surfshark-vpn-review/">Surfshark VPN Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/802169/govee-rgbic-neon-rope-lights-review-your-lights-your-way/">Govee RGBIC Neon Rope Lights Review</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.howtogeek.com/806053/logitech-mx-master-3s-mouse-review/">Logitech MX Master 3S Mouse Review</a></div>	</div>
<div style="clear: both;"></div>
</div>
<div style="min-height: 320px; width: 31%; float: left; padding-left: 4%" role="menu"><h4 style="text-transform: uppercase;">Across LifeSavvy Media</h4><strong class="sptag sptagicon-lifesavvy"><span class="sptagicon">↪</span> FROM LIFESAVVY</strong><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.lifesavvy.com/131867/gozney-roccbox-pizza-oven-review/">Gozney Roccbox Pizza Oven Review: Restaurant-Quality in a Portable Package</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.lifesavvy.com/130813/harber-london-leather-desk-mat-review/">Harber London Leather Desk Mat Review: More Than Just Stylish</a></div><hr><strong class="sptag sptagicon-lifesavvy"><span class="sptagicon">↪</span> FROM REVIEW GEEK</strong><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.reviewgeek.com/122875/ecobee-smart-thermostat-premium-review-the-new-best-smart-thermostat/">Ecobee Smart Thermostat Premium Review: The New Best Smart Thermostat</a></div><div class="oswald-header-menu-link"><a role="menuitem" href="https://www.reviewgeek.com/120704/tidbyt-review/">Tidbyt Review: A Smart Display That's More Decoration and Novelty</a></div>	</div>
<div style="clear: both;"></div>
</div>
</div>
</div>
<script>
	document.addEventListener("DOMContentLoaded", function(event) { 
		document.querySelectorAll('.menuitem-reviews')[0].addEventListener('click', function(event) {
			showGenericContentBlock(document.querySelectorAll('.reviews-content')[0], event, this);
		});	
	});
</script>
<div class="full-screen-menu search-menu">
<div class="full-screen-menu-inner">
<div class="htg-close">X</div>
<div class="inner">
<form class="searchform" action="/search/" method="get">
<input type="text" name="q" value="" placeholder="Enter search term" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<nav id="site-navigation-2" class="main-navigation" role="navigation">
<div class="menu-header-column-1-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-363960" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363960"><a href="https://www.howtogeek.com/category/windows/">Windows</a></li>
<li role="menuitem" id="menu-item-363961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363961"><a href="https://www.howtogeek.com/category/mac/">Mac</a></li>
<li role="menuitem" id="menu-item-363962" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363962"><a href="https://www.howtogeek.com/category/iphone-and-ipad/">iPhone</a></li>
<li role="menuitem" id="menu-item-363963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363963"><a href="https://www.howtogeek.com/category/android/">Android</a></li>
<li role="menuitem" id="menu-item-760628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-760628"><a href="https://www.howtogeek.com/holiday-2021/">🎁 Holiday 2021</a></li>
</ul></div>
<div class="menu-header-column-2-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-363964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363964"><a href="https://www.howtogeek.com/category/smart-home/">Smarthome</a></li>
<li role="menuitem" id="menu-item-363965" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363965"><a href="https://www.howtogeek.com/category/microsoft-office/">Office</a></li>
<li role="menuitem" id="menu-item-363966" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363966"><a href="https://www.howtogeek.com/category/privacy-security/">Security</a></li>
<li role="menuitem" id="menu-item-363967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363967"><a href="https://www.howtogeek.com/category/linux/">Linux</a></li>
<li role="menuitem" id="menu-item-760629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-760629"><a href="https://www.howtogeek.com/buying-guides/">Buying Guides</a></li>
</ul></div>
<div class="menu-header-column-3-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-363968" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363968"><a href="https://www.howtogeek.com/news/">News</a></li>
<li role="menuitem" id="menu-item-363969" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363969"><a href="https://www.howtogeek.com/t/features/">Features</a></li>
<li role="menuitem" id="menu-item-363970" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363970"><a href="https://www.reviewgeek.com">Review Geek</a></li>
<li role="menuitem" id="menu-item-410821" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-410821"><a href="https://www.lifesavvy.com">LifeSavvy</a></li>
<li role="menuitem" id="menu-item-697758" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-697758"><a href="https://www.howtogeek.com/newsletter">Newsletter</a></li>
</ul></div>
<div class="menu-header-column-4-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-363971" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363971"><a href="https://www.howtogeek.com/about/">About Us</a></li>
<li role="menuitem" id="menu-item-363972" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-363972"><a href="https://www.howtogeek.com/contact/">Contact Us</a></li>
<li role="menuitem" id="menu-item-445703" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-445703"><a href="https://www.facebook.com/groups/geektalkgroup/">Geek Talk</a></li>
<li role="menuitem" id="menu-item-671446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-671446"><a href="https://www.cloudsavvyit.com">CloudSavvy IT</a></li>
</ul></div>	</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu subscribe-menu" data-nosnippet="data-nosnippet">
<div class="subscribe-wrap">
<div class="htg-close">X</div>
<div class="inner">
<div class="left">
<img width="100" height="79" loading="lazy" src="https://www.howtogeek.com/wp-content/themes/htg-responsive/img/htg-email-small.png" alt="" role="presentation">
<span class="emailsubheader" role="heading" aria-level="1">The Best Tech Newsletter Anywhere</span>
<p>Join <span style="font-weight:bold;color: #000;">425,000 subscribers</span> and get a daily digest of news, geek trivia, and our feature articles.</p>
</div>
<div class="content right">
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" type="hidden" name="postid" value="816924">
<input aria-hidden="true" tabindex="-1" type="hidden" name="list" value="weekday">
<input aria-hidden="true" tabindex="-1" type="hidden" name="tr" value="howtogeek-subscribemenu">
<input aria-hidden="true" tabindex="-1" type="hidden" name="moka-pagerefer" value="">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Your email">
<input aria-label="Go" type="submit" class="ftemsub" value="Go">
</form>
</div>
<img width="195" height="38" style="float: right; max-width: 300px; margin-right: 10%;" src=" data:image/gif;base64,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" alt="" role="presentation">
<p class="email_signup_disclaimer">By submitting your email, you agree to the <a href="/terms-of-use">Terms of Use</a> and <a href="/privacy-policy">Privacy Policy</a>.</p>
</div>
</div>
</div>
<div id="page" class="site hentry h-entry">
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;min-height: 250px;margin-bottom:20px;align-items: center;display: flex;justify-content: center;" aria-hidden="true" class="adslot adslot970 ">
<div aria-hidden="true" id='purch_Y_L_1_1'></div>	<div style='clear:both'></div>
</div>
<header class="entry-header">
<div class="mokaBreadcrumbWrapper"><ul vocab="https://schema.org/" typeof="BreadcrumbList" class="breadcrumbs"><li class="first"><a title="Home Breadcrumb" aria-label="Home Breadcrumb" href="/">&#127969;</a></li>	<li property="itemListElement" typeof="ListItem">
<a property="item" typeof="WebPage" href="https://www.howtogeek.com/category/microsoft-office/">
<span property="name">Microsoft Office</span>
</a>
<meta property="position" content="1"/>
</li>	<li property="itemListElement" typeof="ListItem">
<a property="item" typeof="WebPage" href="https://www.howtogeek.com/category/microsoft-excel/">
<span property="name">Microsoft Excel</span>
</a>
<meta property="position" content="2"/>
</li></ul></div>
<h1 class="entry-title"><a aria-label="How to Highlight Duplicates in Microsoft Excel" title="How to Highlight Duplicates in Microsoft Excel" href="https://www.howtogeek.com/816924/excel-highlight-duplicates/">How to Highlight Duplicates in Microsoft Excel</a></h1>
<div class="entry-meta" data-nosnippet="data-nosnippet">
<img loading="lazy" src="https://www.howtogeek.com/thumbcache/60/60/0e7d155c4e8e20764d90c3e7a5574d1d/wp-content/uploads/2021/02/Mahesh.png" width="36" height="36" style="float: left;margin-right: 8px;border-radius: 18px;" alt="" role="presentation">
<span class="author-meta-entry-wrap">
<a class="p-author h-card vcard author post-author bio_popup_on_hover_1" href="https://www.howtogeek.com/author/maheshmakvana/"><span class="fn">Mahesh Makvana</span></a><div class="bio_popup_hoverbox_1"><img height="84px" width="84px" src="https://www.howtogeek.com/wp-content/uploads/2021/02/Mahesh.png?width=84&height=84&fit=crop" alt=""><strong class="bio_popup_name">Mahesh Makvana</strong><br/><span class="bio_popup_title">Writer</span><br style="clear: both;"/><p class="bio_popup_body">Mahesh Makvana is a freelance tech writer who specializes in writing how-to guides. He has been writing tech tutorials for over a decade now. He’s written for some of the prominent tech sites including MakeUseOf, MakeTechEasier, and Online Tech Tips. <a style="text-decoration: underline;" href="https://www.howtogeek.com/author/maheshmakvana/" aria-label="Full Biography for Mahesh Makvana: Read more...">Read more...</a></p><a href="/about" class="bio_popup_aboutbtn">About How-To Geek</a></div><link rel="prefetch" href="https://www.howtogeek.com/wp-content/uploads/2021/02/Mahesh.png"/>	<span style="white-space:pre;"><svg role="img" aria-label="Twitter Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;height: 12px;width: 12px;display: inline-block;position: relative;top: 2px;" aria-hidden="true" tabindex="-1"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"></path></svg> <span class="author-twitter"><a href="https://twitter.com/maheshhari">@maheshhari</a></span></span>
<br/>
<div style="display: inline-block;">	<time class="post-date published" datetime="2022-07-13T13:00:06-04:00">Jul 13, 2022, 1:00 pm EDT</time>
| 1 min read
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Mahesh Makvana">
<meta name="twitter:label2" content="Est. Reading Time">
<meta name="twitter:data2" content="1 minute"></div>	</span>
</div><!-- .entry-meta -->
</header><!-- .entry-header -->
</div> <!-- page -->
<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<article id="post-816924" class="post-816924 post type-post status-publish format-standard category-the-geek-blog tag-features breadcrumbs-microsoft-excel breadcrumbs-microsoft-office">
<div class="entry-content e-content">
<p><img class="type:primaryImage alignnone size-full wp-image-731027" data-pagespeed-no-defer src="https://www.howtogeek.com/wp-content/uploads/2021/05/MS-excel-logo-675.png?width=1198&trim=1,1&bg-color=000&pad=1,1" alt="Microsoft Excel Logo." width="1200" height="675"/></p>
<p>Do you want to find and optionally delete the duplicate entries in your spreadsheets? If so, use <a href="https://www.howtogeek.com/howto/45670/how-to-highlight-a-row-in-excel-using-conditional-formatting/">Microsoft Excel&#8217;s conditional formatting</a> option to highlight duplicates and then select an option to remove those items. We&#8217;ll show you how.</p>
<p>To find the duplicates, use conditional formatting that checks the duplicate values in your cells and highlights them in <a href="https://www.howtogeek.com/788658/how-to-copy-conditional-formatting-in-microsoft-excel/">your chosen formatting</a>. Then, optionally, you can ask Excel to remove all duplicates from your dataset, keeping only the unique values in it.</p>
<p><strong>RELATED:</strong> <a href='https://www.howtogeek.com/howto/45670/how-to-highlight-a-row-in-excel-using-conditional-formatting/'><strong><em>How to Highlight a Row in Excel Using Conditional Formatting</em></strong></a></p>
<div class="autotoc_wrapper"><strong class="moka_autotoc_heading">Table of Contents</strong><p></p><blockquote class="moka_autotoc"><p><a href="#autotoc_anchor_0">Highlight Duplicate Values in Excel</a><br><a href="#autotoc_anchor_1">Remove Duplicate Values in Excel</a><br></p></blockquote></div>
<div id="div-thetop1" style="margin-top:5px;margin-bottom:15px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-format="fluid" data-ad-layout="in-article" data-ad-client="ca-pub-9173525300015284" data-ad-slot="2986027408"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>	<div style='clear:both'></div>
<h2 role="heading" aria-level="2"><a name="autotoc_anchor_0"></a>Highlight Duplicate Values in Excel</h2>
<p>To highlight non-unique values, first, open your spreadsheet with Microsoft Excel.</p>
<div class="future_hybrid_paragraph_first"></div><p>In the spreadsheet, select the dataset which you want to check for duplicates. Make sure to include the <a href="https://www.howtogeek.com/220829/how-to-show-and-hide-row-and-column-headers-in-excel/">column headers in your selection</a>.</p>
<p><img class="alignnone size-full wp-image-816954" src="https://www.howtogeek.com/wp-content/uploads/2022/07/1-select-dataset.png?trim=1,1&bg-color=000&pad=1,1" alt="Select the dataset." width="470" height="438"/></p>
<p>From Excel&#8217;s ribbon at the top, select the &#8220;Home&#8221; tab. Then, in the &#8220;Styles&#8221; section, choose Conditional Formatting &gt; Highlight Cells Rules &gt; Duplicate Values.</p>
<p><img class="alignnone size-full wp-image-816955" src="https://www.howtogeek.com/wp-content/uploads/2022/07/2-highlight-duplicate-values.png?trim=1,1&bg-color=000&pad=1,1" alt="Use conditional formatting." width="604" height="500"/></p>
<p>You&#8217;ll see a &#8220;Duplicate Values&#8221; box. Here, click the first drop-down menu and choose &#8220;Duplicate.&#8221; Select the second drop-down menu and pick the formatting you want to use to highlight the duplicate entries. To use custom formatting, choose &#8220;Custom Format.&#8221;</p>
<p>Then, click &#8220;OK.&#8221;</p>
<p><img class="alignnone size-full wp-image-816957" src="https://www.howtogeek.com/wp-content/uploads/2022/07/3-customize-duplicate-formatting.png?trim=1,1&bg-color=000&pad=1,1" alt="" width="513" height="200"/></p>
<div class="future_hybrid_paragraph"></div><p>On your spreadsheet, you&#8217;ll find that <a href="https://www.howtogeek.com/733093/how-to-highlight-blanks-or-errors-in-microsoft-excel/">Excel has highlighted</a> the duplicate entries in your selected formatting style.</p>
<p><img class="alignnone size-full wp-image-816958" src="https://www.howtogeek.com/wp-content/uploads/2022/07/4-duplicates-highlighted.png?trim=1,1&bg-color=000&pad=1,1" alt="Duplicates highlighted in a spreadsheet." width="470" height="439"/></p>
<p>And that&#8217;s how you easily spot non-unique records in your datasets.</p>
<p><strong>RELATED:</strong> <a href='https://www.howtogeek.com/733093/how-to-highlight-blanks-or-errors-in-microsoft-excel/'><strong><em>How to Highlight Blanks or Errors in Microsoft Excel</em></strong></a></p>
<h2 role="heading" aria-level="2"><a name="autotoc_anchor_1"></a>Remove Duplicate Values in Excel</h2>
<p>Excel offers a feature that automatically <a href="https://www.howtogeek.com/198052/how-to-remove-duplicate-rows-in-excel/">removes duplicate values from your datasets</a>.</p>
<p>To use it, first, select your dataset in your Excel spreadsheet. Make sure to select your column headers as well.</p>
<p><img class="alignnone size-full wp-image-816954" src="https://www.howtogeek.com/wp-content/uploads/2022/07/1-select-dataset.png?trim=1,1&bg-color=000&pad=1,1" alt="Select the dataset." width="470" height="438"/></p>
<div class="future_hybrid_paragraph"></div><p>In Excel&#8217;s ribbon at the top, click the &#8220;Data&#8221; tab. Then, from the &#8220;Data Tools&#8221; section, choose &#8220;Remove Duplicates&#8221; (it&#8217;s an icon with an &#8220;X&#8221; on it).</p>
<p><img class="alignnone size-full wp-image-816962" src="https://www.howtogeek.com/wp-content/uploads/2022/07/5-remove-duplicates.png?trim=1,1&bg-color=000&pad=1,1" alt="Select &quot;Remove Duplicates&quot; at the top." width="539" height="342"/></p>
<p>On the &#8220;Remove Duplicates&#8221; box, if you&#8217;ve included column headers in your selection, then enable the &#8220;My Data Has Headers&#8221; option. In the &#8220;Columns&#8221; section, make sure the correct column(s) are listed.</p>
<p>Then choose &#8220;OK.&#8221;</p>
<p><img class="alignnone size-full wp-image-816963" src="https://www.howtogeek.com/wp-content/uploads/2022/07/6-remove-duplicate-options.png?trim=1,1&bg-color=000&pad=1,1" alt="" width="511" height="438"/></p>
<p>Excel has removed duplicate entries from your dataset.</p>
<p><img class="alignnone size-full wp-image-816964" src="https://www.howtogeek.com/wp-content/uploads/2022/07/7-duplicates-removed.png?trim=1,1&bg-color=000&pad=1,1" alt="Duplicates removed from the spreadsheet." width="469" height="382"/></p>
<p>And you&#8217;re all set.</p>
<p><strong>RELATED:</strong> <a href='https://www.howtogeek.com/198052/how-to-remove-duplicate-rows-in-excel/'><strong><em>How to Remove Duplicate Rows in Excel</em></strong></a></p>
<script>
			function readMoreLink(e, to, site) {
				e.preventDefault();
				let xmlhttp = new XMLHttpRequest();
				var htg = -1;
				var htgm = document.cookie.match('htg=([0-9]*)');
				if (htgm && htgm.length == 2) {
					htg = htgm[1];
				}
				xmlhttp.open("GET", 'https://px1.lifesavvy.com/rm/816924/' + to + '/howtogeek/' + htg, true);
				xmlhttp.onreadystatechange = function() {
					if (xmlhttp.readyState === 4) {
						self.location = e.target.href;
					}
				}
				xmlhttp.send();
			}
		</script>
<div class="nextup">
<span id="nextuplabel" style="font-weight: bold; font-size: 22px; color: #000; margin-bottom: 10px; display: block;" role="heading" aria-level="2">READ NEXT</span>
<ul id="nextuplist">
<li>&rsaquo; <a onclick="readMoreLink(event, 808099);" href="https://www.howtogeek.com/808099/awesome-safari-iphone-features/">12 Awesome Safari Features You Should Be Using on iPhone</a></li><li>&rsaquo; <a onclick="readMoreLink(event, 816374);" href="https://www.howtogeek.com/816374/do-wi-fi-extenders-deserve-their-bad-reputation/">Do Wi-Fi Extenders Deserve Their Bad Reputation?</a></li><li>&rsaquo; <a onclick="readMoreLink(event, 806798);" href="https://www.howtogeek.com/806798/how-long-does-it-take-to-charge-an-electric-car-2/">How Long Does It Take to Charge an Electric Car?</a></li><li>&rsaquo; <a onclick="readMoreLink(event, 817813);" href="https://www.howtogeek.com/817813/nasas-new-space-photos-are-the-perfect-desktop-wallpapers/">NASA&#8217;s New Space Photos Are the Perfect Desktop Wallpapers</a></li><li>&rsaquo; <a onclick="readMoreLink(event, 817514);" href="https://www.howtogeek.com/817514/amazon-fire-7-kids-tablet-review/">Amazon Fire 7 Kids (2022) Tablet Review: Safe, Sturdy, but Slow</a></li><li>&rsaquo; <a onclick="readMoreLink(event, 816621);" href="https://www.howtogeek.com/816621/amazon-prime-day-2022-deals/">The Best Amazon Prime Day 2022 Deals You Can Still Buy</a></li>
</ul>
</div>
</div><!-- .entry-content -->
<footer class="entry-footer" data-nosnippet="data-nosnippet">
<div style="border: 1px solid #eee;padding: 15px;margin-bottom: 20px;">
<a href="https://www.howtogeek.com/author/maheshmakvana/"><img width="200" height="200" style="float:left;margin-right:15px;margin-bottom:15px;width:100px;" src="https://www.howtogeek.com/wp-content/uploads/2021/02/Mahesh.png?width=200&#038;height=200&#038;crop=1:1" alt="Profile Photo for Mahesh Makvana"></a>
<span>
<a href="https://www.howtogeek.com/author/maheshmakvana/" style="
					    font-weight: bold;
					    text-transform: uppercase;
					    /* padding-bottom: 10px; */
					    /* display: block; */
					    font-size: 20px;
					    font-family: oswald,roboto,sans-serif;
					    padding-top: 0;
					    margin-top: 0;
					    line-height: 20px;
					"><span style="
					    padding-top: 0;
					    margin-top: 0;
					">Mahesh Makvana</span></a>
<br style="
					    margin-top: 10px;
					"><span style="/* margin-top: 10px; */font-size: 15px;">Mahesh Makvana is a freelance tech writer who specializes in writing how-to guides. He has been writing tech tutorials for over a decade now. He’s written for some of the prominent tech sites including MakeUseOf, MakeTechEasier, and Online Tech Tips. <br style="
					    display: none;
					"><a href="https://www.howtogeek.com/author/maheshmakvana/" style="
					    text-transform: uppercase;
					    font-size: 13px;
					    font-weight: bold;
					    /* float: right; */
					">Read Full Bio »</a></span>
</span>
<div style="clear:both;"></div>
</div>
</footer><!-- .entry-footer -->
</article><!-- #post-## -->
<a name="comments"></a>
</main><!-- #main -->
</div><!-- #primary -->
<style>
	#secondary {
  display: inline-block;
  float: left;
  max-width: 370px;
  padding-left: 30px;
  width: 100%; }
  #secondary .adSystem_ads {
    overflow: hidden; }
    #secondary .adSystem_ads .g-page {
      min-height: 105px; }
  #secondary .did-you-know {
    font-size: 13px; }
    #secondary .did-you-know p {
      margin-bottom: 0px; }
    #secondary .did-you-know .top-bar {
      padding-top: 10px;
      padding-bottom: 10px; }
  #secondary .dyk-content {
    padding: 0px 10px 10px 15px; }
  #secondary .daily-tech-term .dtt-content h4 {
    font-size: 14px;
    font-weight: 600;
    margin-top: 0px;
    margin-bottom: 0px; }
  #secondary .daily-tech-term .dtt-content p {
    margin-top: 0px; }
  #secondary .daily-tech-term .dtt-content {
    font-size: 13px;
    line-height: 16px;
    padding: 10px; }
  #secondary .top-bar {
    border-top: 2px solid #1d55a9;
    padding-left: 16px;
    padding-top: 10px; }
  #secondary .sidebar-glossary {
    width: 300px;
    margin-left: auto;
    margin-right: auto; }
    #secondary .sidebar-glossary .top-bar {
      margin-bottom: 20px; }
    #secondary .sidebar-glossary .sfpost {
      margin-bottom: 15px;
      position: relative;
      min-height: 200px; }
    #secondary .sidebar-glossary .sfp2 {
      display: inline-block;
      float: left;
      position: absolute; }
    #secondary .sidebar-glossary .sfp3 {
      font-size: 14px;
      position: absolute;
      bottom: 5px;
      background-color: rgba(0, 0, 0, 0.75);
      padding: 14px;
      width: 100%; }
      #secondary .sidebar-glossary .sfp3 a {
        color: white; }
      #secondary .sidebar-glossary .sfp3 span {
        font-weight: 600 !important; }
  #secondary #purch_Y_R_0_1 {
    display: block;
    margin: 0 auto;
    text-align: center; }

@media only screen and (max-width: 1070px) and (min-width: 768px) {
  #primary {
    max-width: 65% !important; }
    #primary img {
      max-width: 100% !important; }
  #secondary {
    max-width: 35% !important; }
    #secondary .geek {
      display: none; }
    #secondary .subscribe-text {
      padding-left: 10px;
      width: 100%; }
    #secondary .social-icons {
      display: block; }
      #secondary .social-icons a {
        display: block;
        width: 100%; } }

.sidepopwrap {
  text-align: center; }

@media only screen and (max-width: 768px) {
  .sidepopwrap, body #content #secondary {
    display: none; } }

.popular-posts {
  margin-left: auto;
  margin-right: auto;
  text-align: left;
  width: 300px; }
  .popular-posts .top-bar {
    padding-left: 0px !important; }

.sidebar-popular-post:first-child .title-rendered {
  color: #FFF; }

.sidebar-popular-post:first-child .title-rendered:hover {
  color: #e07d02; }

.sidebar-popular-post:first-child {
  border-bottom: none;
  padding-bottom: 0px;
  padding-top: 0px; }

.sidebar-popular-post:last-child {
  border-bottom: none; }

.sidebar-popular-post .sppfirst-accessible {
    position: absolute;
    padding: 8px 14px;
    background: rgba(23, 34, 50, 0.8);
    color: white;
    font-size: 18px;
    font-family: 'Oswald', sans-serif;
    font-weight: normal; }

.sidebar-popular-post {
  position: relative;
  width: 100%;
  border-bottom: 1px solid #CCC;
  padding-bottom: 10px;
  padding-top: 10px; }
  .sidebar-popular-post img {
    border: 1px solid #000;
    width: 100%; }
  .sidebar-popular-post .post-title {
    width: 100%;
    min-height: 50px;
    padding-left: 10px; }
    .sidebar-popular-post .post-title.first {
      background-color: rgba(0, 0, 0, 0.6);
      color: white;
      position: absolute;
      bottom: 8px;
      padding: 10px; }
  .sidebar-popular-post .number {
    display: inline-block;
    color: #ccc;
    font-size: 40px;
    float: left;
    margin-top: -10px;
    width: 15%; }
  .sidebar-popular-post .title-rendered {
    display: inline-block;
    float: left;
    width: 85%;
    color: #444; }
  .sidebar-popular-post .title-rendered:hover {
    color: #e07d02; }


</style>
<aside id="secondary" class="widget-area sidebar-article" role="complementary">
<div aria-hidden="true" id='purch_Y_R_0_1'></div>	<div style='clear:both'></div>
<div aria-hidden="true" id='purch_Y_S_0_1'></div>	<div style='clear:both'></div>
<div id="floating-sidebar-area">
<div class='future_hybrid_sidebar_top_margin_first' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
<div class='future_hybrid_sidebar_top_margin' aria-hidden="true" id='purch_Y_R_0_1'></div>
</div>
</aside><!-- #secondary -->
<div class="article-bottom">
<div class="OUTBRAIN" data-src="https://www.howtogeek.com/816924/excel-highlight-duplicates/" data-widget-id="AR_1"></div>
<div aria-hidden="true" id='purch_Y_L_0_1' style="padding-top:30px"></div>	<div style='clear:both'></div>
</div>
</div><!-- #content -->
<div class="message" style="
	    padding: 50px 0px 30px;
	    font-size: 15px;
	    margin: 0px 20px;
	"><span style="
	    max-width: 900px;
	    display: block;
	    color: #333;
	    padding: 0px 20px;
	    margin: auto;
	    border: 1px solid #CCC;
	    padding: 20px 20px;
	    background: #FAFAFA;
	">How-To Geek is where you turn when you want experts to explain technology. Since we launched in 2006, our articles have been read more than 1 billion times. <a href="/about/">Want to know more?</a></span>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="logo">
<a title="How-To Geek" aria-label="How-To Geek" href="https://www.howtogeek.com">
<img width="200" height="38" src="https://www.howtogeek.com/wp-content/uploads/2019/02/htglogo_white.png" alt="How-To Geek" class="logo">
</a>
<div class="social">
<a title="Facebook" aria-label="Facebook" href="https://facebook.com/howtogeek">
<div class="facebook">
<svg id="icon-facebook" viewBox="0 0 43.8 34" width="100%" height="100%" aria-hidden="true" tabindex="-1"><title>Facebook Icon</title><g><path id="f_6_" fill="#FFFFFF" d="M22.4,30.1V18.9h3.7l0.6-4.4h-4.3v-2.8c0-1.3,0.3-2.1,2.2-2.1h2.3V5.8c-0.4-0.1-1.8-0.2-3.4-0.2c-3.3,0-5.6,2-5.6,5.7v3.2h-3.8v4.4h3.8v11.2L22.4,30.1L22.4,30.1z"></path></g></svg>
<p>Facebook</p>
</div>
</a>
<a title="Instagram" class="rss-link" href="https://www.instagram.com/howtogeeksite">
<div class="twitter" style="background-color:#c04d02">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" style="fill: white;" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1"><title>Instagram Icon</title><path d="M12 2.163c3.204 0 3.584.012 4.85.07 3.252.148 4.771 1.691 4.919 4.919.058 1.265.069 1.645.069 4.849 0 3.205-.012 3.584-.069 4.849-.149 3.225-1.664 4.771-4.919 4.919-1.266.058-1.644.07-4.85.07-3.204 0-3.584-.012-4.849-.07-3.26-.149-4.771-1.699-4.919-4.92-.058-1.265-.07-1.644-.07-4.849 0-3.204.013-3.583.07-4.849.149-3.227 1.664-4.771 4.919-4.919 1.266-.057 1.645-.069 4.849-.069zm0-2.163c-3.259 0-3.667.014-4.947.072-4.358.2-6.78 2.618-6.98 6.98-.059 1.281-.073 1.689-.073 4.948 0 3.259.014 3.668.072 4.948.2 4.358 2.618 6.78 6.98 6.98 1.281.058 1.689.072 4.948.072 3.259 0 3.668-.014 4.948-.072 4.354-.2 6.782-2.618 6.979-6.98.059-1.28.073-1.689.073-4.948 0-3.259-.014-3.667-.072-4.947-.196-4.354-2.617-6.78-6.979-6.98-1.281-.059-1.69-.073-4.949-.073zm0 5.838c-3.403 0-6.162 2.759-6.162 6.162s2.759 6.163 6.162 6.163 6.162-2.759 6.162-6.163c0-3.403-2.759-6.162-6.162-6.162zm0 10.162c-2.209 0-4-1.79-4-4 0-2.209 1.791-4 4-4s4 1.791 4 4c0 2.21-1.791 4-4 4zm6.406-11.845c-.796 0-1.441.645-1.441 1.44s.645 1.44 1.441 1.44c.795 0 1.439-.645 1.439-1.44s-.644-1.44-1.439-1.44z"/></svg>
<p>Instagram</p>
</div>
</a>
<a title="Twitter" href="https://www.twitter.com/howtogeek">
<div class="twitter">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 300.00006 244.18703" height="244.19" width="300" aria-hidden="true" tabindex="-1"><title>Twitter Icon</title>
<g style="" transform="translate(-539.18 -568.86)">
<path d="m633.9 812.04c112.46 0 173.96-93.168 173.96-173.96 0-2.6463-0.0539-5.2806-0.1726-7.903 11.938-8.6302 22.314-19.4 30.498-31.66-10.955 4.8694-22.744 8.1474-35.111 9.6255 12.623-7.5693 22.314-19.543 26.886-33.817-11.813 7.0031-24.895 12.093-38.824 14.841-11.157-11.884-27.041-19.317-44.629-19.317-33.764 0-61.144 27.381-61.144 61.132 0 4.7978 0.5364 9.4646 1.5854 13.941-50.815-2.5569-95.874-26.886-126.03-63.88-5.2508 9.0354-8.2785 19.531-8.2785 30.73 0 21.212 10.794 39.938 27.208 50.893-10.031-0.30992-19.454-3.0635-27.69-7.6468-0.009 0.25652-0.009 0.50661-0.009 0.78077 0 29.61 21.075 54.332 49.051 59.934-5.1376 1.4006-10.543 2.1516-16.122 2.1516-3.9336 0-7.766-0.38716-11.491-1.1026 7.7838 24.293 30.355 41.971 57.115 42.465-20.926 16.402-47.287 26.171-75.937 26.171-4.929 0-9.7983-0.28036-14.584-0.84634 27.059 17.344 59.189 27.464 93.722 27.464" fill="#ffffff"/>
</g>
</svg>
<p>Twitter</p>
</div>
</a>
<a title="LinkedIn" href="https://www.linkedin.com/company/howtogeek/">
<div class="linkedin">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" style="fill: #FFF;" aria-hidden="true" tabindex="-1"><title>LinkedIn Icon</title>
<path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"></path></svg>
<p>LinkedIn</p>
</div>
</a>
<a title="RSS Feed" class="rss-link" href="/feed/">
<div class="twitter" style="background-color:#c04d02">
<svg title="RSS Feed Icon" role="img" aria-label="RSS Feed Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: white;" aria-hidden="true" tabindex="-1"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21h-135q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5t-391.5-184.5q-25-2-41.5-20t-16.5-43v-135q0-29 21-47 17-17 43-17h5q160 13 306 80.5t259 181.5q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5t-19.5-42.5q-12-215-101-408.5t-231.5-336-336-231.5-408.5-102q-25-1-42.5-19.5t-17.5-43.5v-143q0-28 20-46 18-18 44-18h3q262 13 501.5 120t425.5 294q187 186 294 425.5t120 501.5z"/></svg>
<p>RSS Feed</p>
</div>
</a>
</div>
</div>
<style>
.footer-email {
	display: inline-block;
    float: left;
    width: 33%;	
}

#footer-email-text {
	margin-bottom: 5px;
	font-size: 16px;
	font-family: "Open Sans", sans-serif;
	margin-top:0px;
}
.footer-email form {margin-bottom:10px;}
.footer-email #ftemtxt, .footer-email .ftemtxt {
    border-radius: 0;
    font-size: 16px;
    padding: 8px;
    height: 40px;
    margin-right: 0px;
    border: 0;
    width: 250px;	
}
.footer-email #ftemsub, .footer-email .ftemsub {

    border: 0;
    border-radius: 0;
    font-size: 14px;
    padding: 8px;
    height: 40px;
    margin-left: 0px;
    background: #f79826;
    color: #000;
    font-weight: bold;
}
@media screen and (max-width: 768px) {
	.footer-email {
		display: block;
		text-align: center;
		width: 100%;
		border-top: 1px solid #999;
    	margin-top: 20px;
    	padding-top:15px;
	}
}


</style>
<div class="footer-email" data-nosnippet="data-nosnippet">
<p id="footer-email-text">The Best Free Tech Newsletter Anywhere</p>
<form action="https://www.howtogeek.com/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" type="hidden" name="postid" value="816924">
<input aria-hidden="true" tabindex="-1" type="hidden" name="list" value="weekday">
<input aria-hidden="true" tabindex="-1" type="hidden" name="tr" value="howtogeek-footer">
<input aria-hidden="true" tabindex="-1" type="hidden" name="moka-pagerefer" value="">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Enter Your Email">
<input aria-label="Sign Up" type="submit" class="ftemsub" value="Sign Up">
</form>
<p style="font-size: small;">By submitting your email, you agree to the <a style="display: inline; text-decoration: underline" href="/terms-of-use">Terms of Use</a> and <a style="display: inline; text-decoration: underline;" href="/privacy-policy">Privacy Policy</a>.</p>
</div>
<div class="pages">
<ul id="menu-footer" class="menu" role="menu">
<li role="menuitem" id="menu-item-314681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-314681"><a href="https://www.howtogeek.com/about/">About Us</a></li>
<li role="menuitem" id="menu-item-314683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-314683"><a href="https://www.howtogeek.com/contact/">Contact Us</a></li>
<li role="menuitem" id="menu-item-314685" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-314685"><a href="https://www.howtogeek.com/345703/we-are-hiring/">Join Our Team</a></li>
<li role="menuitem" id="menu-item-407624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-407624"><a href="https://www.lifesavvymedia.com/sponsorship.php">Advertising</a></li>
<li role="menuitem" id="menu-item-314687" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-314687"><a href="https://www.howtogeek.com/privacy-policy/">Privacy Policy</a></li>
<li role="menuitem" id="menu-item-329744" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-329744"><a href="https://www.howtogeek.com/terms-of-use/">Terms of Use</a></li>
<li role="menuitem" id="menu-item-711322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-711322"><a href="https://www.howtogeek.com/accessibility/">Accessibility</a></li>
<li role="menuitem" aria-label="Do not sell my info">
<div id="show-do-not-sell-info-container"></div>
</li>
<li role="menuitem">
<input class="darkModeToggle" id="darkModeToggle" aria-label="Toggle Dark Mode" type="checkbox" onclick="if (document.body.classList.contains('darkmode')) { document.body.classList.remove('darkmode'); document.cookie = 'enabledarkmode=no; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/; SameSite=Strict;'; } else { document.body.classList.add('darkmode'); document.cookie = 'enabledarkmode=yes; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/; SameSite=Strict;'; }"/> <label class="darkModeToggleLabel" for="darkModeToggle">Toggle Dark Mode</label>
</li>
</ul>
</div>
</div>
<a class="copyright" href="https://www.lifesavvymedia.com">© 2022 LifeSavvy Media. All Rights Reserved</a>
</footer><!-- #colophon -->
<script>
		if (document.getElementById('moka_no_dark_mode')) {
			// Disable dark mode (and toggle!) on this page
			[].forEach.call(document.getElementsByClassName('darkModeToggle'), a => a.remove());
			[].forEach.call(document.getElementsByClassName('darkModeToggleLabel'), a => a.remove());
		} else {
			let useDarkMode = false;
			if ( document.cookie.includes('enabledarkmode=yes') ) {
				useDarkMode = true;
			} else if ( document.cookie.includes('enabledarkmode=no') ) {
				useDarkMode = false;
			} else {
				// Default to off
				useDarkMode = false;
			}

			if (useDarkMode) {
				document.body.classList.add('darkmode');
				document.getElementById('darkModeToggle').checked = true;
			}
		}
	</script>
<style>
div.message,body #content {position:relative;z-index:8998 !important;}
.site-footer {z-index:8999 !important;}
#ctMediaContainer { z-index: 1; }
#purch-gdpr-banner { z-index: 999999; background-color: #555; }
body #content #primary #post-451039 .entry-header h1 { font-size: 35px; }
body #content #primary #post-706130 .entry-header h1 { font-size: 35px; }
body #content #primary #post-755717 .entry-header h1 { font-size: 35px; }
body #content #primary #post-781951 .entry-header h1 { font-size: 35px; }
body #content #primary #post-508968 .entry-header h1 { font-size: 35px; }
.google-auto-placed {   display: none !important; }

body.author.archive.darkmode #content .archive-description, body.darkmode .entry-header h2.entry-title a {
  color: white;
}

body.darkmode #content #primary .entry-content {
  color: white;
}

body.darkmode .page-content, body.darkmode .entry-content, body.darkmode .entry-summary, body.darkmode #content #primary .post-navigation ul a {
  color: white;
}

body.darkmode #content #primary article.tag-splashbox .entry-header h2 {
  color: white;
}

body.darkmode .entry-summary {
  color: white;
}

body.darkmode div.message span {
	color: white !important;
	background-color: black !important;
}

body.darkmode #primary .wp-caption-text {
	background-color: #000;
	color: #999;
}

body.darkmode pre, body.darkmode #primary .entry-content > pre {
	color: #eee;
	background-color: black;
	border: 1px solid #eee;
}

body.darkmode .linkedin a svg {
  fill: white;
}

body.darkmode .post-author a, body.darkmode a.post-author, body.darkmode span.post-author, body.darkmode time {
	color: white;
}

body.darkmode #page .entry-header .entry-meta .post-author {
	color: white;
}

body.darkmode .site-footer .pages a, body.darkmode .site-footer .footer-nav a {
	color: #e07d02;
}

body.darkmode .load-more {
	color: white;
	border: 1px solid white;
	background-color: black;
}

body.darkmode { 
	background-color: #000;
    color: #FFF;
}

@media screen and (min-width: 768px) {
	body.darkmode #page .entry-header .entry-title a {
		color:#FFF;
	}
}

body.darkmode #page .entry-header .entry-title a {
	color:#FFF;
}

body.darkmode #page .entry-header {
	background-color: #000;
}

body.darkmode #content {
	background-color: #000;	
}

body.darkmode a, 
body.darkmode .entry-content a, 
body.darkmode #primary .entry-content ul#nextuplist li a {
	color:#e07d02;
}

body.darkmode .article-bottom ins {
	background-color: #000;		
}
body.darkmode .sidebar-popular-post .title-rendered {
	color:#EEE;
}

body.darkmode #content #primary .homepage-articles article header h2.entry-title a, body.darkmode #content #primary .homepage-articles article header h2.entry-title {
	color:#EEE;
}

body.darkmode #content #primary article.type-facts {
	background-color: #14386f;
    border: 1px solid #14386f;
}
body.darkmode #content #primary article.type-facts .entry-content {
	color:#FFF;
}
body.darkmode #content #primary article.type-facts .article-text p {
	color:#EEE;
}
body.darkmode #primary .answers .answer, 
body.darkmode #primary .full-answer-text strong{
	color:#000;
}

body.page-id-692291 .adslot970,
body.page-id-711318 .adslot970,
body.page-id-329684 .adslot970,
body.page-id-1031 .adslot970,
body.page-id-2 .adslot970,
body.author .adslot970,
body.postid-345703 .adslot970 {
  display: none !important;
}

body.page-id-711318 #secondary {
  display: none !important;
}

blockquote.moka_autotoc {
    margin-top: -10px !important;
    line-height: 1.8;
    margin-bottom: 0 !important;
}

.page-id-749264 .splashbox {
	padding-right: 0 !important;
}

.long_form_roundup_widget .lfroundup_introus a {
	text-decoration: underline;
	font-weight: bold;
}

.jwplayer svg {
	max-width: 100px;
	max-height: 100px;
}
.jw-svg-icon {
    height: 24px;
    width: 24px;
}
.jw-player-position {
	height: 371px;
	overflow: hidden;
}	.product-share-links a {
		background-color: #be1522;
	}

	.product-share-links a {
		display: inline-block;
	}

	.long_form_roundup_widget .award {
		background-color: #5d7688;
	}
	.long_form_roundup_widget .highlight {
		background-color: #1a4d82;
	}
</style>
<div id='out-of-page'>
</div>
<div id='1x1'>
</div>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1113647-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1113647-1');
</script>
<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-dPPj_fTCprdm0"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-dPPj_fTCprdm0.gif" border="0" height="1" width="1" alt=""/>
</div>
</noscript>
<!-- End Quantcast tag -->
<!-- Admiral -->
<script type="text/javascript">
if (document.querySelector('.sponsoredtitlebanner') == null && document.querySelector('.single-post') != null && document.querySelector('.tag-holiday-2021') == null && document.querySelector('.tag-commerce_featured') == null && document.querySelector('.tag-hide_inline_content_ads') == null) {
	!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://selfishsnake.com/v2wmlQ4Eo0uS6W8iQLcJuEC0MAK0LD8WB4yVCEXPB6SRDC7tDVUu119qvNU1jB4MG",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o.admiral=o.admiral||t})(window);!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");
	var addEngageListener = function() {
	    if (!window.admiral) {
	        setTimeout(addEngageListener, 500);
	        return;
	    }
	    window.admiral('addEventListener', 'engage.loaded', function() {
	    	window.admiral_engaged = true;
	    });
	};
	addEngageListener();
}
</script>
<!-- End Admiral -->
<script>
/* Comscore */
var IEVersion = function() {
  if (navigator.appName === 'Microsoft Internet Explorer') {
    var re  = new RegExp("MSIE ([0-9]{1,}[.0-9]{0,})");
    if (re.exec(navigator.userAgent) != null) {
      return parseFloat(RegExp.$1);
    }
  }
  return -1;
};

var _comscoreID = '10055482';
var _origin = window.location.origin;
if (_comscoreID!='' && _comscoreID.indexOf('$')!=0
   && (IEVersion() == -1 || IEVersion() > 8)) {
    var scripts = document.getElementsByTagName('script')[0];
	var s = document.createElement('script');
	s.src = (document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";
	scripts.parentNode.insertBefore(s, scripts);
   
	s = document.createElement('script');
	s.innerHTML = "setTimeout('COMSCORE.beacon({"+
		   "c1:2," +
		   "c2:\""+_comscoreID+"\"," +
           "c3:\""+_comscoreID+"\"," +
           "c4:\""+_origin+"\"," +
           "c5:\"Technology - News\"," +
           "c6:\"\"," +
           "c15:\"\"" +
		   "});', 3000);";
   scripts.parentNode.insertBefore(s, scripts);
}
/* /Comscore */
</script>	<script type='text/javascript'>
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var lambdaimg = document.createElement('img');
		lambdaimg.alt = '';
		lambdaimg.width = '1';
		lambdaimg.height = '1';
		lambdaimg.src = 'https://www.howtogeek.com/lambda-uploads/howtogeek/816924/' + htg + '/blank.gif?1657737952';
		document.body.append(lambdaimg);
	</script>
<script>
	var loadOutbrain = function() {
		window.removeEventListener('scroll', loadOutbrain);	
		let script = document.createElement('script');
		script.src = '//widgets.outbrain.com/outbrain.js';
		script.async = true;
		document.body.append(script);
	}
	window.addEventListener('scroll', loadOutbrain);
	</script>
<script>
	!function(){var n,e,a,t,s,i;if((n=document.getElementById("site-navigation"))&&void 0!==(e=n.getElementsByTagName("button")[0]))if(void 0!==(a=n.getElementsByTagName("ul")[0])){for(a.setAttribute("aria-expanded","false"),-1===a.className.indexOf("nav-menu")&&(a.className+=" nav-menu"),e.onclick=function(){-1!==n.className.indexOf("toggled")?(n.className=n.className.replace(" toggled",""),e.setAttribute("aria-expanded","false"),a.setAttribute("aria-expanded","false")):(n.className+=" toggled",e.setAttribute("aria-expanded","true"),a.setAttribute("aria-expanded","true"))},s=0,i=(t=a.getElementsByTagName("a")).length;s<i;s++)t[s].addEventListener("focus",l,!0),t[s].addEventListener("blur",l,!0);!function(e){var a,t,s=n.querySelectorAll(".menu-item-has-children > a, .page_item_has_children > a");if("ontouchstart"in window)for(a=function(e){var a,t=this.parentNode;if(t.classList.contains("focus"))t.classList.remove("focus");else{for(e.preventDefault(),a=0;a<t.parentNode.children.length;++a)t!==t.parentNode.children[a]&&t.parentNode.children[a].classList.remove("focus");t.classList.add("focus")}},t=0;t<s.length;++t)s[t].addEventListener("touchstart",a,!1)}()}else e.style.display="none";function l(){for(var e=this;-1===e.className.indexOf("nav-menu");)"li"===e.tagName.toLowerCase()&&(-1!==e.className.indexOf("focus")?e.className=e.className.replace(" focus",""):e.className+=" focus"),e=e.parentElement}}();	/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);</script>
<script type="text/javascript">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</script>
<script>
	// Load all lazy-loaded images before someone prints:
	let loadAllLazy = () => {
		var imgs = document.querySelectorAll('[data-pagespeed-lazy-src]');
		imgs.forEach(e => e.src = e.attributes['data-pagespeed-lazy-src'].value);
	}
	// IE and FireFox:
	window.onbeforeprint = loadAllLazy;
	// Chrome and Safari:
	let mediaQueryList = window.matchMedia('print');
	mediaQueryList.addListener((mql) => {
    	if (mql.matches) loadAllLazy();
	});
</script>
<script type="text/javascript">
	(function() {
		if (document.referrer) {
			var x = document.getElementsByName('moka-pagerefer');
			for (var i = 0; i < x.length; i++) {
				x[i].value = document.referrer;
			}
		}
		
		document.querySelectorAll('.menu-item, #topmenu li a, .explore-menu-trigger').forEach(function(item) {
			item.addEventListener('click', function(e) {
				var menuLabel = this.innerText.replace('»', '').trim();
				gtag('event', 'Menu Item', {
				  event_catgory: menuLabel,
				  event_label: menuLabel
				});
			}, false);
		});
	})();
	
			window._htg_bordeaux_remove_excess = function() {
			document.getElementById('floating-sidebar-area').style.display = 'block';
				
			[...document.getElementsByClassName('future_hybrid_sidebar_top_margin')].forEach(function(slot) {
				if (slot.offsetTop + slot.clientHeight > document.getElementsByClassName('entry-footer')[0].offsetTop) {
					slot.parentNode.removeChild(slot);
				}
			});
			[...document.getElementsByClassName('bordeaux-slot')].forEach(function(slot) {
				if (slot.offsetTop + slot.clientHeight > document.getElementsByClassName('entry-footer')[0].offsetTop) {
					slot.parentNode.removeChild(slot);
				}
			});
		};
		setTimeout(function() {
			window.addEventListener('scroll', window._htg_bordeaux_remove_excess);
		}, 800);
	</script>
<script>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</script>
<!-- Facebook Pixel Code --- MOVED FROM HEAD - img tags are not allowed in head tag, must be in body (accessibility) -->
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=335401813750447&ev=PageView&noscript=1"/></noscript>
<!-- /Facebook Pixel Code -->
</body>
</html>
