SEARCH

How-To Geek

Troubleshooting Internet Explorer on Vista Locking Up or Running Slowly

If you are having issues with Internet Explorer running extremely slow, crashing, locking up, or just generally behaving badly, there are a couple of troubleshooting steps that you can follow to likely fix the problem. And no, I’m not going to just tell you to install Firefox.

Of course I’ll suggest it, since Firefox is an excellent browser… But for most people, Internet Explorer works just fine and does everything you need. So let’s get that browser working properly again!

Test Using Internet Explorer’s "Safe Mode"

The first thing you can do is run Internet Explorer with all the add-ons (or plugins) disabled, which will help us determine if the problem is caused by an add-on or somewhere else in the system.

You can find the "Internet Explorer (No Add-ons)" menu item under Accessories \ System Tools in the start menu, or you can launch IE from the command line with the -extoff switch like this: iexplore.exe -extoff

 image

If the performance / locking up problems are gone, then you know you are dealing with a problem add-on, most likely one of those toolbars that seem to be attached to every shareware application.

Disable Internet Explorer Add-Ons

Close the "safe mode" IE window, and then open Internet Explorer normally. Click on the Tools menu, then Manage Add-ons, and then Enable or Disable Add-ons:

image

In this screen, you can select Add-ons and then choose to Disable them one by one using the radio button at the bottom.

image

The default list shows only the add-ons that are currently loaded, so you should also check out the other selections, because the problem add-on might not be set to load on startup.

image

In order to properly troubleshoot, it would be easiest to disable all of them, and then re-enable one by one until you find the problem add-on (which you should uninstall if possible)

Reset All Internet Explorer Settings to Default

If you are having too many issues, you can always just completely wipe the slate clean and start over with a fresh Internet Explorer configuration, which should fix the vast majority of issues.

Open the Internet Properties dialog by finding the Internet Options section in Control Panel (just type internet into the search box)

image

(Note that you can also right-click on the Internet Explorer icon on the desktop and choose Properties, or just use Tools \ Options if you are able to open Internet Explorer)

image

Once there, choose the Advanced tab, and then click on that Reset button. Everything will be completely wiped clean, but it’s likely you’ll have better luck browsing from then on.

Scan Your Computer for Viruses/Spyware

This should be a given… anytime your computer is running extremely slow you should scan for viruses and spyware.

Disable Receive Window Auto-Tuning

If none of those fixes the problem, and you are just having a really slow browsing experience only on your Vista computer, the problem could very well be due to the network auto-tuning feature in Windows Vista which is incompatible with some routers.

Open up an administrator mode command prompt (right click on command prompt and choose Run as Administrator), and then type in the following command.

netsh int tcp set global autotuninglevel=disabled

You’ll have to reboot the computer after making this change. Note that the same change also can help fix problems with copying large files.

Re-register actxprxy.dll

According to Windows expert Ed Bott, if you are having issues with Internet Explorer running really slowly, you can re-register the ActiveX Marshaling Library (which is also buried in a Microsoft article).

Open up an administrator mode command prompt (right click on command prompt and choose Run as Administrator), and then type in the following command.

regsvr32 actxprxy.dll

You’ll have to reboot the computer after making this change.

Reboot Your Router!

I can’t tell you the number of times that my browsing experience slowed down to a crawl because my Linksys router needed a reboot. This seems to happen a lot more if you are downloading torrents as well.

image

If you are still having problems at this point, head on over to our forum and ask our growing community of helpful geeks.

Lowell Heddings, better known online as the How-To Geek, spends all his free time bringing you fresh geekery on a daily basis. You can follow him on if you'd like.

  • Published 04/22/08

Comments (41)

  1. tim

    I had no idea you could reset IE to default, great tip!

    Love the last pic :-)

  2. Fird

    Ahh.. I always forgot that router tip! Thanks for reminding me!

  3. Austin

    Excellent tip as always!

    A couple people I work with had problems with IE locking up, running extremely slow, and crashing a few weeks ago. I uninstalled the Google Toolbar and it fixed both of them! When they reinstalled the latest version it worked fine.

    That last picture is great! :D

  4. Daniel Spiewak

    Any consumer ipv4 (NAT-based) router should be restarted at least once every few weeks. With some routers (like the more recent LinkSys), I would recommend power cycling even more frequently. The problem is that most routers have slight memory leaks in their firmware. The NAT table is a very oft-queried component in IPv4 routers, so this is often where the problem shows up. The reason the issue is exacerbated by torrenting is because BitTorrent (as with most P2P software) opens up a large number of short-lived connections to different destinations. This causes a *massive* amount of load on the NAT.

    Even using m0n0wall, which is vastly superior to consumer routers, I still have to reboot once every few months.

  5. whoisvaibhav

    The plugins part is exactly what I did for my IE7 installation on WinXP long time ago: [mod-removed]

    However, I didn’t know the reset tip (for some reason my particular IE7 installation gives javascript errors on sites where other people’s IE7 doesn’t). I will try to reset tip to see if that works..

  6. whoisvaibhav

    I confirm that the Reset trick fixed my IE big time. Not only have I stopped getting these stupid Javascript errors, there’s another thing that has been fixed.

    It used to be so that IE7 would display any images in webpages in a blurry (less resolution?) manner with jagged edges.

    That is fixed now.

  7. jobe masters

    The reason the router needs resetting with p2p is that there are too many open connections. Routers usually have a default timeout for open connection which is too long for p2p networking.
    In most routers (including the linksys ones) you can’t change this setting, but alternative router firmware (such as the ones covered by lifehacker here: http://lifehacker.com/344765/turn-your-60-router-into-a-user+friendly-super+router-with-tomato) will allow you to set this to a shorter time, thus, eliminating this problem. (and usually – this will make your p2p networking faster and more efficient.)

  8. forestdance

    For many of my acquaintances who experience gradual slowing of their computer and particularly their internet, I recommend the checking for spyware as a first step. Many think that their virus protection automatically scans for spyware and catches it all. It may not. Running a separate spyware program will often dramatically improve their functioning. I personally like the Ad-Aware SE Personal one (it’s free), but there are many out there or they can upgrade their virus protection to include spyware. Thanks for the additional tips to try.

  9. Pavan Patel

    Thanks for this valuable information……

  10. Murtuza Khambhaty

    Hey !
    It’s works….Many thanks for the tips..
    I was trying to fix this problem from last 2 hours and finally follow what you said and it works for me.

    Please keep sharing such things…

  11. mercedesccc

    I have vista and Internet Explorer keeps locking up and webpages have words upon words, I can’t view video clips, some secure sites that require passwords will not totally download. Is it possible to fix this?

  12. mochafl

    Open up an administrator mode command prompt (right click on command prompt and choose Run as Administrator), and then type in the following command.

    how do i do this

  13. will

    I am an apple fan and new to this vista thing – new laptop for the teenage kids and all……..and I really don’t have much of an idea what you mean by all this stuff…but thanks anyway. Vista and the rest really are not progressive are they.

  14. mike

    well , the above steps did was not supportive & it did not help me in any way
    but thanks anyways.

  15. Aleeve

    Nice reference to south park – very appropriate! Love that episode

    Great tut too :D

  16. Cyrel

    brilliant!!!

  17. Sajith

    I have vista home premium.When connected net then IE is not loading any page.I instal Mozilla Fire fox also,then also pages are not showing.what is the problem ?

  18. siim

    I also have an issue… If i try to open internet explorer on my vista home premium it just says internet explorer have stopped working and doesnt do anything plus it is affecting my downloads… Please help someone i appreciate that :)

  19. KAB

    I am having the same problem outlined by Sajith above…
    I have vista home premium.When connected net then IE is not loading any page.I instal Mozilla Fire fox also,then also pages are not showing.what is the problem ?

    Does anyone have any suggestions?

  20. nohairleft

    i have a problem that i can’t seem to fix totally. i have vista and IE8. at times i lose sound AND the ability to copy and paste. at one time i found a forum that suggested a codec download, which i did and it fixed the problem…or seemed to, for a short time. now i’m back to the same thing…no sound and not able to copy and paste, at times. if i reboot, the sound and the copy and paste stuff will come back for a lil while. any suggestions…it’s drivin me to drink excessively and pull my hair out!!

  21. Jamie Carr

    I have a problem with vista IE8. When bootingup the app I then get an error message stating that Internet explorer has stopped working properly and gives me 2 choices…to close the program or go online and search for a solution. when I select that option IE hangs and I cannot even close it down. I have tried to install another version but keep being told that the version on my laptop is a newer version. I have also seen my security crash as a result and have so far been unable to re-install.

    Can anyone help?

  22. Jill

    Thanks! That was great advice. It turns out, after I tried all of the previous suggestions, all I had to do was reboot my router :P Maybe move that one to the top of the list lol.

  23. Robert

    I have 73 or so running on my comp. at all times which ones do I need and dont need

  24. Dick

    I have Vista home premium and IE7. I have to sign in every
    time i want to check my mail. It won’t remember my password
    and is very unstable. Windows Live mail with Qwest live.
    Does anyone have some ideas? Thanks

  25. David

    For the last several days I’ve had to sign in every time I close my Optimum Online window. This even happens if I close then immediately reopen the window. I’m using a wireless HP Pavilion laptop running IE7 and Windows Vista. Same thing occurs on a wireless desktop at my job but not with the wired desktop. Tried adding Optimum to allowed sites through Internet Options (never had to) and it didn’t work. I haven’t personally made any changes in the system lately and automatic update has been off. Did a full system scan using NoAdware and no dice. Any ideas?

  26. john zolner

    Im reading all posted comments about internet explorer not working and went to repair specialest and he explained in some areas of country and heavy usage of internet this is common problem. It also depends on cheapness of computer. I advise from experience dont download any programs from internet to try to fix these problems If you do you will find these programs will attach itself to your opeating system and you will have a DIFFUCULT time to remove them as they will make there present known in constasnt reminders to purchase more of there content and popup blockers wont remove these popups
    It can be more adviseable to let experts take care of problem, I did and didnt have to go thru all of the fixes people recommend. Of course There is charge but it was worth it. Unless of coarse you are an expert computer user well advanced in computer usage. also the lower the price of unit brings these problems on. That is why I had Mine built the way I want it cost money but NO PROBLEMS at all

  27. David The Anti-Geek

    Could not figure this out to save my life, very frustrated. Thank you, disabling Google Taskbar cured the problem – FINALLY! Really appreciate the help, searched all over till I found this post.

  28. kelly

    Thank you so much for the help. I have become so frustrated bc ie has been so slow and not loading, freezing etc. I thought maybe my computer was low on space and needed to remove some stuff. thank you for saving me the trouble because now all is running super fast again!!!

  29. Paul

    Thanks. Seems to be working much better now.

  30. jacqui

    Ayee! Thank you, followed all steps, IE8 is behaving FINALLY – PTL. and added bonus, Outlook is also faster (a coincidence?). Maybe rebooting the router should be the first step?

  31. Chris

    Thank you sooo much. This article was my first result on Google and it fixed my problem in minutes. I couldn’t load anything in Internet Explorer, now it loads fast. I disabled the add-ons and reset it back to default settings.

    I don’t normally post comments, but was very grateful for the fix, so wanted to express it.

    Thanks again!

  32. Emma

    Thank you soo much for the help!!

    I really found it worth it to try out one of your solutions and indeed it did work satisfact…

    Like Chris I also never comment but this time around I have to show my appreciation.
    Had a Problem with my windows and Internet Explorer runnin on vista.It would take like 10 mins to load, but after resetting the internet options to default vola!!!!!!! The delays are now history.

    Thanks again

    Cheers!!!!

  33. Denise Chilton

    I have done all the suggestions listed above and when I click on Internet Explorer it does nothing….no hour glass.or anything..it’s like it doesn’t recognize it at all. I have Internet Explorer 8 and it worked fine up until 4 days ago. Can anybody help?

  34. ryan_expert

    thanks for the help. i could load webpages no problem, but the actual program was lagging like crazy. it literally took 4 – 5 seconds just to close a tab or window. apparently it was the AVG Safe Search add on slowing it down. it’s only been doing it for a couple days, i wonder if it was some messed up update from AVG. i may go send them an angry email >.>

    anyway, thanks again!

  35. Sami Richmond

    ok so i have an acer netbook with windows vista and my internet explorer wont load any pages it just says page cannot be displayed….ive restored my laptop to the day before and it worked and loaded fine but after an hour or so it wouldnt load any websites any more. i ran MaCaffe and it had said their were no viruses.. upon opening my IE i went under tools and tried to click on internet options but it would not allow me…if anyone has suggestions on ways to fix this plz contact me and help :/ im desperate!!!!

  36. oli-uk

    If you have no internet connectivity, try and find a disk from someone with Firefox,chrome, opera or whatever other browser and install this even if you never use it again

    My advice for what its worth is that if you have a working version of IE whether IE8 or 9 or whatever
    Don’t touch it
    Leave it alone so that it can do updates

    If you try to upgrade it, downgrade it or even use it for browsing it will probably break and then you can’t do any updates.

    Use a different browser for everyday use and leave IE to do updates only
    There are lots of browsers to choose from

    If you are really keen on using IE then at least download another browser SOON so that when IE stops working you can get some online help.

  37. Annonymous

    Man.. after banging head with Microsoft, this post helped resolve my issue. I was getting weird error messages on OWA. I disabled the add-ons, and found the issue to be resolved. Many thanks for this post.

    cheers!

  38. Mary Bartley

    Is the problem that Vista has problems. It doesn’t have the best reputation. Every time I am on the computer for any length of time this happens. I am not computer-savy enough to try to do some of the things that are suggested. Norton has swept the computer and o problems,

  39. Aimee

    Wow – thanks so much for your advice. After hours of struggling with Internet Explorer in SLOW MODE – and after scanning for viruses and spyware, and checking to make sure it wasn’t something related to my Internet provider – finally stumbled onto your article and IT WORKED! I ran IE with Add-ons disabled – and it just sailed right along! Then I went back and disabled all the programs that I thought might cause trouble – and everything is still working smoothly! I can’t thank you enough – we are all so reliant on our computers today – it’s amazing how disabled we become when our computers become disabled!

    anyway – many thanks. after having a bit of a less than perfect day – your advice really helped turn the tide on that.. keep up the great work! best! -aar

  40. Greg

    Thanks for the great help! Your clear directions allowed me to diagnose and fix the MSIE add-ons’ problem with my computer quickly and easily.

  41. Stan

    Thanks for the great info. Cleared my problems up. Some of the best advice I have seen and used.

Get Free Articles in Your Inbox!

Join 134,000 newsletter readers

Email:

Go check your email!