SEARCH

How-To Geek

How To Force Extension Compatibility with Firefox 3.6+

If you’ve already upgraded to Firefox 3.6, you might have noticed that many of your extensions no longer work, and the old checkCompatibility trick doesn’t work anymore. Or does it?

Thanks to my good buddy Daniel for pointing out the change in Firefox 3.6. His personal blog is so nerdy it will make your head explode.

Force Extension Compatibility with Firefox 3.6+

This is the error you get when you try and install an extension that isn’t compatible. Pay special attention to the Firefox version string, as we’ll need that later.

 image

Type about:config into the address bar, and then after clicking through the warning, you’ll want to right-click in the list and choose New –> Boolean from the menu.

image

Now we’ll be prompted to enter the preference name. This is where you need to pay attention to the exact version you are using, because the preference has to be set for the exact version of Firefox you are using.

We’re using Firefox 3.6b3, as noted in the error message above, so the preference would be the following… note the capital C there, very important.

Update: For the current Firefox 3.6 release candidate you’ll need the following:

extensions.checkCompatibility.3.6

Basically the format is extensions.checkCompatibility.VERSION.b for Beta releases or extensions.checkCompatibility.VERSION.a for Alpha releases. So if you were testing out Firefox 3.8 Alpha, you’d use extensions.checkCompatibility.3.8a as the preference name.

image

Yeah, that wasn’t the simplest thing. On the next dialog, just choose “false” and close the dialog.

image

You should now see the value in the list if you filter for it.

image

And your extensions should now install. If they don’t, then you probably put the wrong version into the preference name.

image 

Definitely a very useful tip, and one that I suspect I’ll be using all the time.

Lowell Heddings, better known online as the How-To Geek, spends all his free time bringing you fresh geekery on a daily basis. You can follow him on if you'd like.

  • Published 11/25/09

Comments (16)

  1. WIIIAI

    There’s an easier way — the Nightly Tester Tools add-on. Puts a button in the add-ons sidebar to override compatibility.

  2. Jon

    The Nightly Tester Tools adds a whole bunch of other stuff that most of us don’t want. I’d rather just do the quick tweak instead, and keep my extension list smaller.

    Thanks for the tweak! I was wondering what was going on.

  3. Phil

    Great tweak I had no idea that you could do this

  4. aj99

    Sweet! now I can use Firefox 3.6 again. I installed it and had problems so I stopped using it but with this I can use it now.

  5. Travis

    I actually like the new Add-on Compatibility Reporter from Mozilla. It sets the compatibility flags in config for you. Then after you have tested the extensions, you can send reports to the add-on developers to let them know their extensions are compatible.

    https://addons.mozilla.org/en-US/firefox/addon/15003

  6. The Geek

    Yeah, this is the very first setting I use when setting up a new profile.

  7. ArpitNext

    Well, that may cause trouble & may crash firefox. Another way to make a particular add-on working:

    1> Download the XPI file directly (Right click on install button, save target as)

    2> Unzip the xpi file using Winrar or any such tool.

    3> Edit the install.rdf file – change version number to 3.6 or something else. Save file.

    4> Zip the file again. Change the extension (.zip to .xpi) – Install the add-on by dragging.

    Thankfully, this method will not crash the browser – and you can change setings for individual add-ons

    Cheers!

  8. Dianne Moses

    Sincere thanks for this tip. I use Roboform to store many passwords, and it’s great to have it back, rather than opening IE whenever I visit a site where I need a password and username.

  9. John

    Very helpful.

  10. Broni

    MR Tech Toolkit add-on always take care of the issue.

  11. paranoia

    “MR Tech Toolkit add-on always take care of the issue” great answer, that’s why I quoted you Broni,exactly what I was going to say, works every time.

  12. Ramon E. Ritter

    Thank you very much. It’s just the information I needed to upgrade to FF 3.6

  13. frankell

    … you made my day !!

  14. Horacio

    hello guys
    i followed the steps for this but when i switch engines to
    open a website with the IE tab add-on this one jusf stop and says LODAING on the tab name
    and never displays the page
    any clues????
    thank you

  15. Sitthykun

    beautiful code ….!

  16. Ajetovski

    WHAT DO i TYPE FOR THE CODE IF MY VERSION IS 3.6.13?

Get Free Articles in Your Inbox!

Join 134,000 newsletter readers

Email:

Go check your email!