SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

Windows message re:imminent hard drive failure

(20 posts)
  • Started 2 years ago by ElStellino
  • Latest reply from giannisoft
  • Topic Viewed 20780 times

ElStellino
ElStellino
Posts: 16

Since 6 months ago randomly Windows 7 prompts a message regarding the hard disk imminent failure.

Since then I always backed up all my data on my wife's laptop and on other storages. I honestly don't care, I can reinstall everything when it will happen, but as 6 months have passed, the hard disc has been checked in the meanwhile several times with check disk and with other software, hence I start doubting of the reliability of this message. Also because this message saying that a problem has been found appears randomly in the middle of something important stating that there is a problem that only Windows 7 can detected but all the other software programs on the market can't.

The hard disk is 18 months old, in perfect health, fast, silent; and Windows 7 in spite of the fact that supposedly knows that there is a problem, it doesn't even bother to tell me which problem it is. Even if you click on the 'Don't bother me again with this stupid message' the message will prompt again. And again. And again.... ad infinitum.

Does anybody know how to disable this annoying messages forever, maybe with a registry hack, please?

Posted 2 years ago
Top
 
vistamike
vistamike
Posts: 10945

I don't think it is a good idea to disable that prompt.
There are a couple of things to try just to check

From the command prompt type sfc /scannow
and see if that finds anything.
Also Seatools
Although this is from Seagate it works on most drives.

Mike

Posted 2 years ago
Top
 
ElStellino
ElStellino
Posts: 16

Many thanks Mike, I tried sfc and it did something more than scanning because it seems from the log that also repaired something. However, it's too long to paste everything here.

I tried then to perform a S.M.A.R.T. test with the Seagate program, and it came out as "passed".

Does this mean that possibly whatever was wrong has gone?

But in the event the message will appear again I honestly would like to disable it: I understood there is a problem, prompting it 3 times a day won't solve it.

Posted 2 years ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

I have a feeling that it comes via Security Center. So in there, you need change the way Security Center alerts me.

Posted 2 years ago
Top
 
ElStellino
ElStellino
Posts: 16

Well, thanks, but after I performed these two scans I'd rather leave it like that for the moment, to see if the message prompts again. Security Center wants me to perform a back up which I have been doing it already since many moons ago, and so I muted it: I didn't want to use tons of DVDs and needed instead the information in my hard drive scattered amongst my storages for an easy recovery.

Posted 2 years ago
Top
 
ElStellino
ElStellino
Posts: 16

Hello, here I am back again. This morning I switched the computer on and the message came out twice already. Waiting for the third one in which I can click "bugger off, I don't want to know".

Seriously, I'd like to disable it: "don't tell me again about this problem" means exactly "don't tell me again about this problem", but Windows doesn't get it.
I have done my back up already, I am confident the hard disk will last other five years with no problems, I really don't want to be reminded every day. And if it dies I'll do like in the old days with windows 3.10, 95, 98 and XP: that day the computer will say "Media test failure, check cable - operating system not found" and then I will get a new hard disk. Not now that hard disk is working perfectly.

Please, if you know how to disable the prompt, share: you'll make me happy :)

Posted 2 years ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

See my last post.
Set it to never.

Posted 2 years ago
Top
 
ElStellino
ElStellino
Posts: 16

Hello Lighthouse, where do I find Security Center please? Action Center, Security? I have nothing saying about messages from Windows there. All messages addressed to other issues (Firewall, Virus Protection, Windows Update, Spyware protection and so on.)

Posted 2 years ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

If you start typing security center in the Start Search box, it will show on the list.
I am on Vista, but I think it's the same in 7.

Posted 2 years ago
Top
 
Santo
Santo
Posts: 1288

Imminent hard drive failure error is because your computer hard drive has SMART technology to do a predictive failure analysis and to tell you when its failure is imminent. This can be a false warning too. If it is so the only way to disable this warning is from the computers BIOS setup or you may check for the latest firmware for the hard drive and install it from your PC/Hard drive manufacturer website. There is no way you will be able to disable this error in Windows Action Center.

Edit: If it is in warranty, then I recommend you to get it replaced.

Posted 2 years ago
Top
 
ElStellino
ElStellino
Posts: 16

@Lighthouse, it's different in Windows 7: if I type "Security Center" in the search box it comes out just one result from Control Panel, "Check Security Status". It's where I went to previously but no happiness there.

@Santo that makes sense. I will try to do a firmware update I remember I searched for it last time but I was already running the latest one. I will check now.

If it doesn't work I will check the BIOS.

The hard drive, a Samsung Spinpoint, would be in warranty but when I bought it I opted for the OEM version for the lower cost: thing is that that the 36 month warranty is given only to regularly imported hard drives and I didn't know (nor ebuyer.com wrote on the description) that an OEM version isn't just something without a box but something automatically losing any warranty rights.

Thanks all!

Posted 2 years ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

Santo. Interesting. I have SMART, but there is nothing in the BIOS about it, or disabling alerts of any kind (except for power supply)

Posted 2 years ago
Top
 
Santo
Santo
Posts: 1288

@LH, the option to enable or disable SMART option in BIOS differs from manufacturer to manufacturer and also depends on the BIOS version of the manufacturer.

@ElStellino, "Security Center" in Vista was replaced by "Action Center" in Windows 7.

Posted 2 years ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

Santo. I know all BIOS's differ :)
and thanks for that info about SC being changed to AC. Until I get my main laptop up and running, I can't access 7.

Posted 2 years ago
Top
 
ElStellino
ElStellino
Posts: 16

Hello,
10 days have passed since Windows 8 has been installed in a second partition of the same "failing" hard drive, and for W8 this hd is healthy. Never saw the message again, hence it was (actually it still is) a bug of W7. I had already the latest HD firmware update already but I actually haven't checked in the bios yet.
Thanks guys.

Posted 2 years ago
Top
 
ElStellino
ElStellino
Posts: 16

Hello, I decided to log in again in windows 7 today and with punctuality the prompt appeared again. Decided to solve this thing I restarted the computer and opened the BIOS setup, I found SMART and it was already disabled.
Right now I am using Windows 8 although I don't like the Metro interface, and that's just not to see that message. But as W8 is a consumer preview eventually it will expire and it will no longer work, forcing me to go back to Windows 7.
For this reason I really would like to disable that prompt. Has anybody more ideas, please?

Posted 2 years ago
Top
 
Xhi
Xhi
Posts: 6298

Have you run a full scan with Malwarebytes Antimalware?

Posted 2 years ago
Top
 
ElStellino
ElStellino
Posts: 16

Hello Xhi, no, I generally use Spybot. I will restart the system later and try that one too, thanks.

Posted 2 years ago
Top
 
morning
morning
Posts: 2

well if it's still of any use to you here we go.... I had the same problem few weeks ago and after a long search I found out that this guy here "Microsoft-Windows-Disk-Failure-Diagnostic-Module" (which by the way also reads the S.M.A.R.T. info from HDD) gives you the frustrating message.
so in win 7 go in regedit (registry editor u can type regedit in windows search from start menu) and look for: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\DiskDiagnostics\FallbackPolicy there you will find "EnabledScenarioExecutionLevel" with a value of 2 just change that value to 1 and your message error should go away (to change the value right click on the name and then modify) . you can also open regedit and go EDIT>> FIND and type in EnabledScenarioExecutionLevel but make shure when it finds the value is in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\DiskDiagnostics\FallbackPolicy (for windows7 in other windows versions is in other places)... for me at works for now I applied the method a few days now and the message has gone away so far :)

hope it helps.

P.S. for the worried "experts" .... yes I backed my data, yes I checked my drive for errors and so on... if the hdd shows no problems and the message is frustrating IT MUST BE STOPPED!!! :)

G'day!

Posted 1 year ago
Top
 
giannisoft
giannisoft
Posts: 1

Hallo. You can disable this notification under the scheduled tasks. Win7 --> system control, system and security, management, task planning.
Then left click to task planning library > Microsoft > Windows > DiskDiagnostic and delete the entry in the middle field.
There are no other ways.
Ciao

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!