SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 8

(Solved) - Windows 8 and Java problem.

(13 posts)
  • Started 1 year ago by ipadfan23
  • Latest reply from Lighthouse
  • Topic Viewed 27023 times

ipadfan23
Posts: 16

Hi, there!

I have windows 8 on my laptop. A couple of days ago downloaded Java 7 update 17 on it. ( Windows 8 desktop mode). But it looks like they are not compatible, my Windows ( Google chrome and Internet Explorer) can not verify that Java is installed. I rang Oracle(Java) and Microsoft people. They are aware of the problem, but did not give any solutions.
Does anyone knows how to fix the problem. Because certain programs do not work without Java.

Thank you very much.

Posted 1 year ago
Top
 
Xhi
Posts: 6298

If the previous update worked, go back to it until the problem is fixed.

Posted 1 year ago
Top
 
ronniesonora
Posts: 919

ipadfan23, you might check and see if Java Script is disabled in Google setting. Go to settings--show advanced setting--under Privacy click on content settings--then go to Java Script and see if the circle (allow all sites to run Java Script) is ticked.

Posted 1 year ago
Top
 
ipadfan23
Posts: 16

Thank you for suggestion, Xhi, but I got Windows 8 recently and I do not know if previous updates worked with it. From what I read the oldest version of Java that suppose to work with Windows 8 must be Java 7 update 10. I have tried that and even Java 6 update 43, but no results. Windows still do not recognize the installed Java.

Posted 1 year ago
Top
 
ipadfan23
Posts: 16

Thank you, ronniesonora. I have checked, the Java script circle is ticked. There must be something else.

Posted 1 year ago
Top
 
raphoenix
Posts: 14920

This is what MS says about installing Java RT 7 Update 17 in Windows 8 with IE 10.

http://windows.microsoft.com/e.....e-10-win-7

Posted 1 year ago
Top
 
ronniesonora
Posts: 919

ipanfan23, If you use 32-bit and 64-bit browsers interchangeably, you will need to install both 32-bit and 64-bit Java in order to have the Java plug-in for both browsers. check here http://www.java.com/en/download/manual.jsp

Posted 1 year ago
Top
 
ipadfan23
Posts: 16

Thank you, raphoenix, this is what I have done from the very beginning. But windows 8 ( and Internet Explorer) do not recognize the installed Java.

Posted 1 year ago
Top
 
ipadfan23
Posts: 16

Hi, ronniesonora, thank you. Yes, I downloaded both yesterday, but no results. I will try to download both of them tomorrow, just to try once more. Thanks again.

Posted 1 year ago
Top
 
ipadfan23
Posts: 16

Hi, everyone !

Thank you for all your suggestions! During those few days I have tried nearly everything.....except disabling my Kaspersky Internet Security 2013. When I disable Kaspersky (and at the same time so called Windows Defender is disabled) - Java 7 update 17 starts to work. And only then Java tester confirms that java is installed on my laptop!
Now I just have to figure out what adjustments in settings of Kaspersky Security or Windows Defender I have to make, so I do not have to disable them all together.
I would like to hear some ideas. Thank you very much.

Posted 1 year ago
Top
 
ronniesonora
Posts: 919

ipadfan23, glad you got it fixed! On your question about Kaspersky and Windows Defender. I would have thought that Kaspersky would have turned Windows Defender off. Usually then you have two anti-virus programs running, you end-up with a conflict as you did. So i would only run one. Personally, I would use Windows defender and Anti-Malwarebytes. They will work together. http://www.filehippo.com/downl.....i_malware/

Posted 1 year ago
Top
 
ipadfan23
Posts: 16

Hi, ronniesonora. Thank you for your answer! I will definitely consider your advice. Personally, I like Kaspersky Security, because it always kept my computer running without viruses. But because of the Windows 8 Windows Defender program I will have to consider a change. Thanks again.

Posted 1 year ago
Top
 
Lighthouse
Posts: 13598

Could be a Firewall issue, so check that.

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.