SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

windows 7 and xp networking help (after reading how to)

(22 posts)
  • Started 4 years ago by wonderland
  • Latest reply from wonderland
  • Topic Viewed 19397 times

wonderland
Posts: 13

I tried doing howtogeek's how to guide on windows 7 and xp networking but I couldn't connect both pc's

My question is ..
If I haven't had these 2 pc's I networked together before, will this guide still work ? I did this step by (I have linksys wireless router) but I can't see xp computer when I check network. Only other thing I can see is Network Infrastructure Linksys WRT54GL. Both pc's ar connected to wireles router...
Maybe there is something more I should do on xp side ?

Any advice would be greatly appreciated.

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

wonderland, hello. Which guide did you follow? Can you provide a link to it please?

Posted 4 years ago
Top
 
wonderland
Posts: 13

http://www.howtogeek.com/howto.....-7-and-xp/

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

You won't see the XP system on the Windows 7 system unless you have enabled File and Printer Sharing on the XP system and shared some folder or printers. This isn't shown in the article.

Posted 4 years ago
Top
 
wonderland
Posts: 13

I shared folde on windows 7, shared and entire drive on windows xp, but I still can't see other pc :(

Do you mean enable file and printer sharing in network wizard in xp ? or in services.msc ?

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

If the Network Wizard allows you to enable File and Printer Sharing, then that should work. What I would do is modify the connection properties so that File and Printer Sharing is bound to the adapter that you are planning to share with. Either way, once File and Printer sharing is enabled, the service should be running in services.msc. You should not need to start the Service manually.

Also, make sure that you don't have a software firewall that is blocking File and Printer sharing traffic (SMB).

Posted 4 years ago
Top
 
wonderland
Posts: 13

What I would do is modify the connection properties so that File and Printer Sharing is bound to the adapter that you are planning to share with. - where can I configure that ?

Other pc has windows xp home - maybe thats the problem ?
Maybe im just doing something wrong.
I have:
*followed the guide configuring windows 7
* server - enabled in services.msc (I have some things switched off in services.msc in xp though but im not sure what exactly is needed for networking, all default settings are present in windows 7 though )
* workgroups are with the same name on win7 and xp
* both windows have shared folders
* both windows ar connected to internet via wireless router

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

So, if you open Network Connections from Control Panel or My Network Places, you will see the list of network connections, such as "Local Area Connection", "Wireless Network Connection", and so on. Choose one of these connections and select Properties. This Properties sheet will show you the network adapter being used for the connection under "Connect using", and the network protocols bound to the connection (aka bindings) under "This connection uses the following items". You need to be sure that File and Printer Sharing for Microsoft Networks is in the list of bindings and selected.

I'm not sure which services are needed either, but my guess would be that you at least need Computer Browser, Server, Workstation, maybe Network Location Awareness, maybe Network Access Protection (SP3) and all of their dependencies.

Also, do you have Password Protected Sharing enabled in Windows 7? If so, you will need to provide user credentials to the Windows 7 system in order to access it.

Posted 4 years ago
Top
 
wonderland
Posts: 13

The file and printer sharing binding was already enabled in both computer wireless network connections.

I have most services enabled, I just had spoolsv disabled because i didn't use printer etc. Workstation was enabled (i didn't mess up services I just followed a guide and disabled what isn't needed), those services you described were enabled.

Password protection is disabled in windows 7 as well

Posted 4 years ago
Top
 
ashi
ashi
Posts: 33

hi wonderland
the tut you followed is good but it was failed to mention what you MUST have on XP to be seen in Vista/7.
You need to see install the LLTD Responder on your xp. BUT if you have xpSP3 it would NOT install either so you have to extract the downloaded exe file and install manually the LLTD once you do that and confirm it that you have an entry "Link Layer Topology Responder" (I do not have access to XP so I am not sure what is the exact line)

how to extract the exe file??
Rename the WindowsXP-KB922120-v5-x86-ENU.exe to lltd.exe and copy it to C: drive.
Go to command prompt and type
cd c:\
Then
c:\lltd.exe -x:c:\lltd

you should a file name lltd on C drive. the folder named SP2QFE and another folder IP are the one you are after.

Go to your connection properties and INSTALL ---> PROTOCOL ---> HAVE DISK---->point to C:\lltd\sp2qfe\ip
It should install the lltd and you should see a new entry "Link Lyar Topology Responder".
Restart your computer and you should see XP in vista/7..

anything else just ask......

Posted 4 years ago
Top
 
wonderland
Posts: 13

Hey ashi, thanks for your help.

I Didn't install what you said because, at the moment, I can see windows xp pc on my windows 7 machine. Im not sure what I did, guess it was restart on xp machine. Problem is that I can't see windows 7 shared folder on xp and I can't connect to xp from windows 7. any ideas ?

Posted 4 years ago
Top
 
wonderland
Posts: 13

oh , when I try to connect to xp from win 7 i get "windows cannot access \\RIRARDSPC" check the spelling of the name. Otherwise there might be a problem with your network To try to identify and resolve network problems, Click Diagnose.

Posted 4 years ago
Top
 
wonderland
Posts: 13

restarted windows 7 and I can't see xp pc on network again :(

Posted 4 years ago
Top
 
wonderland
Posts: 13

update, I can see windows xp on my windows 7 machine ( laptop was connected to wrong network) , can't see windows 7 on xp pc though .... and can't connect from windows 7 to xp :(

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

wonderland, you might be interested in a parallel thread with a similar problem. We need to check your networks from the Command Prompt as shown there.

Since I don't know the host names of your systems, I will just call them XP-PC and WIN7-PC. On the WIN7-PC, run the following command:

net view

That will show you all of the systems that are seen by the WIN7-PC including itself. Next, we will ask the WIN7-PC what it is sharing:

net view \\WIN7-PC

Similarly, on the XP-PC we want to ask which other systems it can see and have it look for shares on the WIN7-PC so run the same commands shown above but on the XP-PC. Copy the output here in a new post.

Posted 4 years ago
Top
 
ashi
ashi
Posts: 33

hi again
lets start from the scratch.. i mean from Bottom. and then you can secure it once it is working.
please excuse for some obvious instructions ;)

Windows 7:
STEP 1:
Add new user in User Accounts
USER "geek" and
password: 123.
STEP 2:
Go to network sharing center "View you active networks" click on it to change it to PUBLIC NETWROK (I know but hey you wanna see if it works first huh? then you can secure it anytime..).
OK then click on "Change advance sharing settings" on the left menu "TURN ON PASSWORD PROTECTED SHARING" and use 128 bit encryption too.. SAVE

STEP 3:
Then Go to My computer Properties and NOTE or Change workgroup NAME (say WONDERLAND).

STEP 4:
Make a folder on Desktop, put some files in it. then right click on folder--properties---sharing---Advance sharing---CHECK sharing-- Apply--OK.

STEP 5: CLOSE this computer..

WIN XP:
STEP 1:
open windows explorer.. Tools---FOLDER options---VIEW---CHECK LAST ONE use simple file sharing---OK

STEP 2:
Make a folder on desktop put some files in it and right click Share...

STEP 3:
(Recommended)
Go to network connection in control panel---Run Networks setup wizard--Next--Next---- OTHER(if you are using router)---First one--NEXT--check name--workgroup name "WONDERLAND"
OR
My computer---properties---computer name-- change to "WONDERLAND"
Restart, START Win7 while xp restarting.

Win7 should be able to access XP and from XP it would ask for login info enter "geek", "123"

Report back...

Posted 4 years ago
Top
 
wonderland
Posts: 13

------------------------windwos xp machine-------------------------------------

C:\Documents and Settings\Gunta>net view
System error 6118 has occurred.

The list of servers for this workgroup is not currently available

C:\Documents and Settings\Gunta>net view \\RICARDSPC
Shared resources at \\RICARDSPC

Share name Type Used as Comment

------------------------------------------------------------------------------
D Disk
SharedDocs Disk
The command completed successfully.

C:\Documents and Settings\Gunta>

------------------------windwos 7 machine-------------------------------------

C:\Users\Uldis>net view
Server Name Remark

---------------------------------------------------------------------------
\\BLIND-STARE
\\RICARDSPC
The command completed successfully.

C:\Users\Uldis>net view \\BlIND-STARE
Shared resources at \\BlIND-STARE

Share name Type Used as Comment

---------------------------------------------------------------------------
D on BLIND_STARE Disk
Down Disk
My Music Disk
This Is Music Disk
Users Disk
The command completed successfully.

Posted 4 years ago
Top
 
wonderland
Posts: 13

hey ashi, now after restarting , I can't see windows xp pc on windows7 .. :(

Posted 4 years ago
Top
 
ashi
ashi
Posts: 33

do you see win7 in Xp?? and can you access it?

Posted 4 years ago
Top
 
wonderland
Posts: 13

No I don't see win7 in xp.. I restarted xp again and I can see it in windows 7 now but still can't access it though

Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Get Free Articles in Your Inbox!

Join 134,000 newsletter readers

Email:

Go check your email!