SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows XP

USB storage device recognized but does not appear in My Computer

(21 posts)
  • Started 6 years ago by jak
  • Latest reply from guntoter
  • Topic Viewed 61832 times

jak
Posts: 9

This has only recently become a problem on my pc. When I attach a mass storage device, ie.. a usb flash drive, a usb SD/MMC converter drive, or a camera.. I get the 'Safely Remove Hardware icon, the device appears as a mass storage device in device manager, appears and is accessable when I assign a drive letter in disk management, but does not appear in My Computer. I used to get a dialogue message asking if I wanted to open a folder or other options.

The only way I can access the mass storage device is by manually assigning a drive letter and opening the drive through disk management. Any advice or help would be greatly appreciated.

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

Can you access it if you type the drive letter (Like H:\) in the address bar of Windows Explorer and press enter?

Posted 6 years ago
Top
 
whs
whs
Posts: 17584

Check your Aotoplay applet. Press Start > type AUTOPLAY > click autoplay above > go to the bottom of the page and click "Reset all defaults". See whether that helps.

Posted 6 years ago
Top
 
jak
Posts: 9

I couldn't quite follow your directions. I'm not exactly sure where you want me to type autoplay once I press start. I did leave out that I'm running a Dell XPS Gen 4 w/ XP Media Center in my first post. I've never used another OS so I'm not sure if those directions were for Mac or Windows.

I was able to reset the autoplay defaults by clicking on properties of my cd drive. Still a NO-GO on accessing the usb device. If I go to disk management to see the usb mass storage device and click properties, there is no autoplay tab for that device or for the drive once I assign it a letter.

Thank you for responding.

Posted 6 years ago
Top
 
thegeek
The Geek
Posts: 2059

I think whs assumed you were using Vista, which works differently.

You might want to download TweakUI and see if you have any drive letters hidden from My Computer... that's the only good reason why the drive wouldn't show up in there but still be accessible.

Posted 6 years ago
Top
 
jak
Posts: 9

A through Z are checked in TweakUI for drives and autoplay. I can even see that the F drive has the storage device through tweak but it still isn't showing in My Computer.

Posted 6 years ago
Top
 
thegeek
The Geek
Posts: 2059

Do you have any add-ons installed for Explorer ?

Also, you should be able to enable/disable autoplay in TweakUI... make sure that it's enabled for that drive letter.

Posted 6 years ago
Top
 
jak
Posts: 9

I apologize jd. The post counter says 6 posts and I only see 3 of them... my origianl post along with the replies from whs and The Geek. I'm not sure why I can't see your post or my 2 replies.(Maybe The Geek can help me with this problem also...) I found your post by clicking on the 'RSS feed for this topic' link and reading through the code. Now... in response to your reply. :)

Even after I assign a drive letter I'm only able to find the drive in explore by scrolling towards the bottom of the page where I can see it with no drive letter. (Even though I know it has been assigned to F)

Posted 6 years ago
Top
 
thegeek
The Geek
Posts: 2059

@jak

What browser are you using to access the forum?

Posted 6 years ago
Top
 
jak
Posts: 9

I have a lengthy list when I go to Tools>Manage add-ons. I recognize all but one of them. Myway.com?? I also have one from Sonic to do with drive letter access. Is there a way to copy/paste that list here for you?

Posted 6 years ago
Top
 
jak
Posts: 9

IE 7...

Yes.. all drives were also checked in tweak.

Posted 6 years ago
Top
 
thegeek
The Geek
Posts: 2059

So you are using IE7 but can't see every other post?

Posted 6 years ago
Top
 
jak
Posts: 9

Sorry The Geek, It has been a long day and very little sleep this week. Things are a little slow upstairs tonight. I'm on my vista machine now and I see all of the posts. The other machine ( the problem machine is upgrading from IE6 to 7 now. I see all posts now. Thanks. As for the add-ons... you think that may be the problem? I'm going to disable all of the add-ons and try the SD card device.

Posted 6 years ago
Top
 
thegeek
The Geek
Posts: 2059

Disabling the add-ons is a good idea. You can also use ShellExView to take a look at shell extensions registered with the computer and disable them:

http://www.nirsoft.net/utils/shexview.html

- Thanks for noticing the IE6 problem... I have no clue why the posts aren't displaying. Doesn't make much sense, but I'll fix it.

Posted 6 years ago
Top
 
jak
Posts: 9

Disabling the add-ons didn't fix it. I restart the comp, plug the usb device in, hear the double beep, go to My Computer and see no drive, go to Disk Management... There I see the hard drive at Disk 0 Basic w/ C:as the drive letter and the storage device at Disk 1 Removable w/ no drive letter. I can not access the contents of the device unless I manually assign a drive letter.

So... the command that normally gives/ assigns the drive letter once it recognizes it as a storage device is the problem? The USB controller? OK. I have 4 Universal Host Controllers and one Enhanced Host Controller showing in device manager. I'm lost from here on. What do I do with these? Delete them and let the New Hardware wizard re-detect them? Will this even help?

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

Windows handles assigning drive letters.
Windows Explorer handles showing the drives with assigned letters.
The shellexview listed above is for disabling shell extensions that may prevent Windows Explorer from working right.
Windows should be assigning letters on the appearence of a removalable drive. It's strange that it's not.

Posted 6 years ago
Top
 
jak
Posts: 9

I didn't recognize anything new or out of the ordinary in the shellexview program. I think it is time to wipe the system and start from scratch. Now, thanks to Dell, I have to come up with a copy of Media Center seeing as they didn't send a system disk with this comp. Go figure. Thank you for your help.

jak

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

If they didn't send a disc then they probably included a recovery partition for formating the drive and reinstalling Windows.
You can usually access it by pressing a key on boot up like F12.
Note: You will lose all your data by using it.

Posted 6 years ago
Top
 
kk902
Posts: 1

I had a similar type problem, my SD/MMC converter drive, or a camera used to pop up in "My Computer" as a drive (G:) and then after I mapped a Network Drive and used letter (G:) suddenly next time I connected my SD/MMC converter drive, or a camera it did not pop up in "My Computer" at all, although there was a beep noise to indicate that the USB was connected.
Here is what I've done:
1. (Ensure that you have connected your USB device ),then Got To : "Control Panel" -> "Administrative Tools" -> "Computer Management"
2.On the left hand side of the "Computer Management Explorer" select "Disk Management" you should see your removable storage device in the list with the same letter as your mapped network drive.
3.Do right button on your removable drive and choose "Change Drive Letter or Paths..." and assign different letter.

That is all, go back to "My Computer" and the drive should be there. Next time you connect it, it will pop-up with a newly assigned letter.

Or maybe you can just map you network drive with a different letter :)

That's what worked for me I don't know if its the same case with you ...
Regards
Kirill

P.S Good Luck

Posted 6 years ago
Top
 
blackberrybrian
Posts: 1

KK902 Thats it exactly for me !! THANKS !!!!!!!!!!!

I think what caused this for me is a network drive set by my office at G. Windows I think likes to assign H and G etc for USB drives added on and it was taken and getting confused...(Non technical observation.)

The above fix from KK902 is fast and easy. Microsoft should have this in their damn knowledge base...

Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!