SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Geek Stuff

(Solved) - US government tells computer users to disable Java

(20 posts)
  • Started 1 year ago by amkeew
  • Latest reply from StringJunky
  • Topic Viewed 938 times

amkeew
Posts: 661

http://hosted2.ap.org/NMSAN/81.....6b41f6d26b

The U.S. Department of Homeland Security is advising people to temporarily disable the Java software on their computers to avoid potential hacking attacks.

The recommendation came in an advisory issued late Thursday, following up on concerns raised by computer security experts.

Experts believe hackers have found a flaw in Java's coding that creates an opening for criminal activity and other high-tech mischief.

What's up with this ? If I disable java, how can I log on to the forums?

Posted 1 year ago
Top
 
Lighthouse
Posts: 13598

This was advised a while ago here. You can still get onto forums with it disabled.

http://www.howtogeek.com/12293.....heres-how/

Posted 1 year ago
Top
 
amkeew
Posts: 661

Thanks LH for that link.

One question:

I use FF, where I wnet to Options/Content/JavaScript and disabled the JavsScript.

I found that HTG sign-in box is not seen and could not login.

So what do I do then?

Posted 1 year ago
Top
 
Scott
Posts: 5618

Java not to be confused with JavaScript

Posted 1 year ago
Top
 
amkeew
Posts: 661

Aha. Thanks Scott.

So.

1. I enable javascript in the browser

2. I disable or remove plugins like Java Development Tool, Java (TM) Platform SE 7 U9 etc.

Am I right?

Posted 1 year ago
Top
 
Lighthouse
Posts: 13598

I think so.

Posted 1 year ago
Top
 
Drizzle
Posts: 2045

@ amkeew
Yes I have enabled Javscript in FF your question 1

I was advised by MS support a while ago , when we were sorting out a problem with an update not being succesful .
to disable the two plugins you mention..
So yes to your question 2...

and have no problems :):)

Posted 1 year ago
Top
 
Lighthouse
Posts: 13598

Thanks Kate, cos I don't seem to have anything java related, on my system.

Posted 1 year ago
Top
 
vistamike
Posts: 10945

Since having this new machine I have never installed Java (did uninstall after setting up as well (win 7)).
Never had a problem without it.

Mike

Posted 1 year ago
Top
 
amkeew
Posts: 661

Thanks to you all. I have removed the java program via control panel, removed from java platform FF plugin and disabled the java deployment tool plugin (FF does not provide the remove option for this)

Now the million dollar question.

Which answer should I choose for the green mark ? :)

Posted 1 year ago
Top
 
vistamike
Posts: 10945

It has been marked as solved! No one answer selected.

Mike

Posted 1 year ago
Top
 
Lighthouse
Posts: 13598

That one :)

Posted 1 year ago
Top
 
amkeew
Posts: 661

Mike, LH - Such helpful peeps. :)

Thanks again everyone.

Posted 1 year ago
Top
 
Lighthouse
Posts: 13598

Our pleasure, from all the team :)

Posted 1 year ago
Top
 
Straspey
Posts: 556

Mozilla has taken the proactive step of disabling the Java plugin in Firefox:

Java Plugin 7 update 10 and lower (click-to-play), Windows has been blocked for your protection.

https://addons.mozilla.org/en-US/firefox/blocked/p182

Posted 1 year ago
Top
 
ispalten
Posts: 6259

Straspey, check the DATE on your link, old news...

However, if you go to the MENU BAR, ADD-ONS, and then PLUGINS you'll see it is disabled (I'm on FF 18).

Irv S.

Posted 1 year ago
Top
 
Straspey
Posts: 556

Irv -

I went out for the day shortly after my post above, and just wanted to reply anot have you think I was ignoring your helpful advice.

Thanks for pointing out the date that link - sorry I was not more attentive.

I actually discovered that link by checking my FF Plugins to see that they had already disabled it with the warning.

I'm assuming there will be a "FIX" for this very soon - no ?

Thanks again for your reply.

Posted 1 year ago
Top
 
StringJunky
Posts: 2454

If one must have the Java plugin in Firefox you can use this this easily accessible add-on QuickJava which defaults to the status bar at the bottom but you can easily move its buttons to the top by right clicking the Home button and choosing Customise > Click/Drag buttons To desired location. I've got the Flash and Java buttons showing red (off) and when I click them on they will turn blue. You can keep them off by default and enable them as required.

https://addons.mozilla.org/en-US/firefox/addon/quickjava/

In Chrome or Dragon you can enable the Click To Play function by going to Settings > Show Advanced Settings > Privacy > Content Settings > Plugins > Click To Play radio button on > Exit. You will see an icon in the address bar to click to enable plugins for a site. Just click the icon again to disallow it on that site after if required.

If you use internet Explorer you can't disable it therefore it's best to remove Java completely from your system and then use Chrome or Firefox with their specific Java plugin when you need Java.

Tony

Posted 1 year ago
Top
 
amkeew
Posts: 661

SJ, that's a cool FF add-on. Thanks.

Posted 1 year ago
Top
 
StringJunky
Posts: 2454

That's ok mate.:)

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.