SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Linux

Unity desktop

(5 posts)
  • Started 1 year ago by bruce6111
  • Latest reply from BobJam
  • Topic Viewed 986 times

bruce6111
Posts: 1

I'm new to Unity. When I install 12.04 on my PC the launcher does not appear, although I can start programs by moving my cursor all the way to the left of my screen and clicking away. Of course I can't see which icons I'm clicking on.

The menu bar also appears at the top of my screen but it shows no text unless I move the cursor over the bar, forcing me to search for the text.

I've installed 12.04 twice, and this has happened twice. How do I get the launcher and the contents of the menu bar to appear?

Any thoughts on what I'm doing wrong will be greatly appreciated.

Posted 1 year ago
Top
 
alvasrawuther
Posts: 37

@bruce6111 - That thing with the menu bar you said is actually a new 'feature' of Ubuntu rather than a shortcoming or fault. It's called the universal menu bar and it saves screen space. It'll only show the title unless you scroll over it and then it reveals the menu items.

Go to system settings>Appearance>Behaviour and make sure the settings are the same as the screenshots below and tell me if the problem persists.
http://i.imgur.com/g8xGf.png

And you can switch back to GNOME if you want to.
Just open the terminal and type in the following commands with the internet connected.
sudo -s - Type this command then enter your password. Then enter the following commands.
add-apt-repository ppa:gnome3-team/gnome3
apt-get update
apt-get upgrade
apt-get dist-upgrade
apt-get install gnome-shell
apt-get remove unity
exit

Then restart your PC to start using GNOME instead of Unity.

Posted 1 year ago
Top
 
nosparks
Posts: 148

Bruce6111, checking this out from a live bootable USB of Ubuntu 12.1, at the top left is an icon that has the label of "Dash Home" come up if your mouse is over it. Right click here and choose "Applications" and lots of things will show ( you may have to click show more ), then it is only one normal click to launch any of these.

Personally I prefer Linux Mint with the Mate desktop.

Posted 1 year ago
Top
 
BobJam
BobJam
Posts: 1052

@Bruce6111,

You can toggle between Unity and other DE's ("Desktop Environments") you have. So you can try another DE, and if you don't like it, you can always go back to Unity. (Of course, if you remove Unity, it won't show up as one of your DE options.)

When you log-in, there will be a small circular symbol next to the password field (above and on the right). Click it, and it will give you choices of DE. Here's what it may look like, depending of course on what DE's you've installed/are on your system:

I agree with nosparks, the Mate DE is much better than Unity.

First you have to install the Mate repository. I prefer to edit the sources.list file directly. You have to add lines to this file as root of course.

So, the command I use is "sudo gedit /etc/apt/sources.list" (WITHOUT the quotes.)

Add these lines to the bottom of the file:

deb http://packages.mate-desktop.org/repo/ubuntu precise main
deb-src http://packages.mate-desktop.org/repo/ubuntu precise main

Now update the list:

sudo apt-get update

Now you need to install the authentication:

sudo apt-get install mate-archive-keyring

Update again: sudo apt-get update

Check your Software Sources GUI . . . the repository and the authentication should be added.

Now install the Mate DE:

sudo apt-get install mate-core

sudo apt-get install mate-desktop-environment

Now, log out and log back in.

Log out again. This time, before you log back in, click on that circular little symbol by the password field. Mate should show up. Select it then enter your password . . . you will start up in the Mate environment. Customize as you wish, and remember this is basically Gnome2, so you will have the capability to customize much more than you did with Unity (which is Gnome3).

Sometimes the Mate DE is cranky and doesn't show up right away. Log in and out a few times. If it still doesn't show up at login (clicking that circular symbol), then you might have to run your Update Manager. Install all things Mate.

Now you can toggle back and forth between Mate and any other DE in the list.

To check for sure whether or not you're in Mate, there should be an "About Mate" selection in your system menu WHEN you boot into Mate:

Change gears . . .

There is some advantage to using the "Classic (No effects)" DE, because IT uses Metacity as your windows manager, while Unity defaults to Compiz, a windows manager that often causes video troubles, depending on your card/chips. I THINK Mate also uses Metacity.

(I use Mate in 12.04 and have had no troubles with a cranky video card. Plus Mate is pretty slick. It's much like the old GNOME2 desktop that a lot of users prefer. Much more customizable than Unity.)

For using the "Classic (No effects)" DE, see http://ubuntuforums.org/showthread.php?t=1966370 . This is a VERY informative thread. I highly recommend reading through it.

Posted 1 year ago
Top
 
BobJam
BobJam
Posts: 1052

Corrections: "sudo gedit . . . " should be "gksudo . . . ". Anytime you're invoking a GUI app with administrator privileges, use the "gk" addition to "sudo".

Clarification: alvasrawuther's image is what you should have to solve your problem. I am also curious if that is what you see.

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.