The How-To Geek Forums Have Migrated to Discourse


How-To Geek Forums / Linux

SuSE 10.2 Yast "rpm failed to install -- - ?"

(2 posts)
  • Started 8 years ago by embedded
  • Latest reply from supermansghost
  • Topic Viewed 3238 times

PARTNER SPOTLIGHT

Recommended: Clean Your Mac the Easy Way with CleanMyMac 3

If you want to clean up your Mac the easy way, CleanMyMac is a great tool to get the job done easily, and it will even keep your computer clean automatically.

Unlike the competition, it also includes great tools like a Clean Uninstaller, to get rid of applications and clean up the junk that they leave behind. All with the click of a button.

Download CleanMyMac 3 for Free Today

Posted yesterday 
Top
embedded
Posts: 3

If openSuSE 10.2 Yast has database problems it tells you. One can use rpm --cleandb however when the description is "-- ?-" and the package installer #"rpm --cleandb" does not work Yast has a really nasty issue. This is recorded in German in Bugzilla but there appears to be no "fix". (Comments say this is broken in 10.2 and likely to be broken in 10.3)

In addition smart package manager 0.51 fails with python errors when tried.

Likely a rather bad thing happened to Yast and something needs to be reinstalled from scratch. Has anyone experienced this and done something workable? (PIII 1Ghz 512MB 120GB HD Intel mother board. ATI Rage128 AGP no special drivers. Micron Clientpro)

Cheers John

Posted 8 years ago
Top
 
supermansghost
Posts: 350

I'm pretty sure there's a file in the yast directory that saves the list of available packages... you should be able to remove that file and reset it, but I don't have a Suse box to test on.

Otherwise I think you can uninstall it and reinstall with an RPM...

Posted 8 years ago
Top
 



Topic Closed

This topic has been closed to new replies.