SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows Vista

Summertime

(10 posts)
  • Started 1 year ago by SarahJames
  • Latest reply from SarahJames
  • Topic Viewed 473 times

SarahJames
SarahJames
Posts: 6581

Hi gals and guys :)

I have a weird problem bugging me and I hope you all can shed some light on it ;)
When daylight time settings change the time on the files in my D and G drive changes.
Now you may think that's not a big deal, but I synchronize these files to an external drive and the time on these files doesn't get changed.
Over the years I have acquired a lot of files - G drive alone contains more than 1TB.
So my synchronizing program goes besirk and wants to overwrite all those files, who are still exactly what they used to be, but when the time was for instance 8.05 it's now 9.05.

Beside that it is also annoying it happening on photo's who are set to the time they were taken and after several years it looks as if some were taken in the middle of the night instead of during the day. That just is plain weird.

So how do I stop this from happening?
It annoys me year after year and I still haven't found a solution :'(
Last year I went so far I disconnected my two internal harddrives, but this year I forgot.
There must be a way to stop this, since it doesn't happen to my external drive (who was also connected at the time).

Edit: and they don't revert back to their old time when wintertime sets in - at least then they don't change, but then the photo's would keep their original time :P

Posted 1 year ago
Top
 
Xhi
Xhi
Posts: 6298

How about just turning off automatic daylight time changing and set it manually.

Posted 1 year ago
Top
 
SarahJames
SarahJames
Posts: 6581

Will give that another try, but I've tried that before and there was a reason that didn't work either.

Edit: Oh darn, now everything is set TWO hours back. So when the time is supposed to be 0.00 it had gotten to 1.00 and after setting daylight saving times to manual I end up with the time on 23.00.
This is nuts!

Posted 1 year ago
Top
 
GuiltySpark
GuiltySpark
Posts: 4024

Is your external drive always hooked up to your machine ?

Posted 1 year ago
Top
 
StringJunky
StringJunky
Posts: 2454

Have you tried disabling it in the registry? Open Regedit and follow this path:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation > Right-click on DynamicDaylightTimeDisabled > Modify > Change to 1

Looking into it a bit, this time-stamp business is all by design so files adjust according to the time zone they are in when they are transferred internationally...the DST thing is all tied in with that.

Posted 1 year ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

Would setting your comp to a different time zone help ? I wonder.

Posted 1 year ago
Top
 
SarahJames
SarahJames
Posts: 6581

@ Tony - Checked the registry, but it is already set to disabled (did that this morning ;D).

And no matter what it was intended for - photo's that were taken during the day in 2004 now show they've been taken late at night (would be lovely if life could be that sunny LOL), so it's not working!

@ LH - I don't know, but I use the clock gadget and I'd prefer it to display my time ;)

Edit: I don't think disabling the daylight saving time automatic update will help, because I had to change the time manually after that and all the files got a different time again.
It only happens to files on internal drives, not on the external one and yes, it is hooked up permanently.

Posted 1 year ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

Aha. I have the answer :)
Keep all your files on external drives :)

Posted 1 year ago
Top
 
GuiltySpark
GuiltySpark
Posts: 4024

Not sure exactly on the solution but Lighthouse may be right.

Apparently it's to do with the conversion between DST and UTC (which is slightly different to GMT) : http://ask-leo.com/why_do_file.....hange.html

Posted 1 year ago
Top
 
SarahJames
SarahJames
Posts: 6581

That's my problem!
Only thing is all my drives are NTFS already and it is still happening :'(

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.

Get Free Articles in Your Inbox!

Join 134,000 newsletter readers

Email:

Go check your email!