SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows Vista

(Solved) - Sonic Cineplayer decoder pack

(10 posts)
  • Started 6 years ago by jjpatterson65
  • Latest reply from ndirish
  • Topic Viewed 44899 times

jjpatterson65
Posts: 5

I am running Vista Ultimate SP1 with Intel Q6600 processor , 2 gig ram, Nvidia GeForce 8800 GTS video.

I uninstalled Roxio Easy Media Creator 9.1 with the intent of switching to Nero 8 video software.
Now any time I try to open an MPG video file with Windows Media Player I get a dialog box with the statement:
“Please wait while windows configures Sonic Cineplayer decoder pack.
Gathering required information..."
Everything freezes for about 30 seconds. Then it displays an error message:
"Internal Error 2718 {8D337F77-BE7F-41A2-A7CB-D5A63FD7049B} OK "
The really bad part is that when I click “OK” the whole thing starts over again and displays the same error.
If I do this about 5 or 6 times the file will finally play normally.
This is a bad problem but I can't seem to get any help from Roxio. They have references to it on their forum but none of the suggestions they made seem to work.
I tried Roxio's suggestions for a clean install and removed Roxio and Sonic references from the system registry but it didn’t help. I would be willing to reinstall their program, but even though I have the boxed copy, I cannot get it to reinstall.
I am pretty sure this has to do with Windows Media Player trying to automatically load the required codecs to play the movie file but I don’t see any way to stop it.
I have installed Media Player Classic and it has the same problem.
I tried some of the uninstall utilities and registry repair utilities but they didn't help either.
Like I said, this is a bad problem and I really need some help.
Thank you, jjpatterson65

Posted 6 years ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

Have a look in Default Programs > Associate a file type or protocol with a program. And see what it's set to.

Posted 6 years ago
Top
 
ScottW
ScottW
Posts: 6609

jj, run this utility to find out what is the default DVD decoder under Windows Vista:
http://www.whittakermoore.com/VMCD.exe

This decoder will be used for playback of most MPEG files.

Posted 6 years ago
Top
 
jjpatterson65
Posts: 5

I ran VMCD.exe as administrator and got an error message:"Unhandled exception has occurred in your application..." It gave the option of continuing, which I did. Tried setting all available codecs as preferred but nothing changed. Still have the problem.

I was hoping someone out there would know of some registry edit that would fix this problem. I don't know of any other way to influence the operation of windows media player. I looked through all of the controls and did not see anything related to codecs.

I have run "Windows Event Viewer" and this displays as multiple warnings under "Administrative Events" with a source of MsiInstaller detecting product "{8D337F77-BE7F-41A2-A7CB-D5A63FD7049B}".

I have no idea what {8D337F77-BE7F-41A2-A7CB-D5A63FD7049B} is but it repeates several times every time an MPG file is opened.

Thanks again for any help, jjpatterson65

Posted 6 years ago
Top
 
ScottW
ScottW
Posts: 6609

That long string of numbers is a CLSID which is a unique identifier that Windows uses to identify certain objects. Based on what I find from googling on that CLSID, it looks like it's "Sonic Cineplayer Decoder Pack" or "Roxio Cineplayer Decoder Pack". Also, this is a MsiExec entry which stands for MicroSoft Installer. So it's either an installer or uninstaller entry. I'm thinking maybe a piece of that Roxio Easy Media Creator software is still on your system and WMP is getting stuck trying to access it.

Do you have any entries in Programs and Features to uninstall the Decoder Pack? Do you find the CLSID in your registry? Try a search in regedit and post back with the results.

Posted 6 years ago
Top
 
jjpatterson65
Posts: 5

The Regedit search did not find any reference to {8D337F77-BE7F-41A2-A7CB-D5A63FD7049B} and a harddrive file search likewize.
The event viewer I mentioned earlier had also listed:
"Sole Feature {DAA6C2EE-E666-4FAE-9799-F84BC3933DC0}" which I did the same searches for with no result.
There are no entries in Programs and Features listing Cineplayer, Roxio or any other suspects that could be removed to solve the problem.
I have gone to the trouble and expense of buying and installing Sonic's Cineplayer decoderpack for Vista, $14.99 in hopes that this would solve the problem. It installed without errors but has not made any change what so ever to my problem. Apparently there are differences between the original EMC9 version and the new Vista version. That CLSID did not show up.

Anyway, it looks like you were on the right track about MsiExec getting stuck trying to access the CLSID{8D337F77-BE7F-41A2-A7CB-D5A63FD7049B}. Now do you have any ideas about how to disable whatever it is that invokes the installer when opening MPG files. As I might have mentioned this problem is not unique to Windows Media Player, it occurs with several other players as well but not with players that have built-in decoders.
Again, thanks for your assistance, jjpatterson65

Posted 6 years ago
Top
 
ScottW
ScottW
Posts: 6609

For attacking the installer problem, try the Windows Installer CleanUp Utility:
http://support.microsoft.com/d.....bid=290301

To attack the video playback issues, use the K-Lite Codec Tweak Tool
http://www.free-codecs.com/Cod.....wnload.htm

Select the options, Detect broken codecs, Detect broken DirectShow filters and run it.

Posted 6 years ago
Top
 
jjpatterson65
Posts: 5

Scott,

What can I say, THANK YOU, I mean really. The K-Lite Codec Tweak Tool with the options you mentioned selected really did the trick.
It found about 20 registry entrys related to broken codecs and filters that I had it delete. Now all is well with all players. Event viewer is clear and even the VMC.exe works correctly.
Thank you so much,
jjpatterson65

Posted 6 years ago
Top
 
ScottW
ScottW
Posts: 6609

Jan: yippee! I love it when a fix works out for someone. You are very welcome and I'm glad to hear your problem is solved.

Posted 6 years ago
Top
 
ndirish
Posts: 1

Thank you ScottW. I used your link for the K-lite tweak tool and it worked. I have been trying for weeks to solve this problem and this did it.
THANK YOU VERY MUCH
Jerry

Posted 5 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!