SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

slow ping problem

(17 posts)
  • Started 4 years ago by chirantanf
  • Latest reply from chirantanf
  • Topic Viewed 18872 times

chirantanf
Posts: 32

hi again,
I am on qwest VDSL net, and here is the speedtest result at speedtest.net

as you can see my ping is very slow, 545ms, but at the same time my roommate is getting ping of 42ms, why is this happening? what is the solution? we both test at the same site, 1 after the other, and my ping is never below 500 while his ping is never above 50. oh by the way my HP laptop has windows 7 and atheros wifi adapter while his dell laptop has win XP and unknown wifi adapter.

Posted 4 years ago
Top
 
chirantanf
Posts: 32

by the way i did ping test with command prompt, and here is the result

but in browser the ping is still around 540ms, either in firefox or chrome.

Posted 4 years ago
Top
 
ispalten
ispalten
Posts: 6259

Your going to different servers with the webpage (have you tried pingtest) and the ping command. Even then, tracert would be a better choice, it would show the server with the lag.

++++++++++++++++++++++++
C:\Users\Irv>tracert www.google.com

Tracing route to www.l.google.com [74.125.45.106]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms LINKSYSWRT350N [192.168.1.1]
2 6 ms 5 ms 7 ms 10.212.64.1
3 7 ms 5 ms 6 ms gig7-0-0-11.orldflclmt-rtr1.cfl.rr.com [24.95.23
2.16]
4 7 ms 7 ms 9 ms 24.95.228.9
5 37 ms 10 ms 11 ms 77.228.95.24.cfl.res.rr.com [24.95.228.77]
6 19 ms 19 ms 19 ms ge-1-3-0.cr1.atl20.tbone.rr.com [66.109.6.104]
7 19 ms 19 ms 56 ms ae-1-0.pr0.atl20.tbone.rr.com [66.109.6.177]
8 20 ms 19 ms 19 ms 66.109.9.90
9 19 ms 21 ms 22 ms 64.233.174.2
10 20 ms 148 ms 20 ms 72.14.232.215
11 21 ms 30 ms 21 ms 209.85.253.133
12 19 ms 19 ms 20 ms yx-in-f106.1e100.net [74.125.45.106]

Trace complete.

C:\Users\Irv>ping www.google.com

Pinging www.l.google.com [74.125.159.105] with 32 bytes of data:
Reply from 74.125.159.105: bytes=32 time=21ms TTL=54
Reply from 74.125.159.105: bytes=32 time=20ms TTL=54
Reply from 74.125.159.105: bytes=32 time=21ms TTL=54
Reply from 74.125.159.105: bytes=32 time=20ms TTL=54

Ping statistics for 74.125.159.105:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 20ms, Maximum = 21ms, Average = 20ms

C:\Users\Irv>
++++++++++++++++++++++++

You might want to look at this THREAD on another forum. A few things to try, but I can't tell if any would work?

I ran the test too,
TEST RESULT/a>

Are both wireless adapters the same speed? Have you tried in the same location your roommate gets the readings?

Irv S.

Posted 4 years ago
Top
 
chirantanf
Posts: 32

C:\Users\Chirantan>tracert www.google.com

Tracing route to www.l.google.com [74.125.19.99]
over a maximum of 30 hops:

1 1 ms 1 ms <1 ms qwestmodem.domain [192.168.0.1]
2 21 ms 25 ms 21 ms phnx-dsl-gw44-236.phnx.qwest.net [67.40.227.236]

3 20 ms 20 ms 20 ms phnx-agw1.inet.qwest.net [75.160.237.89]
4 135 ms 32 ms 31 ms lap-brdr-03.inet.qwest.net [67.14.22.74]
5 31 ms 31 ms 31 ms 192.205.36.17
6 45 ms 44 ms 43 ms cr1.la2ca.ip.att.net [12.122.128.62]
7 43 ms 79 ms 44 ms cr1.sffca.ip.att.net [12.122.3.121]
8 64 ms 45 ms 44 ms 12.122.114.45
9 42 ms 42 ms 42 ms 12.88.147.10
10 43 ms 47 ms 42 ms 216.239.46.194
11 42 ms 50 ms 54 ms 209.85.251.94
12 42 ms 43 ms 42 ms nuq04s01-in-f99.1e100.net [74.125.19.99]

Trace complete.

C:\Users\Chirantan>ping www.google.com

Pinging www.l.google.com [74.125.19.99] with 32 bytes of data:
Reply from 74.125.19.99: bytes=32 time=43ms TTL=56
Reply from 74.125.19.99: bytes=32 time=42ms TTL=56
Reply from 74.125.19.99: bytes=32 time=42ms TTL=56
Reply from 74.125.19.99: bytes=32 time=43ms TTL=56

Ping statistics for 74.125.19.99:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 42ms, Maximum = 43ms, Average = 42ms

C:\Users\Chirantan>

thats my trace route result, i ll try and get the same thing from my room mate's laptop. and yeah we have been running the tests keeping both the laptops side by side. i guess both wireless adapters are of the same speed, no issue with that either.

Posted 4 years ago
Top
 
raphoenix
raphoenix
Posts: 14920

chirantanf,
---
Use [ pingpath ] for more info.
http://en.wikipedia.org/wiki/PathPing
---
Can take a while according to how you configure.
---
Regards,
Rick P.

Posted 4 years ago
Top
 
chirantanf
Posts: 32

i can definitely say that the slow ping problem is due to something with windows 7, as i am now running ubuntu from Live CD, widout installing it, and in ubuntu, on firefox, i get the ping as 45ms with speedtest at speedtest.net.

Posted 4 years ago
Top
 
raphoenix
raphoenix
Posts: 14920

Could be that Win7 is not configured properly and also, MS never advertised that Win7 was "blazing fast". (LOL)
Look at the number of networking questions we receive on the forum.
---
SP1 is due out soon.
---
Regards,
Rick P.

Posted 4 years ago
Top
 
ispalten
ispalten
Posts: 6259

Chirantanf, the link on a thread in another forum had some things to change, wait, I gave the WRONG link, THIS IS THE CORRECT ONE, look at all 5 pages before doing anything. It seems the registry change might do the trick.

By the way, my results are on W7 64 bit Home Prem. if that matters.

Irv S.

Posted 4 years ago
Top
 
chirantanf
Posts: 32

mine is win7 professional, but it didnt work for me!

Posted 4 years ago
Top
 
ispalten
ispalten
Posts: 6259

Then one has to suspect the wireless card drivers? Can you switch wireless cards?

Irv S.

Posted 4 years ago
Top
 
chirantanf
Posts: 32

i have found the problem, but for that it took reinstalling windows. the culprit is ESET smart security, as till i installed ESET smart security my newly installed win 7 pro was giving me pings of 40ms, which is decent. but the moment i installed ESET smart security i started getting pings of over 540ms, so i uninstalled it and tried again, and again i got pings of around 40ms.
so now i dont know what to do, whether to use ESET and lose on ping or use some different security solution. can anyone tell me how good is MS security essentials? and if it affects pings like ESET did

Posted 4 years ago
Top
 
StringJunky
StringJunky
Posts: 2454

Hi Chirantanf

MS Essentials is fine and light...I doubt it will affect the ping. There's only one way to find out.... :)

Tony

Posted 4 years ago
Top
 
chirantanf
Posts: 32

just installed MSE, and still my ping is fine, so plan on using MSE now, though would like to know what went wrong with ESET in 1st place.

Posted 4 years ago
Top
 
mickeyblue
mickeyblue
Posts: 1521

depends on what version of ESET you were using, some versions were not compatible with Win7, then a patched version came out, maybe its still not 100% compatible with Win7.

Posted 4 years ago
Top
 
chirantanf
Posts: 32

that could be the reasons, as for me ESET has always been a pretty reliable security suite, but then they themselves say that this version is compatible with win7, so it should work. hopefully in few months time, when i ll again give it a shot, it will have sorted the issue.

Posted 4 years ago
Top
 
mickeyblue
mickeyblue
Posts: 1521

stick with MSE i was also an ESET fan, but then changed to Win7 and at the time they did not have a compatible version, so i tried MSE out and have stayed ever since, wont go back.

Posted 4 years ago
Top
 
chirantanf
Posts: 32

ok. is MSE a security suite or just AV solution?

Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!