SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

PRINT SPOOLER WON'T STAY RUNNING

(18 posts)
  • Started 1 year ago by cat1974
  • Latest reply from cat1974
  • Topic Viewed 1394 times

cat1974
Posts: 8

My OS is Windows 7 on a laptop. I have a Canon MP560 printer (which is wireless). I have been able to use my printer through wireless until about 4 days ago and it stopped working. I get an error message that the print spooler has stopped running. I have searched and searched on the computer for fixes. I have uninstalled and reinstalled my printer. I have ran Spybot, degfrag, cleanup, virus scans, and registry cleaners. I still can't get my spooler to stay started. Can someone please help?

Posted 1 year ago
Top
 
GuiltySpark
GuiltySpark
Posts: 4024

Hi cat1974 ,

Welcome to HTG ,

Hold Winkey+R to bring up a Run box,

Type "services.msc" minus quotations,

Scroll down to find Print Spooler and check to make sure it is set to Automatic,

Right click the Print Spooler and select Properties,

Check to see the Dependencies are set to Automatic.

Posted 1 year ago
Top
 
vistamike
vistamike
Posts: 10945

Also, should it help;

Click Start.
Run CMD as administrator

At the prompt type; net stop spooler

press Enter.

type; del %systemroot%\System32\spool\printers\* /Q

press Enter.

type net start spooler

press Enter.

exit, reboot your machine

Mike

Posted 1 year ago
Top
 
cat1974
Posts: 8

I tried GuiltySpark and vistamike suggestions. As soon as I tried to print I got the message the spooler was not running again.

Posted 1 year ago
Top
 
Ruja
Posts: 230

Try using System Restore and select a restore point before you found these problems.

Posted 1 year ago
Top
 
cat1974
Posts: 8

I did a system restore and it still turns off.

Posted 1 year ago
Top
 
scorpion99
scorpion99
Posts: 1033

Can you post us a picture about your print spooler service status.
We would like to know if it is disabled or no , and in case you are getting a specific error when trying to start it, please post us a screenshot of the error.
Note that Print spooler depends on the following services: HTTP , Remote Procedure Call (which much be also set to automatic and started as GuiltySpark said)

Posted 1 year ago
Top
 
raphoenix
raphoenix
Posts: 14920

Is a common problem in Windows 7 but I can't tell you why.

Most of the time you catch the error in the Event Logs because the system will print OK Without the Spooler running.

Again I have never found out the WHY ??

Posted 1 year ago
Top
 
cat1974
Posts: 8

I hope this screenshot turns out right. I have never done one before. If not can you tell me how to post a screenshot.

print spooler service status

I do not get an error message when I try to restart the print spool. Only when trying to print.

Here is a screenshot of the other services. The Http is not showing up. It was there earlier today.

dependencies
rpc
dcom

Posted 1 year ago
Top
 
Xhi
Xhi
Posts: 6298

How to post a picture on H2G, but your method seems to work, too.

Posted 1 year ago
Top
 
ronniesonora
Posts: 919

You can try this, go to C -> Windows -> System32 -> Spool -> Printers and delete all files in side this folder, if any. This is the location printers spool documents before sending to printers. Once you delete these files, print queue will be cleared.

Posted 1 year ago
Top
 
GuiltySpark
GuiltySpark
Posts: 4024

cat1974 ,

Check your RPC (remote procedure call) not RPC Endpoint Manager they are different things.

Posted 1 year ago
Top
 
cat1974
Posts: 8

There were no files to delete.

Posted 1 year ago
Top
 
cat1974
Posts: 8

Here is a screenshot of the RPC (remote procedure call).

remote procedure call

I had a new issue today. When I attacked my laptop to the printer via USB it told me it installed drivers. I was able to print several different things via USB with no problems. As soon as I disconnected the USB I was not able to print. But unlike the past few days, the print spooler stayed started. I went into C -> Windows -> System32 -> Spool -> Printers and nothing was there.

Posted 1 year ago
Top
 
GuiltySpark
GuiltySpark
Posts: 4024

You could try setting RPC Locator to Auto, but I don't think this will do much.

Are you currently accessing the web via wi-fi ?

Posted 1 year ago
Top
 
vistamike
vistamike
Posts: 10945

Disable that procedure, apply click ok, reboot

Posted 1 year ago
Top
 
cat1974
Posts: 8

vistamike

Disable which procedure?

Posted 1 year ago
Top
 
cat1974
Posts: 8

GuiltySpark

Yes, I have a wireless router. Online connection is working fine.

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!