SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Linux

Overheat problem when using Linux

(9 posts)
  • Started 1 year ago by HaneenSu
  • Latest reply from Ruja
  • Topic Viewed 1419 times

HaneenSu
Posts: 4

Hi everyone,

I recently downloaded linux (mint distribution) on my Vaio laptop.

I am facing a problem whenever I use Linux.
My laptop turns crazy, its temperature increases dramatically and the fan doesn't stop, especially when I use the browser!! This is not the case when I use windows 7 on my laptop .. Any suggested solution?

Posted 1 year ago
Top
 
vistamike
vistamike
Posts: 10945

HaneenSu Hi

Having had the same problem with Ubuntu 12.10 yesterday (and Mint previously) I'd recommend; http://zorin-os.com/

Zorin seems to handle temperature control better than Mint and Ubuntu.

Mike

Posted 1 year ago
Top
 
Ruja
Posts: 230

Make sure you have installed the drivers for your graphics card. I suspect this works similarly in Ubuntu and in Mint, try searching for "Additional Drivers" in the menu, and see if you have proprietary drivers to install. Or you could go to the manufacturer's webpage (i.e. nvidia) and download the driver directly.

Posted 1 year ago
Top
 
vistamike
vistamike
Posts: 10945

What is the model of your Vaio? We need to see the video spec and find a linux driver if there is one.
I do know from experience that Sony drivers in linux are difficult to source or install.

Mike

Posted 1 year ago
Top
 
HaneenSu
Posts: 4

Thank you for your responses.
My laptop's model is VPCSB .. it is an "S" series laptop

Posted 1 year ago
Top
 
HaneenSu
Posts: 4

So what do you think? Is there a linux driver for it? sorry but I am not that expert!

Posted 1 year ago
Top
 
Ruja
Posts: 230

Did you do what I said? Look for the "Additional Drivers" and see what you have there:

If you have several NVIDIA drivers like in this picture, you only need to install one of them, so get the recommended one.

From Linux Mint 14 Nadia release info:

"To install additional drivers, please run the "Software Sources" tool from "Menu->Preferences->Software Sources" and click on the "Additional Drivers" tab. "

Posted 1 year ago
Top
 
HaneenSu
Posts: 4

Thank you for the detailed steps.

Well here is what I got :S
Seems there is something wrong

http://tinypic.com/r/35inpdu/6

Posted 1 year ago
Top
 
Ruja
Posts: 230

Ok probably that screen got updated but it is the same information, thanks for the screenshot. You are currently using the open-source driver, which in my case (I use nVidia) does not have 3D acceleration, and has relatively poor performance. That may be your problem. Try changing to one of the proprietary ones, the last one, listed as "fglrx-updates". You will have to restart after the change.

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.