SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows Vista

(Solved) - NVIDIA Corporation driver update for NVIDIA nForce Serial ATA Controller

(9 posts)
  • Started 6 years ago by jkois
  • Latest reply from jkois
  • Topic Viewed 20720 times

jkois
Posts: 38

whenever i install this driver update, the "safely remove hardware" icon appears in the quick launch. if i click it i get the window which shows my hard drive and 2 dvd drives as external hardware.

does any one know a fix? or should i just not install this "optional" driver update?

Thanks,

of course the update does not show up in "installed updates" so how do i remove it now? do i have to restore?

Posted 6 years ago
Top
 
whs
whs
Posts: 17584

These things usually come as drivers (programs) not updates. That's why you don't see it in the Updates list. If you go to COMPUTER and first left then right click on the device, you can still "safely remove". The little icon is not that handy anyhow because it only tells you the USB adress and you have to know where your device sits.

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

I have that entry displayed in Windows Update too.
I had installed it and then uninstalled it for another reason.
That reason probably doesn't apply now. I'll try installing the update and see if I have the same issue.
If so I'll see if it can be fixed somehow.

Edit: Yep I got the problem from that update.
My "Safely Remove Hardware" icon shows:
"Safely remove SAMSUNG HD501LJ SCSI Disk Device - Drives(C:, H:)"
"Safely remove TSSTcorp CD/DVDW SH-S183L SCSI CdRom Device - Drive(O:)"
Both are internal drives and the hard drive can't be removed even if I click on it as Windows is running from it.
I'll check the settings in Device Manager and see if it can fixed.

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

I just searched on the NVIDIA community site and figured out why it's displayed.
The reason why the internal drives show up with the driver update is because SATA drives support hot swap.
Hot Swap is a feature lets you remove the drive from the inside of the computer and put another drive inside the computer while the computer is running.
In this case the hard drive entry is useless. You can't remove it while Windows is running and Windows won't let you do so anyway.
It could be useful to hot swap the CDRom drive if it failed and you didn't want to shutdown first.
There is a registry key you can set to stop the "Safely Remove Hardware" icon from appearing but it would also remove the ability to swap eSATA (External SATA) drive so you might not want to do so if you have an eSATA drive.

The thread with the information and link to registry key info is http://forums.nvidia.com/index.php?showtopic=39427

Posted 6 years ago
Top
 
jkois
Posts: 38

ok great. i will try that. but before i do, this will not affect any other external devices i may plug in, such as my blackberry of media player. the icon will still appear for those right?

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

Yes it will still appear for other devices. It will just disappear for internal and external SATA drives.
You may need to reboot for the registry key to take effect.
I haven't rebooted to test so I don't know for sure if the key works.

Direct link to topic on registry key: http://forum.msi.com.tw/index.php?topic=99884.0
I think you may want to try adding it to the nvstor32 key if adding it to nvstor doesn't work.

Edit: I just tried adding that key and rebooting. It didn't remove the entries for me. You can still try it and see if works.

Posted 6 years ago
Top
 
jkois
Posts: 38

I really don't think i have the savvy to mess with the registry. i would rather just remove the update and hide it in windows update. can you run that process down for me? thanks. er i mean the driver not the update!!!

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

You can try rolling back the driver this way:
1. Click Start.
2. Right click on Computer and click Manage.
3. Click Continue on the UAC prompt.
4. Click Device Manager on the left.
5. Double click on "IDE ATA/ATAPI controllers".
6. Double click on "NVIDIA nForce Serial ATA Controller".
Note: There may be more then one entry. In this case just double click the first one.
7. Click driver at the top.
8. Click Rollback Driver.
9. Click Yes to rollback the driver.
10. Click Yes to restart the computer.

If you get it in Windows Update again you can just right click on it and click "Hide Update".
If you ever want it again you can go to "Restore Hidden Updates" to show it again.

Accepted Answer · Posted 6 years ago
Top
 
jkois
Posts: 38

excellant. i will give it a go when i get home tonite. thanks again.

Posted 6 years ago
Top
 



Topic Closed

This topic has been closed to new replies.