SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Geek Stuff

(Solved) ~ Network - Computer Recognition

(10 posts)
  • Started 6 years ago by jmcguire
  • Latest reply from jmcguire
  • Topic Viewed 1550 times

jmcguire
Posts: 552

I have a very small home network setup.

I have a gateway router that has a computer connected directly to it. Also connected to the device is a wired router (this is in another room of the house).

Connected to the second router is a second computer. I need the second computer and the first computer to be able to see one another across the network.

The reason I have it set up this way, is I needed internet is the second room, and instead of running multiple 65 foot (approx 20 meters) cords, I ran one, and used a router to connect all the devices in the second room.

Can anyone help with this?

Gateway router - Westel 327w
Second router - Linksys NR041

Posted 6 years ago
Top
 
whs
Posts: 17584

For starters you have to setup the Firewalls so that they allow access. This is the procedure in case you have Norton IS:

1.Determine your computer's Internet address (IP):
Press WIN+R
In the Run dialog box, type COMMAND, then press OK
At the command prompt, type the following and press Enter after each one:
cd\
ipconfig
The IP Configuration information is displayed in the DOS box.
Write down the IP address for each computer on your home network.
2. Add the Internet address (IP) to Firewall Trusted list:
Start Norton Internet Security.
In the main pane, click Norton Internet Security tab.
Click Settings.
Under Web Browsing, click Personal Firewall and then click Configure.
In the left pane, click Trust Control.
In the right hand side, click the Trusted tab. Click Add.
In the Enter Trusted Computer dialog box, type the IP address of each computer on your network into the box (but not the one on which you are on), and then click OK.
Note: For multiple IP addresses, separate each one with a space.
The IP address(es) that you entered appear on the Trusted tab.

Posted 6 years ago
Top
 
MetrotekGeek
Posts: 16

You probably need to disable DHCP on the 2nd router.

Posted 6 years ago
Top
 
jmcguire
Posts: 552

Well I disabled DHCP on the 2nd router. I will let everyone know tomorrow if this worked.

I have to fix the first computer (Windows Logon Interface corrupted and it keeps restarting after the Windows Boot Screen) and I needed the recognition to transfer the 1st computer's files back to it. ( I am going to have to put it's hard drive in the 2nd computer to get the file off)

As a side note, if anyone knows an easier way to fix this other than simply re-installing Windows, it would be greatly appreciated.

Posted 6 years ago
Top
 
ScottW
Posts: 6609

jmcguire, I'm addressing the first question about the network setup. Coming in from the Internet, you have your 1st router acting as a gateway. That's how most routers are used. Connected to this gateway router is PC #1 and (via a long cable) router #2. You want this 2nd router to act as a hub or switch and NOT as a gateway. You want it to pass packets along, and not do address translation or create a subnet. Ideally, there would be a setting in the config menus that you could set to make it act as a hub or a switch. My Linksys has a setting in Setup -> Advanced Routing -> Operating Mode, that can be either Gateway or Router. See if your has a similar setting.

Also, you can probably learn something about how routers work and can be cascaded together from this web page by Steve Gibson:
http://www.grc.com/nat/nat.htm

EDIT: can't make an ASCII drawing here <sigh>

Posted 6 years ago
Top
 
jmcguire
Posts: 552

@ScottW

That does sound like what I am trying to achieve. I was messing around with the router, and yes it does have an option to switch between Gateway and Router, I changed it to Router, but the next day when I tried to use the computer, I noticed it has dropped the connection and I couldn't access the router, so I reset the router. The same thing happened when I disabled DHCP earlier last week, only almost immediately. (It seems to always drop the connection when I turn DHCP off.)

I installed uTorrent today to get the DVD install of Ubuntu and was messing with Port Forwarding. I changed my router's address to 192.168.1.2 from 192.168.1.1, but then changed it back. The address of the gateway is also 192.168.1.1.

What would be the best steps to take to achieve my desired result?
Would I still be able to access the router's settings?
Is there a way to access the gateway's settings from a computer connected to the router?

*EDIT*
I have uploaded screenshots of every screen in my router preferences to a photobucket account.
Network Anywhere NR041

The router also has a button to toggle between Normal and Uplink mode.

Posted 6 years ago
Top
 
raphoenix
Posts: 14920

jmcguire,
EDIT: Don't understand what you are attempting to accomplish with so few computers.
I'll give SAME Answer and Link as ScottW.
http://www.grc.com/nat/nats.htm
Kindest Regards,
Rick P. ♥ :)

Posted 6 years ago
Top
 
jmcguire
Posts: 552

What I am trying to accomplish is to allow the devices (mainly the computer) connected to the second router to see the computer (and any other device I connect later) to the first gateway. Currently the second router has its own network and cannot see what is outside it. The second router is obtaining the internet connection from the gateway. The second router has gaming devices connected as well, but that is less important if they can see the devices connected to the first gateway.

*UPDATE*
I was able to get the computers to see each other. My problem now is when the second computer tries to access the first, it says:
"[The computer name] is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The network path was not found."

I think it may have to do with file sharing issues, so I will check into that.

For those of you interested, the way I was able to get the computers to see each other was, on the second router:
Turn of DHCP
Change to Router mode
Change IP address to be different from first router
Change Ethernet cable from gateway to plug into LAN port instead of WAN port
Restart computer and router

Changing the cable to be plugged into a LAN port was what took me forever to figure out. Thanks for everyone's help. Hopefully I just need to check the file sharing options on the first computer to get this to work!

*UPDATE*
Well I have the file sharing fixed and everything seems to be working fine.

Posted 6 years ago
Top
 
ScottW
Posts: 6609

Jmcguire, good job! I have never actually done this before, so I don't know all of the required settings for making the second router into a hub. I have a 4-port hub in my living room that is wired to my gateway router here in the computer room. There was no setup, though, it just works.

I would be interested to know what private IP address is assigned to the PC or other devices behind the 2nd router. The devices that I have behind my living room hub are all 192.168.1.x, so they are all on the same subnet as the rest of my network.

Posted 6 years ago
Top
 
jmcguire
Posts: 552

Thanks @ScottW

I just checked with and my IP Address is 192.168.1.x.
The gateway IP Address is 192.168.1.1 and the router is 192.168.1.2.

Posted 6 years ago
Top
 



Topic Closed

This topic has been closed to new replies.