SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Geek Stuff

My Computer Problem

(5 posts)
  • Started 6 years ago by Goblin40
  • Latest reply from Goblin40
  • Topic Viewed 1049 times

Goblin40
Posts: 4

Yay a non vista related problem (just kidding, I actually love Vista very much)

Okay so I'll get started.

I got an m2n-SLI board with an AMD 5000+ and 2gb of gskill DDR2800 ram.

Here are some links:

http://www.newegg.com/Product/.....6813131013

http://www.newegg.com/Product/.....6819103194

http://www.newegg.com/Product/.....6820231098

I know that the motherboard works because the light is green and all the fans are on, etc. I don't think the computer would even turn on if the processor had been shorted or something...

One thing that I could think of is that I need a new heatsink. I just ordered one but is this enough for my monitor to not turn on? My case is lying sideways because my heatsink can't stay on my processor when it is upright. Sounds weird, I know but I think the person who built the computer for me forgot to include some of the supplies I needed for the heatsink on a AM2 mobo, because I upgraded from a 939.

So everything seems to work except there is a red light on my front panel and my monitor doesn't turn on. The fans work, my graphics card fan, etc and the mobo light turns on.

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

Usually if everything is plugged in and working you will at least see the BIOS screen on the monitor.
Even if the processor was overheating it should display the BIOS screen for a little bit of time on the monitor.
Are you sure the monitor is working right?

Posted 6 years ago
Top
 
Goblin40
Posts: 4

Well, I got it to work on this computer once already. But I must have done something to upset that. The only thing I can think of is that my case isn't closed and it isn't sitting upright, which sometimes can have a weird affect on the video.

So anyway, that does help me out a lot though, because I don't want to RMA anything and it sounds like my stuff is working, just my monitor won't turn on.

I ordered a new heatsink from Newegg, we'll just have to see then.

Posted 6 years ago
Top
 
ThornyCrown
Posts: 17

Any luck with this yet mate?
Have you played with the BIOS at all? Try resetting the BIOS just for the hell of it.
It wont matter how your PC is sitting, that wont stop your computer from running. Check to make sure the video card is firmly seated in the slot.

Thorn

Posted 6 years ago
Top
 
Goblin40
Posts: 4

I've tried everything I can think of. I've tried two different power supplies, two different video cards and a lot of other things like reading the manual a million times. haha but yeah I took it into a shop for a diagnostic, it just might be a DOA motherboard.

Posted 6 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!