SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows Vista

My computer goes to sleep in 30 minutes

(8 posts)
  • Started 4 years ago by rojoyo
  • Latest reply from ScottW
  • Topic Viewed 8952 times

rojoyo
Posts: 6

Hi my computer goes to sleep in 30 minutes, I changed the power settings to never go to sleep and that worked till I rebooted the computer, after I rebooted the computer it was back to going to sleep in 30 minutes, I tried to make a custom power plan and set it to not go to sleep and it was also not there after i rebooted, every thing is OK till I restart the computer, so for some reason the power settings are not saved after I reboot, and yes I saved the changes. I think it is not updating the registry for some reason. thanks for any help.

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

rojoyo, hello. Which Power Plan are you using? When you go to the Advanced Power Settings, what settings do you see under "Sleep"? Here is what I see:

Are these the settings that you are changing?

Posted 4 years ago
Top
 
rojoyo
Posts: 6

I'm using High performance but I'v tried them all and they all revert back to default after I reboot. here is a picture of what I see under advanced Power Settings and yes these are the settings that I am changing

Edit: I also tried to make a new custom power plan and everything was OK, when I rebooted it was gone.
I'v tried to change other power settings and they all revert back to default when I reboot.

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

Well, one thing that's really odd is that the High Performance plan should be set to never sleep. Let's try some strong medicine. From an elevated Command Prompt (run as administrator), run the following command:

powercfg -RestoreDefaultSchemes

Hopefully, this will reset all schemes to their original defaults which should mean never sleep for High Performance. It might wipe out your custom power plans, if there are any. Maybe it will even fix it so you can modify the plans as you wish.

Posted 4 years ago
Top
 
rojoyo
Posts: 6

Well I tried the command that you said from an elevated command prompt and it is still set to 30 minutes and it still reverts back when I change it and reboot, so that didn't work any other thoughts?
anyway I got to go to bed now just so you know

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

The registry entries are under the key HKLM\system\currentcontrolset\control\power\powersettings. You can see the discussion we had about this in a previous thread:
http://www.howtogeek.com/forum.....ta-desktop

Posted 4 years ago
Top
 
rojoyo
Posts: 6

well i just took a look at the registry and there is 15 entries like you said in the other thread
and I think I found the one the controls when the computer goes to sleep and it is set to "0" or never when it is on CA power as you can see in the second picture, so it think the registry is OK, but it seems like it is not loading these values for some reason is there some program that has to start up on startup or that has to run to use these values,

Posted 4 years ago
Top
 
ScottW
ScottW
Posts: 6609

I would think that Power Management would be handled by a service, but I can't find one. I have read that Group Policy options can override power options, but it should say that in the Control Panel. So, I don't know what's going on here.

Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.