SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Linux

mousepointer problems in Ubuntu

(10 posts)
  • Started 2 years ago by lonk
  • Latest reply from BobJam
  • Topic Viewed 909 times

lonk
lonk
Posts: 9

Hi all. This is my first post here. However, I am coming here daily for years.
I use a desktop with multiboot (Ubuntu and Win7).
Also, very important, I am a diabetic. Therefor, my eyesight is not always 100% and there lies my problem.
(hope I don't make to much spellings mistakes, am not a native English speaker)
My problem is that I can not change the default size of my mouse pointer in Ubuntu.
It used to be simple, but not since the last few new versions, as of Unity I believe.
There is the way described somewhere with dconfig but it doesn't work.
Also there is no way to change what kind of pointer you want to use.
I hope someone is able to tell how, and perhaps a more permanent article on the site itself, perhaps categories for people with disabilities in general?

Posted 2 years ago
Top
 
whs
whs
Posts: 17584

I was trying that for years and was not able to change the size. There is no option in the settings. My eyesight is 45% and I can appreciate your problem.

But maybe someone figured it out. So wait for further input.

Posted 2 years ago
Top
 
lonk
lonk
Posts: 9

Thank you whs for your support, perhaps if many people have the same problems it will get picked up by the developers themselves. (I think they come here and also many of the lifehacker community come here also. I am sure the dev's come there to! ) ;)

Posted 2 years ago
Top
 
BobJam
BobJam
Posts: 1052

If the Unity DE is your problem, you can install the Mate DE, and that's a fork of GNOME 2. I have it on my 12.04 version, and it's pretty much like the old GNOME 2.

Also, you might try gnomelook.org and see if any mouse themes suit your needs.

I'm diabetic also, and while I don't use the Assistive Technologies, I DO like a large pointer. There is one on gnomelook.org called "WhiteStyle", it's very large, has a lot of good features (like it rotates to indicate either a link or a download in progress), and it works nicely on 12.04/Mate.

Posted 2 years ago
Top
 
lonk
lonk
Posts: 9

Hi BobJam, thank you! I am not sure what the DE stands for. Actually, I am starting to get used to the whole Unity thing, a simple way of getting my pointer the way I like it should be easy, but it is not! If there is no alternative for making the pointer stand out more I certainly will look again at your solution!
I just find it very odd there is no build in way to do this. I know, they are all working for tablets and touchscreen now, but believe me, besides my awesome phone, I don't want nothing to do with pads... (like them, but they lack everything I like about a PC)

Posted 2 years ago
Top
 
whs
whs
Posts: 17584

I am glad BobJam came to our rescue. He is a real Linux geek. I remember the time when he left the boring world of Windows - LOL.

Posted 2 years ago
Top
 
BobJam
BobJam
Posts: 1052

@lonk,

DE = Desktop Environment

You can toggle between Unity and other DE's you have. So you can try another DE, and if you don't like it, you can always go back to Unity,

When you log-in, there will be a small circular symbol next to the password field (above and on the right). Click it, and it will give you choices of DE. Here's what it looks like:

But of course, first you have to install the Mate DE. (I'm assuming you use 12.04 . . . these instructions are for 12.04)

First you have to install the Mate repository. I prefer to edit the sources.list file directly. You have to add lines to this file as root of course.

So, the command I use is "sudo gedit /etc/apt/sources.list" (WITHOUT the quotes.)

Add these lines to the bottom of the file:

deb http://packages.mate-desktop.org/repo/ubuntu precise main
deb-src http://packages.mate-desktop.org/repo/ubuntu precise main

Now update the list:

sudo apt-get update

Now you need to install the authentication:

sudo apt-get install mate-archive-keyring

Update again: sudo apt-get update

Check your Software Sources GUI . . . the repository and the authentication should be added.

Now install the Mate DE:

sudo apt-get install mate-core

sudo apt-get install mate-desktop-environment

Now, log out and log back in.

Log out again. This time, before you log back in, click on that circular little symbol by the password field. Mate should show up. Select it then enter your password . . . you will start up in the Mate environment. Customize as you wish, and remember this is basically Gnome2, so you will have the capability to customize much more than you did with Unity (which is Gnome3).

Sometimes the Mate DE is cranky and doesn't show up right away. Log in and out a few times. If it still doesn't show up at login (clicking that circular symbol), then you might have to run your Update Manager. Install all things Mate.

Now you can toggle back and forth between Mate and any other DE in the list.

To check for sure whether or not you're in Mate, there should be an "About Mate" selection in your system menu:

Change gears . . .

That WhiteStyle pointer:

is at: http://gnome-look.org/content/.....9d110c8870

@ whs,

Your comment about me using Windows long ago is appropriate: Could you help me out here ? The gal is going to be using the Windows7 Recovery Console and I'm really not familiar with it. TIA.

BJ

Posted 2 years ago
Top
 
lonk
lonk
Posts: 9

Thank you BobJam, I think I will try this. Will let you know if I can get it to work! ;)

Posted 2 years ago
Top
 
lonk
lonk
Posts: 9

After a few hiccups I managed to install the Mate DE. However, even while I get it to work my video card seems to disagree with this DE. I see everything, except it looks like for example my screenlets are just not there while they are there. (Half visible fonts) So this is regrettably no solution as of yet. It looks like I am forced to stay with Unity, now just a way to get that pointer bigger... lol

Posted 2 years ago
Top
 
BobJam
BobJam
Posts: 1052

@lonk,

Video card compatibility has been a perpetual problem with all flavors of Ubuntu and DE's. Though Mate does disable compiz (video effects) and uses metacity only. Unity uses compiz by default.

Have you tried the "Gnome Classic (No effects)" DE? See this.

Posted 2 years ago
Top
 



Topic Closed

This topic has been closed to new replies.