The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Linux

mount an smbfs in ubuntu

(4 posts)
  • Started 8 years ago by azizlp
  • Latest reply from azizlp
  • Topic Viewed 17416 times


Recommended: Clean Your PC the Easy Way with CleanMyPC

If you want to clean up your PC the easy way, CleanMyPC is a great tool to get the job done easily, and it will even keep your computer clean automatically.

Unlike the competition, it also includes great tools like a Clean Uninstaller, to get rid of applications and clean up the junk that they leave behind. All with the click of a button.

Download CleanMyPC for Free Today

Posted yesterday 
Posts: 12

I have trouble mounting my xp local disks via my network in ubuntu.
I'm able to do the same thing in Suse 10.3 and in fedora
this is the command i use to mount my drive C from my xp box in Suse and Fedora

mount -o username=Administrator //$ /mnt

i'm then prompted to enter a password and the drive gets mounted.
Surprisingly it doesnt work in ubuntu.

I need help please.

Posted 8 years ago
Posts: 3814

It appears smbfs mount support isn't installed by default in Ubuntu.
I would guess it's not installed in favor of using a CIFS mount instead.
You can try CIFS by using mount -t cifs instead just mount.
That would make your command: mount -t cifs -o username=Administrator //$ /mnt

If that doesn't work you can install smbfs mount support with the following command: apt-get install smbfs smbclient

Note: Some commands from

Posted 8 years ago
Posts: 12


i tried the first options but it didnt work but i insttalled smbfs n it worked with -t cifs options
Thanx for the help

Posted 8 years ago
Posts: 12

it looks like both options are working perfectly

Thanx again

Posted 8 years ago

Topic Closed

This topic has been closed to new replies.