SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

missing sqmapi.dll while trying to install SP1

(4 posts)
  • Started 3 years ago by germ-x
  • Latest reply from germ-x
  • Topic Viewed 4053 times

germ-x
Posts: 5310

This one has me puzzeled. On an Asus laptop with windows7/64 bit home premium system I keep getting "missing sqmapi.dll error when I attempt to install windows SP1. This happens when I go directly through windows updates or download SP1 from MS. I have done a local search for this file and it is located throughout "C" drive at least 15 times in various folders. The dates and sizes vary, but most are from the OEM startup. I have changed the one in "C:\programs\internet explorer" a couple of times since that one seems to be the one with the most recent date with the same result. I've shut down my AV and rebooted but no help. When I search the net, there are plenty of places that want to fix .dll's but it is not broken just lost and I don't want to start downloading and installing those junk utilities. I have restore points and backup images but if I choose one will it be the correct one as I will lose installed programs as I go back in time. Any ideas?

thanks,
g-x

Posted 3 years ago
Top
 
germ-x
Posts: 5310

bump

Posted 3 years ago
Top
 
skipper86
Posts: 32

Download sqmapi.dll file from the internet and place it in C:\Windows\System32 folder and then try to install SP1

Posted 3 years ago
Top
 
germ-x
Posts: 5310

Thanks, I copied the file into my system32 folder rebooted but still no go.
Windows installed about 20 updates last night and again tried SP1 but failed with the missing sqmapi.dll file"
I really don't like the thought of running the running the factory default setup as everyone knows the reinstall of everything, plus no guarantee SP1 will load.

Posted 3 years ago
Top
 



Topic Closed

This topic has been closed to new replies.