SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

Lost Desktop Icons in Windows 7

(9 posts)
  • Started 4 years ago by gordy
  • Latest reply from gordy
  • Topic Viewed 2178 times

gordy
gordy
Posts: 135

Created shortcuts on desktop from websites. During installation/restart of new applications, many turned into round 'earth' icons with correct label & action, as if I lost the favicons. How do I get them back to correct icon?

Posted 4 years ago
Top
 
raphoenix
raphoenix
Posts: 14920

gordy,
---
This happens I think? when a cache is cleaned up.
---
If you use something like CCleaner or other clean-up programs on startup, they will revert back to standard browser icons on a re-boot or boot-up.
---
At least mine do so am assuming others may clean-up [ ALL ] cashes on boot-ups also.
---
Regards,
Rick P.

Posted 4 years ago
Top
 
gordy
gordy
Posts: 135

I'm using nothing but IE8's & Win7 cleanup utilities. I believe I saw this happen after I installed Adobe Reader, of all things. The desktop blinked, and the globes were there. I am willing to start over (clean install), but this is the second time this has happened in 2 such clean installs!

Posted 4 years ago
Top
 
LH
LH
Posts: 20002

Try this,
Navigate to,
C:\Users\yourusername\AppData\Local\IconCache.db
and delete the IconCache.db file
Then Restart computer.

Posted 4 years ago
Top
 
gordy
gordy
Posts: 135

I tried finding that file, and it seems that this was hidden to me before, in attempting a solution. I have my folder options set to show hidden files & folders, but it does not show it's face in my User Name folder. What now?

Posted 4 years ago
Top
 
raphoenix
raphoenix
Posts: 14920

gordy,
---
I run as Built-in Administrator most of the time but have another account on the machine also.
The cashes are here.
----
"C:\Users\Administrator\AppData\Local\IconCache.db"
"C:\Users\Rick\AppData\Local\IconCache.db"
---
Enable Hidden File Setting in Control Panel -> Folder Options.
---
Regards,
Rick P.

Posted 4 years ago
Top
 
Mongo1961
Mongo1961
Posts: 1

This also happing to me. For me it's in the task bar and start menu. Any ideas??

Posted 4 years ago
Top
 
LH
LH
Posts: 20002

Mongo1961 welcome. Please post your problem in a New Topic.

Posted 4 years ago
Top
 
gordy
gordy
Posts: 135

Ah, I finally got the hidden files to show. Deleting the .db cache did not solve the problem, however. The globes remain. 'Favicons' will stay in IE8's favorites folder as they always have. However, I am thinking Microsoft removed the "Favicon on desktop" style that XP had, due to having to not being able to automatically have IE as default browser in Win 7. Nobody at Microsoft Tech Support can help, only advise that 'you can't count on it because "they listened to user feedback!"' Sorry, I don't understand, unless the free source advocates have won some kind of concession from MS.
Notice: on a clean install of Win 7, that IE8 is NOT on the desktop! You have to drag & drop it from the start menu to the desktop to get it out there. Even so, it's just one of the list in Startup Menu, and one has to "Pin" it to have it show at the top of the menu. There's been some code changes, folks, and I'm not happy. I'll bet using another browser as 'default browser' won't let you save shortcuts to the desktop as Windows indicates it will, with the 'favicon's' present.

Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.