I use the synaptic, and search cinnamon, when I choose it to install, It says Could not mark all package for installation or upgrade, the following package have unresolvable dependencies:

cinnamon:
Depends: gir1.2-clutter-1.0 but it is not going to be installed
Depends: gir1.2-cogl-1.0 but it is not installable
Depends: gir1.2-coglpango-1.0 but it is not installable
Depends: gir1.2-folks-0.6 but it is not installable
Depends: gir1.2-gee-1.0 but it is not installable
Depends: gir1.2-json-1.0 but it is not installable
Depends: gir1.2-muffin-3.0 but it is not going to be installed
Depends: gir1.2-telepathyglib-0.12 but it is not installable
Depends: gir1.2-telepathylogger-0.2 but it is not installable
Depends: gjs (>=1.29.18) but it is not installable
Depends: gnome-bluetooth (>=3.0.0) but it is not installable
Depends: libclutter-1.0-0 but it is not going to be installed
Depends: libcogl9 (>=1.7.4) but it is not installable
Depends: libgjs0- but it is not installable
Depends: libgjs0c (>=1.32.0) but it is not installable
Depends: libmozjs185-1.0 (>=1.8.5-1.0.0) but it is not installable
Depends: libmuffin0 but it is not going to be installed
Depends: caribou but it is not installable
Depends: cups-pk-helper but it is not installable
Depends: gir1.2-gkbd-3.0 but it is not installable
Depends: gir1.2-upowerglib-1.0 but it is not installable
Recommends: gnome-control-center but it is not going to be installed
Recommends: gnome-user-guide but it is not installable
Recommends: gnome-themes-standard but it is not going to be installed
Recommends: gnome-session-fallback but it is not installable

I don't know what to do next, I search the "gir1.2-clutter-1.0", when I select to install it, it says "Could not apply changes!
Fix broken packages first.", I click the Edit--fix Broken packages, but it doesn't work. I also use apt-get update && apt-get upgrade, but it also doesn't work out.

What wrong with this?????

Posted 2 years ago
Top