SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Geek Stuff

Linux - Frozen Xwindow

(6 posts)
  • Started 6 years ago by Zig
  • Latest reply from Liox
  • Topic Viewed 2581 times

Zig
Zig
Posts: 140

If your Xwindow freezes sometimes, here are two ways that you may try to kill your server. The first is the simple simple way of killing your X server the key combination: Ctrl+Alt+Backspace

The second way is a little more complicated, but it works most of the time. Hit Ctrl+Alt+F2 to startup a virtual console, then log in with your user name and password and run:

# ps -ax | grep startx

This will give you the PID of your Xserver. Then just kill it with:

# kill -9 PID_Number

To go back to your first console, just hit Alt-F1

Posted 6 years ago
Top
 
Liox
Posts: 3

You call that a solution ... it takes less time to wait for the freeze to go away than to short it out that way ...
Ubuntu or Fedora if it is a Laptop with dual core is gonna bloody freeze.
I cannot believe there isn't a solution yet!

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

That is just a way to handle a full crash not just something that freezes for a couple minutes.
Of which neither should happen that often.

Posted 6 years ago
Top
 
Liox
Posts: 3

Ok...sorry then, my fedora and Ubuntu freezes all the time on a laptop dual core! No solution yet, anywhere! The screen goes
grey, I disable compiz-fusion and still freezes.... arrrrgggg.

Posted 6 years ago
Top
 
jd2066
jd2066
Posts: 3814

You can try posting at the Ubuntu Forums.

Posted 6 years ago
Top
 
Liox
Posts: 3

Ok, found the solution on a Fedora forum, the continuous crash was due to pulse audio which had to be removed!

Posted 6 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Get Free Articles in Your Inbox!

Join 134,000 newsletter readers

Email:

Go check your email!