SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows Vista

(Solved) - laptop RAM upgrade not showing full amount in Windows.

(11 posts)
  • Started 1 year ago by oldgeezer
  • Latest reply from ispalten
  • Topic Viewed 1617 times

oldgeezer
Posts: 211

Dell Inspiron 1501 laptop running 32bit Vista. Original memory consisted of 2 x 512 Mb chips and both the BIOS and Windows displayed 895Mb available to the system. Ran the Crucial.com scanner and that advised could upgrade to a maximum of 2Gb so ordered & installed the 2 x 1Gb chips to replace the original ones, the BIOS shows 1.9Gb available but when Windows loads still shows only 895Mb. I've reseated them, swapped them around, tried 1 x 512 and 1 x 1Gb in all combinations and still shows 895Mb in both Control Panel/System and in CCleaner's header.

Ran the Crucial scanner again and it correctly identified 2 x 2Gb chips installed, so I'm now at a loss.

One point that may be important is that I'm running it off of a generic power supply - the battery is U/S - and at the moment I'm having to 'press any key' at boot because the system down't recognise the type of power supply. I've ordered a new one but I don't know if this will have any effect.

Anyone have any ideas?

Posted 1 year ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

Have had this before (and in fact you maybe be able to extend to 4GB (despite what Crucial says (and on Dell it's in the small print))) I bumped mine up to 3GB.
Run the hardware checker in Device Manager, and see what comes up.
btw, Dell used 2 types of motherboard. One accepts 2GB, and the other 4.

Edit. What does it say in Task Manager ?

Posted 1 year ago
Top
 
ispalten
ispalten
Posts: 6259

Doesn't 'compute'???

If BIOS sees it, so should Vista?

I assume you did check Vista's Max. Mem. setting? As I recall it was fairly well hidden, ah, found the place on another forum :

===============
Go to Start, type msconfig and press enter. Click on the Boot tab, then
advanced options. Check to see if the 'Maximum Memory' is checked.
Sometimes it is, and Vista will only "see" what is listed. Just uncheck
that and it should work great from there.
===============

Irv S.

Accepted Answer · Posted 1 year ago
Top
 
oldgeezer
Posts: 211

Task Manager displays 895Mb as well. Not too sure what you mean by 'hardware checker in Device Manager'. I'm running the Memory diagnostics from Admin tools at the moment, just to see if it kicks something into life.

Edit: I guess you mean 'scan for hardware changes' - shall do that when the memory checker's through.

Posted 1 year ago
Top
 
whs
whs
Posts: 17584

I think Irv is right. His method should work.

Posted 1 year ago
Top
 
Lighthouse
Lighthouse
Posts: 13598

Or in System, run the Refresh Now.

Posted 1 year ago
Top
 
oldgeezer
Posts: 211

"If BIOS sees it, so should Vista?"

Yes, that's what I thought, hence my confusion. I haven't come across the 'Max Mem' setting so I'll check that in a moment as well - what is the point of that, just out of interest, any idea?.

Posted 1 year ago
Top
 
oldgeezer
Posts: 211

No, the 'max memory' box is unticked. Tried the 'scan for hardware changes' & nothing altered.

Posted 1 year ago
Top
 
oldgeezer
Posts: 211

Just re-booted and I now have 1.9Gb!!!! - hooray!!!. Not too sure which was the fix but many thanks to all concerned - biggest problem now is which was the accepted answer???!!!

Posted 1 year ago
Top
 
whs
whs
Posts: 17584

I think you owe it to Irv.

Posted 1 year ago
Top
 
ispalten
ispalten
Posts: 6259

I think it was done as some special h/w can directly access RAM, and this parameter allowed you to set aside RAM Windows would not use.

Also some might have changed to be accessed to set differently it seems...

Check these links and they seem to implicate not only MSCONFIG, but BCDEDIT and BOOT.INI?

http://www.geoffchappell.com/n.....memory.htm
http://msdn.microsoft.com/en-u.....85%29.aspx

Irv S.

EDIT: Corrected last link

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!