Hi everyone!

I have two WD hard disks, which are both my Passport. Also, I have another WD, which is element'

Also, my windows is 7

The WD my passport hard disks contain folders and files(such as setup files for Smartware and manuals) came inside them from the factory. However, WD elements doesn't contain.

I have installed a program which came only inside the hard disk'WD my passport', but not WD elment. That program is 'WD smartware', which is used to make a backup automatically, earse the hard disk and let me see view quick of drives and other tasks.

Whenever I connected the drives, I saw this message below:(This file doesn't have a program associated with it performing this action)

However, when I connected another hard disk drive, which is from another company 'WD elments', I didn't see such a message. However, I see that the hard disk opens automatically with some options.

Why does the WD elments hard disk opens automatically with options below whenver I connect it. However, the WD my passport don't and I only see the error message of associations.

Moreover, when I erase the hard disk with WD Software associated with the WD my passport hard disks to make an automatic backup and other tasks. Then, I discounted and reconnected the hard disk to my computer, I saw that this windows contains options was shown::

NB: I have made a copy of these files to my internal hard disk before erasing the hard disk during WD Smartware which I installed from hard disk.

However, when I return again and put a copy of the files(files enlightened in this screenshot) coming from the factory in the hard disk. Then whenever I connect my hard disk, I see this error(This file doesn't have a program associated with it performing this action). Also, when I delete them, I saw the auto play opens well.

So I think that the problem is with the files came with My passport hard disks

Also, I made sure that I installed 'WD SES' which is used to enhance the deal with the WD my passport hard disks. 'WD SES DEvices', which is under the catogary 'WD drive management devices' in the device manager, is installed. However, there isn't WD SES Device' for WD elements hard disk.

Posted 1 year ago
Top