SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 8

hELP PLEASE

(5 posts)
  • Started 1 year ago by COREYFINCK
  • Latest reply from whs
  • Topic Viewed 359 times

COREYFINCK
Posts: 5

My mother spilled water on my laptop. Brand is Compaq Presario CQ60.
When i start the laptop i get a black screen that brings up font saying NO BOOTABLE DEVICE FOUND.
I have a windows 8 disk ready to install when i get to the point where it asks me to select the driver to install it says that it cannot locate drivers.
What is going on?
Thank you

Posted 1 year ago
Top
 
germ-x
germ-x
Posts: 5310

Appears the I/s got wet and now the HDD is not being reognized. Don't keep trying or you might "FRY" something and then you have a boat anchor.
Couple of choices
Take apart and try and dry components out
Take to a repair shop and see if they will do if you can't.
If still under warranty you might be able to get some assistance but don't count on it.

Posted 1 year ago
Top
 
COREYFINCK
Posts: 5

Ok thanks,
You think it would be feasible to just try letting things dry out?

Posted 1 year ago
Top
 
germ-x
germ-x
Posts: 5310

You can try setting in front of a small heater or sitting on a furnace register. Whatever you try "REMOVE THE BATTERY FIRST".
You want to just get it warm , not hot or you will damage something for sure. Let it dry out for one or two days.
If you can open it you can try a hair dryer set on warm. This will dry and liquid and blow away any large amounts of water.

Posted 1 year ago
Top
 
whs
whs
Posts: 17584

Let it sit for a few days and then try again.

Posted 1 year ago
Top
 



Topic Closed

This topic has been closed to new replies.