SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Build Your Own PC

first build completed

(10 posts)
  • Started 6 years ago by 0zSpitt
  • Latest reply from The Geek
  • Topic Viewed 1222 times

0zSpitt
Posts: 1037

i've completed my first build. i have ubuntu installed and i set the hard drive to boot first. BUT (we all have big buts) everything works perfectly except one tiny setting i cant figure out. i can't restart. i can shut it down and start it up and ubuntu comes on, but if i restart, i'll get the intel screen, then nothing. i have dual hard drives and dual dvd's if that has anything to do wiffit. but i'm sure it's a setting in the bios i'm not seeing.

Posted 6 years ago
Top
 
ScottW
Posts: 6609

Oz, tell us what motherboard you have so we can look for manuals or BIOS settings online. You are saying that a cold boot -- from power-off to powered-on -- works as expected and a warm boot -- restart from Ubuntu -- stops at this Intel screen. Is that right? What is this Intel screen about -- does it have a title?

Posted 6 years ago
Top
 
0zSpitt
Posts: 1037

the mother board is an intel D945GCNL. the intel screen has an intel logo and underneath says bios f2. and you are correct in the start/restart.

Posted 6 years ago
Top
 
The Geek
Posts: 2059

What kernel version are you using? Also, have you installed all the latest updates?

I found an ubuntu bug that seems to be related:
https://bugs.launchpad.net/ubuntu/+bug/218357

You should also make sure that the power management options are enabled in the BIOS, for instance full ACPI support should be enabled.

Posted 6 years ago
Top
 
0zSpitt
Posts: 1037

would kernel version be bios version? i read the ubuntu forum on intel, and i can't seem to locate the ACPI in my bios settings. i did all of this with your instructions you posted, thanks!

Posted 6 years ago
Top
 
0zSpitt
Posts: 1037

i found ACPI, but the only options are s1 state and s3 state. s3 was enabled from the factory

Posted 6 years ago
Top
 
The Geek
Posts: 2059

Your kernel version is what you usually see on the boot menu, or can be found by doing uname -r at the terminal prompt.

You might want to consider upgrading your BIOS, as that might provide fixes for the issue.

Also in the BIOS setup screen, you may also want to disable boot from network, as perhaps it's kicking into that mode for some unknown reason, although I can't imagine why.

Does the machine run fine for extended periods of time? If not, you should make sure that all your cooling systems are working effectively.

So to sum up:

1) Install all latest ubuntu updates with the update manager
2) Disable network booting in the BIOS
3) Upgrade your BIOS version with the flash utility from the manufacturer's website if necessary.
4) You could try changing ACPI to s1 state instead of s3... usually there's an ACPI 2.0 option.

Posted 6 years ago
Top
 
0zSpitt
Posts: 1037

sounds easy enough, i did try s1 state it didn't do anything. and thanks again.

Posted 6 years ago
Top
 
0zSpitt
Posts: 1037

i got it, i disconnected the second hard drive and second dvd drive. redid the bios and it works perfectly now. thanks again for your how-to series on building a computer

Posted 6 years ago
Top
 
The Geek
Posts: 2059

Glad you got it working!

Posted 6 years ago
Top
 



Topic Closed

This topic has been closed to new replies.