SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Microsoft Office

(Solved) - Excel 2007 error about stdole32.tlb missing or corrupt

(2 posts)
  • Started 4 years ago by StevePaul
  • Latest reply from StevePaul
  • Topic Viewed 32918 times

StevePaul
StevePaul
Posts: 99

I have Vista Home Premium at SP1 and Office Home and Student 2007 installed (originally at SP1), recently I have started to get the following problem...

When I open an Excel spreadsheet I get a pop up with 'stdole32.tlb in it.
Once I OK it, Office then proceeds to Reconfigure Excel,
This happens every time I open an Excel spreadsheet ...

My understanding (from what I've read) is that the stdole32.tlb file is either missing or corrupt; I've checked my system and there is no such file.

I don't know when this problem manifested itself as I haven't used Excel for some time now, however I can say that Excel was working OK previously.

I have uninstalled and reinstalled Office a few times now and the problem still remains.

I have also run Office Diags a couple of times all to no avail !!

I'm assuming this file is something that is installed as part of the OS ...

Nothing I've read suggests how to recreate this file, is it possible ?

Posted 4 years ago
Top
 
StevePaul
StevePaul
Posts: 99

Problem solved (knife and forked !!)...

As nothing was posted here (or anywhere else for that matter) I have come up with a contrived way of restoring the stdole32 file.

First find someone who has Vista installed (Home Premium in my case - not sure it makes much difference)

The stdole32 file (and stdole2) are in the Windows directory (various entries and various locations)..

Copy them to your computer in the relevant locations ....

Search the registry for entries (stdole) and copy them to your registry in the relevant locations ...

Can't guarantee it will work for you, but it worked for me !!

Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!