SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows Vista

(Solved) - DVD Drive not showing on computer

(8 posts)
  • Started 4 years ago by nkwe500
  • Latest reply from nkwe500
  • Topic Viewed 2935 times

nkwe500
Posts: 2

Hi,
My compuetr is not showing the DVD Drive. I noticed that other users have the same problem.
My computer is AMILO PI 2530 laptop
Vista Home Premium OS
Checced device manager as follows:
Device Manager
Optiarc DVD RW AD-7540A ATA Device Properties
General
Device status
Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)
Clicked Check for solutions. Nothing
Checked for updates on line. Came back as " you have the latest version"

Posted 4 years ago
Top
 
LH
LH
Posts: 20002

Try,
http://support.microsoft.com/kb/314060

Posted 4 years ago
Top
 
whs
whs
Posts: 17584

Here is some more by someone who has a similar problem: http://www.howtogeek.com/forum.....?replies=8

Posted 4 years ago
Top
 
matshidiso
Posts: 4

hi nkwe

with that errror code you need to uninstall that software and replace it with new software. the problem does not lie with your dvd drive it is with the actuall software that you loaded.

Posted 4 years ago
Top
 
Merlinpendragon
Posts: 1

I recently had this problem on a gateway. After doing some research I found that I had a corrupted registry. If you go to the Microsoft website they have a fix for this. They have 2 ways to do this. (1) a manual fix that you do yourself or (2) a little program ran from their website. It drove me up a wall to begin with because i keep looking at it as a driver problem but it was not. If I remember right it gave me an error code of 303. I went to microsoft support to find out what error 303 was and it directed me to the fix.

Posted 4 years ago
Top
 
carlozd
carlozd
Posts: 18

Hi nkwe.,

Before you use this a word of caution, you need to make sure that the DVD drive does not have any disks inside it. If the step is followed with a disk in the drive this will damage the drive and the only way to get it fixed would be to get it replaced.

Step 1 : Start >> Run >> Regedit >>Hit Enter OR click Start --> Type regedit in the Start Search (don't hit enter) so that it searches it and brings it up on the menu.

1. In Registry Editor, expand My Computer , and then expand HKEY_LOCAL_MACHINE .
2. Expand SYSTEM , and then expand CurrentControlSet .
3. Expand Control , and then expand Class .
4. Under Class , click {4D36E965-E325-11CE-BFC1-08002BE10318} .
5.

In the details pane of Registry Editor, on the right side, click UpperFilters .

" Note :: You may also see an UpperFilters.bak registry entry. You DO NOT remove that entry. Click UpperFilters only ".
• If you see the UpperFilters registry entry in the details pane of Registry Editor, go to step 6.
• If you do not see the UpperFilters registry entry, you still might have to remove the LowerFilters registry entry. To do this, go to "Step 3: Delete the LowerFilters registry entry."
6. On the Edit menu, click Delete .

Click Yes when you receive the following message:
Are you sure you want to delete this value?

Close the registry editor and restart your computer. Then check in the device manager to make sure that the drive is being detected normally. Generally the CD/DVD drive will be displayed with a yellow triangle with an exclamation mark. If the issue is resolved than it will show a normal display.

Posted 4 years ago
Top
 
LH
LH
Posts: 20002

WARNING.....Before you make any changes in the registry, back it up first !

Posted 4 years ago
Top
 
nkwe500
Posts: 2

Thank you to all for the help. I followed the link from LH's recommendation and although I tried the "Auto" repair it did not work. I eventually did the manual repair proceedure taking the advise to back up first and "Hey Presto"!!! it worked. Thanks again to all
Regards

Posted 4 years ago
Top
 



Topic Closed

This topic has been closed to new replies.

Enter Your Email Here to Get Access for Free:

Go check your email!