SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Linux

Drivers for ubuntu?

(16 posts)
  • Started 6 years ago by LifesSweetDrug
  • Latest reply from fastbullet
  • Topic Viewed 3563 times

LifesSweetDrug
Posts: 72

I have installed the new Ubuntu on a partition on my Dell Inspiron 6400n (came pre-installed with ubuntu ages ago). But I wanted the desktop effects, it use to work fine when I have run other versions of ubuntu before but with the new one it can't seem to find a driver or something. So it won't let me use any effects. It works fine for most other things.

Does anyone know where to find drivers if they are needed? I have googled a lot and posted on Ubuntu forums but no one has got back.

Thanks for any help.

Posted 6 years ago
Top
 
jack7h3r1pp3r
Posts: 2815

are you using on board graphics or do you have a video card?? if you have a video card you will need to goto their website and download the right driver for your card

Posted 6 years ago
Top
 
LifesSweetDrug
Posts: 72

It's integrated. I think it is "Mobile Intel 945Gm Express Chipset Family"/"Intel 82801G". If that means anything to you. I have tried installing some drivers but nothing seems to have happened.

Posted 6 years ago
Top
 
jack7h3r1pp3r
Posts: 2815

did you install the restricted drivers or the proprietary one. you may have to enable restricted drivers to get it to work. post back if you are still having problems

Posted 6 years ago
Top
 
raphoenix
Posts: 14920

LifesSweetDrug,
@Jack
http://www.intel.com/support/c.....022034.htm
May have to Enable Restricted Proprietary installation.
This will get you to the Intel 945GM Chipset Drivers to Download.

Try the Video Driver and Main Chipset Driver.

Won't need the Raid the Driver I don't think.

Kindest Regards,
Rick P.♦:)

Posted 6 years ago
Top
 
LifesSweetDrug
Posts: 72

I tried installing that driver but it got me nowhere =/ I don't know if it is still installed now.

Under the Hardware Drivers it tells me that I have no proprietary drivers installed. How do I enable it the restricted drivers? Because it might not be enabled :S

Thanks for your help.

Posted 6 years ago
Top
 
raphoenix
Posts: 14920

LifesSweetDrug,
******Ensure you install the Intel 945GM (Linux) Chipset Graphics Driver !!!!!
It is found in the drop down box under choose operating system in the link I gave you above.
http://intellinuxgraphics.org/index.html
-----------------------
After thinking about it and trying to remember when I was running Linux, I don't recall installing the Intel Full Chipset Driver on a machine.
Kindest Regards,
Rick P.♦:)

Posted 6 years ago
Top
 
jack7h3r1pp3r
Posts: 2815

i think that all you need to do is enable the proprietary driver. by going to system > administration > hardware drivers then just activate the driver by selecting the graphics driver and clicking activate

Posted 6 years ago
Top
 
raphoenix
Posts: 14920

@jack,
You did go here and see the Intel Latest Stable Graphics Drivers for Linux integrated video H/W ????

http://intellinuxgraphics.org/download.html

When I ran Ubuntu, all I was missing was the Proprietary Driver for the Linksys WiFi Card which was easily installed. Of course I had discrete Linux drivers for everything else except for fake-raid.
Promised everyone last week I would install and evacuate the new Ubuntu release last weekend but never got to it yet for this past week's events. (lol) (lol) (lol)

Kindest Regards,
Rick P.♦:)

Posted 6 years ago
Top
 
jack7h3r1pp3r
Posts: 2815

@rick you shouldn't even need to go there to get the drivers they should already be there when you load up ubuntu and do the updates and such. the only time i have had to get drivers from a manufacture was for my nvidia 8600gt video card but for all of the other on board drivers i haven't had to go else where to get them.

Posted 6 years ago
Top
 
raphoenix
Posts: 14920

@jack,

That is what I was saying (meant) except his video driver is integrated into the chipset unlike some video cards which have a discrete Driver of sorts.
Am like you, had NO trouble setting-up Ubuntu over a year ago but can't remember extactly how I did it and kept NO notes.
I'm posting from memory only and may be (WRONG) concerning everything so don't let me confuse the issue.
Will just watch topic and see how you guys work out the problem :) :) :)
Kindest Regards,
Rick P.♦:)

Posted 6 years ago
Top
 
jack7h3r1pp3r
Posts: 2815

well i'm not too sure on how to fix it if both options don't work and taking a visit into the ubuntu forums can be a task in it self haha

Posted 6 years ago
Top
 
LifesSweetDrug
Posts: 72

I did try using that intel driver before but it hasn't changed anything.

When I go in to the Proprietary Driver there is none there =/

It is strange because all the special effects and stuff works with other versions of Ubuntu that I have had before straight out the box.

Posted 6 years ago
Top
 
jack7h3r1pp3r
Posts: 2815

have you run any updates since your install? if you haven't you will want to run one and it should get you video drivers or you may have to goto the synaptic package manager and search for restricted drivers

Posted 6 years ago
Top
 
LifesSweetDrug
Posts: 72

I installed all the updates that were available, I think. All though I did get some error messages sometimes. Is there a way to see if all the updates are successful?

Posted 6 years ago
Top
 
fastbullet
Posts: 26

You say you just installed "the new Ubuntu" but don't bother to say if it is, in fact, v8.10.

I began using compiz in 7.04- it worked immediately and without trouble. 8.04, on the other hand, is a different animal, and I have never got Compiz to work in it, on either a Dell 4600 with integrated or on the Custom-built machine w/an EVGA 8400GS card.

Do not be surprised if it takes another 4 or 5 distro releases before they fix what they broke.

Posted 5 years ago
Top
 



Topic Closed

This topic has been closed to new replies.