SEARCH

The How-To Geek Forums Have Migrated to Discourse

How-To Geek Forums / Windows 7

Disk Defragment not working. How do I use Task Scheduler?

(21 posts)
  • Started 2 years ago by jocaan
  • Latest reply from Xhi
  • Topic Viewed 5189 times

jocaan
Posts: 20

Windows 7 Disk Defragmenter does not work. I get a message, "Disk Defragmenter cannot start because Task Scheduler service is not running. Start the Task Scheduler Service and try again." Well I was able to open up Task Scheduler, which I never used before but I do not see how to start Disk Defragmenter in that Service.
Frank C.

Posted 2 years ago
Top
 
ronniesonora
Posts: 919

Go to control panel- open administrative tools- click on (services) and then scroll down to task scheduler, if disabled double click on it and a window will open with a drop down menu to enable it.

Posted 2 years ago
Top
 
7ths0n
Posts: 29

I read somewhere that Disk Defragment on W7 is not important to do.

Posted 2 years ago
Top
 
jocaan
Posts: 20

Ronniesonora, ok, when I double clicked on DD it was not started, so I clicked on the Start button in DD Properties and the status changed to Start. However (so many times there is always an "However") the Apply button did not light up, it stayed grayed out. So I clicked ok, closed out and still tried DD but the same message still came up. In Services the Status of Task Scheduler is "Started." But the Status of Disk Defragmenter is blank. So then I double clicked on DD and then the above happened.
Frank C.

Posted 2 years ago
Top
 
Xhi
Posts: 6298

How are you going about starting the Disk Defragmenter? Are you going to Start->Programs->Accesories->System Tools->Disk Defragmenter?? If not try that. In Windows 7 you should not ever have to run it. It is automatic. Mine is set to run every Wednesday at 1:00am. I never have to touch it and as you can see I am 0% fragmented.

Are you one of those folks who when automatic drive came out in cars still insisted on shifting from D2 to D1 to D. Best advice... Quit screwing around with the disk defragmenter.

Posted 2 years ago
Top
 
vistamike
Posts: 10945

Windows 7 actually does handle defragmentation quite well without having to invoke it to run.
I have seen 7 defrag 'hang' after manifold MS updates. And that not really something to worry about to be quite frank because today I remain Mike(!).

However there is a better solution, if you really need to defrag; http://www.piriform.com/defraggler/download

You will only need the free version.

Mike

Posted 2 years ago
Top
 
Xhi
Posts: 6298

@Mike, Shirley, you jest!

Posted 2 years ago
Top
 
vistamike
Posts: 10945

Sheila, I jest not!

Posted 2 years ago
Top
 
ispalten
Posts: 6259

@7ths0n, yes, on W7 disk degrag isn't important, but the 'devil is in the details', it is because W7 does it for you via a SCHEDULED TASK, unless you have an SSD in which case it IS disabled.

@Jocann, there are service dependencies for Disk Defragger service, look at the Dependencies tab, DCOM Server Process Launcher and RPC Endpoint Mapper. Those both must also be running, are they?

When you opened Task Manager, did you 'drill down' to where the scheduled task would be? That is open Task Scheduler --> Microsoft --> Windows and then click on Defrag? Does it show a schedule and when run?

Irv S.

Posted 2 years ago
Top
 
jocaan
Posts: 20

Xhi, I usually go My Computer>C:>Right Click>Properties>Tools>Disk Defrag. When I follow your trail, I do not get the pop-up screen you show. Instead the error message I indicate comes on. I get the same error message when I go my way and click on Disk Defrag. In fact there is nowhere I get the pop-up screen you show. When I double click Disk Defrag in Services I get a Disk Defrag pop-up screen with General, Log On, Recovery and Dependencies tabs.

ispalten: In Task Scheduler there are these 6 Tabs- General, Triggers, Actions, Conditions, Settings and History. Under the History tab I have a red circled Exclamation Point showing Task Start failed (dated for today) and the Launch Code is "Launch Failure."
OK under your 'drill down' procedure it shows Defrag did run last Wednesday but I do not remember it running. Under the Conditions and Setting tab all the options are grayed out.
Frank C.

Posted 2 years ago
Top
 
ronniesonora
Posts: 919

jocaan, if you want a good defrag. use this http://www.filehippo.com/downl.....sk_defrag/

Posted 2 years ago
Top
 
Hermitt
Posts: 1310

jocann, just for S&G's run a "SFC /scannow" to fix any damaged system files?

Jim

Posted 2 years ago
Top
 
jocaan
Posts: 20

ronniesonora: It's not that I'm so hopped up about defragging my hard drive its just that if a part of my system is not working properly I do not want to go on indefinitely like that. I don't want one problem to be piled up on another. With that being sometime solved I do not mind moving on to a good defragging program as you suggest.

Hermitt, uh, could you explain? How do I run an "SFC /scannow" ?
Frank C.

Posted 2 years ago
Top
 
Hermitt
Posts: 1310

Directions on SFC /scannow...............
http://www.sevenforums.com/tut.....ecker.html

Jim

Posted 2 years ago
Top
 
Xhi
Posts: 6298

Start->Type in: cmd -> right click cmd.exe and select Run as Administrator. Type in sfc /scannow. Restart computer and try your problem again.

Posted 2 years ago
Top
 
ispalten
Posts: 6259

Frank, odd that the Task Scheduler shows it had run but you can't run it? Very odd???

Look at these links for some help (some echo what is here with more details) :

http://answers.microsoft.com/e.....7ee13b1904
http://answers.microsoft.com/e.....939b8d58a2
http://answers.microsoft.com/e.....7250597891
http://answers.microsoft.com/e.....fc00f67171
http://forums.mydigitallife.in.....ot-running
http://www.annoyances.org/exec.....1262758789

I'm sort of surprised how many 'claim' it is the A/V and once turned off it works fine? I've had no problem with Norton ISS's I've had/have on this computer?

Irv S.

Posted 2 years ago
Top
 
jocaan
Posts: 20

Hermit, I went to the sevenforums website and downloaded RegCleanPro. The free run did not change anything-same error message. I bought the 1yr subscription and ran the program again-I restarted first and then tried to Defrag. Got the same error message as above so the paid version did not change a thing. I'll try to call Systweek since they do show a phone number and see what happens but if not I will ask for a refund and go on my merry way and thank them for at least trying. One strage thing did happen in that my Firefox Browser does not work, has not worked for some time and I always get some sort of error message if I try to reinstall Firefox. Well when I run RegCleanPro my Firefox icon automatically shows up in my taskbar. When I click on the Firefox icon I get this message: "Your Firefox profile cannot be loaded. It may be missing or inaccessible."

Xhi, ok I went through the steps you indicate. A scan was run and completed after a while. The message at the end of the scan was: "Windows Resource Protection did not find any integrity violations." I then ran Defrag but the same old error message popped up.
Frank C.

Posted 2 years ago
Top
 
Lighthouse
Posts: 13598

Do not buy anything (unless we say otherwise), especially registry cleaners. You have just wasted your money.

Posted 2 years ago
Top
 
Xhi
Posts: 6298

Defragging is really not that important. Try the Piriform Defraggler, if you must, and forget this. It is really not worth the effort. Often times circumvention of a problem is the best, most efficient and most accepted method of fixing problems. Often as Technical Director of a large organization I would have some one call to say, "When I do thus and thus and thus it does not work. I was forced to answer, "well stop doing thus and thus and thus." Problem solved.

Posted 2 years ago
Top
 
raphoenix
Posts: 14920

jocaan,

Looking at the history of your problem postings, I'd suggest a Clean Install.

Running UniBlue did you NO favors awhile back.

Posted 2 years ago
Top
 



Topic Closed

This topic has been closed to new replies.